Windows 8 and 8.1 Forums


Can't install my Mobility Radeon HD 5470

  1. #1


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64

    Can't install my Mobility Radeon HD 5470


    Hey guys,

    I'm here again to address another issue that I'm experiencing. I've reached the limits of desperation and the only thing keeping me sane is the need to read your possible suggestions/solutions.

    I own a Sony Vaio (VPCEB4M1E) which came with Windows 7 and Mobility Radeon HD 5470. When I upgraded to Windows 8 Enterprise Evaluation, my Device Manager would show up my Display Adapter as "ATI Mobility Radeon HD Series 5000 - (Microsoft Corporation WDDM v1.20)

    When I first tried installing the driver I downloaded, the installation would finish in mere seconds (only installs 20MB of the files which isn't really helpful), giving me notifications of success. However, I knew it didn't install it, the screen didn't flash and well, the Device Manager didn't change its description at all. I had managed to find a solution by manually updating the driver through Device Manager. It worked great.

    I upgraded to Windows 8 Pro recently but ever since I was not able to use this method in order to get my driver properly installed. Whatever I try, I keep getting the "Windows detected that your driver is up to date, etc etc) and I still get the same Microsoft Corporation information. I tried disabling automatic drivers installation but didn't help either. This issue is driving me crazy.. I downloaded various drivers which I know would work, it's just that I'm not able or allowed to install them. The setup installation is faulty and the Device Manager won't let me do it either. If I try to uninstall the current Microsoft-provided driver, then I lose the whole Display Adapter category from the list, making it impossible to install the driver.

    Unless I manage to find some kind of turnaround for this, I'll probably have to do without proper drivers..

    Thanks in advance and for reading my thread..

      My System SpecsSystem Spec

  2. #2


    Quote Originally Posted by Wael90 View Post
    Hey guys,

    I'm here again to address another issue that I'm experiencing. I've reached the limits of desperation and the only thing keeping me sane is the need to read your possible suggestions/solutions.

    I own a Sony Vaio (VPCEB4M1E) which came with Windows 7 and Mobility Radeon HD 5470. When I upgraded to Windows 8 Enterprise Evaluation, my Device Manager would show up my Display Adapter as "ATI Mobility Radeon HD Series 5000 - (Microsoft Corporation WDDM v1.20)

    When I first tried installing the driver I downloaded, the installation would finish in mere seconds (only installs 20MB of the files which isn't really helpful), giving me notifications of success. However, I knew it didn't install it, the screen didn't flash and well, the Device Manager didn't change its description at all. I had managed to find a solution by manually updating the driver through Device Manager. It worked great.

    I upgraded to Windows 8 Pro recently but ever since I was not able to use this method in order to get my driver properly installed. Whatever I try, I keep getting the "Windows detected that your driver is up to date, etc etc) and I still get the same Microsoft Corporation information. I tried disabling automatic drivers installation but didn't help either. This issue is driving me crazy.. I downloaded various drivers which I know would work, it's just that I'm not able or allowed to install them. The setup installation is faulty and the Device Manager won't let me do it either. If I try to uninstall the current Microsoft-provided driver, then I lose the whole Display Adapter category from the list, making it impossible to install the driver.

    Unless I manage to find some kind of turnaround for this, I'll probably have to do without proper drivers..

    Thanks in advance and for reading my thread..
    Why not check Windows Update? Sometimes graphics driver update is there, sometimes in Important, sometimes in Optional.
      My System SpecsSystem Spec

  3. #3


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64


    Quote Originally Posted by MrShowdown View Post
    Why not check Windows Update? Sometimes graphics driver update is there, sometimes in Important, sometimes in Optional.
    I just did but there's nothing helpful in there. I check my updates on a regular basis and nothing relevant has came up. Thanks though.
      My System SpecsSystem Spec

  4. #4


    There's nothing wrong about having Microsoft Driver except if it's Basic Display Driver.

    EDIT: If you insist having a non-Microsoft Driver, go to amd.com.
      My System SpecsSystem Spec

  5. #5


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64


    Quote Originally Posted by MrShowdown View Post
    There's nothing wrong about having Microsoft Driver except if it's Basic Display Driver.
    Exactly, Microsoft drivers are always the basic ones. No performance whatsoever. Anyway, I fixed it, the only drivers that would work were from Leshcatlabs.net. Still sucks that I have to keep the 'Test Mode' watermark but it beats not having proper drivers installed.
      My System SpecsSystem Spec

  6. #6


    To get rid of the Test Mode Watermark, run this on an elevated Command Prompt:
    bcdedit /set testsigning off
      My System SpecsSystem Spec

  7. #7


    Athens, Greece
    Posts : 47
    Windows 8 Enterprise RTM x64


    Quote Originally Posted by MrShowdown View Post
    To get rid of the Test Mode Watermark, run this on an elevated Command Prompt:
    bcdedit /set testsigning off
    I tried it right after I noticed it was there and I think it messed up with my drivers in some way. Might give it another try later though. Thanks.
      My System SpecsSystem Spec

  8. #8


    Posts : 15
    Windows 8 64-bit


    I have this video card as well, and driver issues with it. After many issues, I disabled the Intel HD Graphics and I'm making due with just my HD 5470. The problem is I need to run some software which requires OpenGL, and it won't work. My graphic driver version is 8.97.10.6, which I understand is very outdated, but I'm afraid of updating, since when I had switchable graphics with Intel that resulted in me having to re-format.

    My questions:
    • Will updating my graphic driver likely restore OpenGL?
    • If I am to update how should I do it? ATI has a driver removal tool on their website, I could use that to delete the older graphics, but then should I manually install the drivers, should I update through Device Manager, or should I run it through Windows Update? Manual install might not work like Wael said, and Device Manager/Windows Update scare me.


    Thank you in advance

    EDIT: I'm using an Acer 3820TG with Windows 8 Pro 64-bit
      My System SpecsSystem Spec

Can't install my Mobility Radeon HD 5470
Related Threads
SONY is not providing windows 8 support for model VPCEB14EN. where will get windows 8 drivers for graphics card ATI Mobility Radeon HD 5470. I checked AMD website but not found and also Bluetooth BROADCAM drivers are also missing. Any help where to get?
Diver for “ATI Mobility Radeon HD 5470” for windows 8.1 X64, I couldn’t find the driver “ATI Mobility Radeon HD 5470” for windows 8.1 X64. My laptop is “Sony Vaio VPCE C3S0E” I tried the link below but unfortunately the AMD says that the available drivers are NOT compatible with SONY VAIO...
So i got an AMD Mobility Radeon HD 5470 1GB Graphics that is on all other TV´s having 1080p with HDMI or VGA. Now when i plug it in to my TV (Philips TX-L32C4E) it wont be 1080p just 720p. So when i turn it up to 1080p (yes i can) then my picture is getting too small and the textures terrible...
Hi! I have a problem with my Toshiba laptop as stated in topic. I decided to switch win7 to win8 and got stuck on this annoying resolution issue. I had no problem with it on win7 - I just had to uncheck the "show all modes" field and then choose 1920x1080 60Hz from the list. That's it - it...
when i play games some parts of a character is missing its very weired i installed the drivers but it does the same thing
hiiii i can't find ATI Mobility Radeon HD 3650 drive for my laptop DV5 ..... can any one gave it to me please ... i am search a lot of site and i can't find any think :cry::cry::cry::cry:
Hello I have dowloaded the drivers for ati mobility radeon hd 5000 series beacause the drivers not work Configuration: Msi cx 620 i3 330m ati mobility radeon hd 5470 Sorry for my bad english
Eight Forums Android App Eight Forums IOS App Follow us on Facebook