Windows 8 and 8.1 Forums


IBM T60 w/ ATI Mobile Radeon X1400 resolution issue

  1. #1


    Posts : 2
    Windows 7 Pro x64 and Windows 8 Professional x64

    IBM T60 w/ ATI Mobile Radeon X1400 resolution issue


    Hello,

    I have a IBM Thinkpad T60 with a ATI Radeon X1400 video card.
    The laptop has a T7400 Intel Core 2.

    I recently upgraded from Windows 7 Pro x64 to Windows 8 Pro x64.
    When I was running my Win7, I was getting 1680x1050 resolution.

    But now with the latest win8 and latest drivers, I can not get 1680x1050 anymore, instead I can only get 1440x900 resolution.

    Is there any way around this?

    Thank you for your time and effort.

      My System SpecsSystem Spec

  2. #2


    Unless IBM has a driver upgrade for the T60, probably not. AMD abandoned new drivers for that chipset a long time ago, and this summer, they also abandonded the HD 2x/3x/4x series. I have an HD 4290 and the latest AMD driver for it is the (now) Legacy 12.6 driver -- which was not written for Win8.
      My System SpecsSystem Spec

  3. #3


    New Zealand
    Posts : 23
    Windows 8.1 Pro, 32-bit


    Follow this lead and see if there is an option there for your card (I haven't tried it myself but seems to have worked for others).

    ATI Mobility Radeon X1600 graphics card Windows 8 driver missing

    1680x1050 for ATI mobility chipsets can be achieved but it requires a bit of patience and fiddling to get there.

    Please post back your results.

    Regards.
      My System SpecsSystem Spec

  4. #4


    New Zealand
    Posts : 23
    Windows 8.1 Pro, 32-bit


    Here is another thread that may be a helpful starter..

    ATI Mobility Radeon X1400 In DELL Inspiron 9400 on Windows 8 X64
      My System SpecsSystem Spec

  5. #5


    Posts : 2
    Windows 7 Pro x64 and Windows 8 Professional x64


    Thank you for your time Mark, I appreciate your input and explanation.
    Ashleyg, I will take a look at the links you have provided and give a try tomorrow before work. Thank you very much!
    I will let you know how it goes.
      My System SpecsSystem Spec

  6. #6


    Posts : 1
    Windows 8 Pro


    Hi stoli,

    I have good news! I have a working driver installed! Thanks to "Minalte" of this Microsoft thread ATI Mobility Radeon X1600 graphics card Windows 8 driver missing who discovered this process for his x1600 card!

    I also have a T60 (T7600) with the x1400 video card, now running W8Pro beautifully. My screen resolution is now back at 1900x1200. I can watch online content such as Youtube, Hulu etc. and DVDs using PowerDVD.

    Essentially, I installed Microsoft's latest (Windows 7) driver for the x1400 as follows:
    [For some reason Windows Update does not retrieve it automatically].

    Go to the Microsoft Update Catalog at Microsoft Update Catalog

    Search for "Mobility Radeon X1400"

    Cab-files for the latest (2008) Windows 7 drivers for x86 and AMD64 architectures should be listed at the top. (Click on the file's title to get a description).

    Download the AMD64 driver cab-file. (Should be the second one on the list and larger in size).

    Extract it using 7-zip or other.

    Use Device Manager to manually install this driver (i.e. Choose "Let Me Choose" > "Have Disk" and point to folder with extracted files. Install it.)

    You should be good...


    Quote Originally Posted by stoli View Post
    Hello,

    I have a IBM Thinkpad T60 with a ATI Radeon X1400 video card.
    The laptop has a T7400 Intel Core 2.

    I recently upgraded from Windows 7 Pro x64 to Windows 8 Pro x64.
    When I was running my Win7, I was getting 1680x1050 resolution.

    But now with the latest win8 and latest drivers, I can not get 1680x1050 anymore, instead I can only get 1440x900 resolution.

    Is there any way around this?

    Thank you for your time and effort.
      My System SpecsSystem Spec

IBM T60 w/ ATI Mobile Radeon X1400 resolution issue
Related Threads
I have a Samsung ATIV Book 8 with Windows 8.1 and it's been working beautifully for months now, but Device Manager is saying "Windows has stopped this device because it has reported problems. (Code 43)" in the Device Status window about my AMD Radeon HD 8700M Series driver. I've already checked and...
Hello there, I just installed Windows 8.1 x86 on my old notebook Dell Inspiron 6400 and there is a problem in regards to universal search. I suppose that is the graphics card matters because sometimes when I try to wright something I can't see any letters that I type and other times it show some...
Hello, I have a issue with Windows since I updated from 8 to 8.1. I tried googling my issue and cannot find anything about this. I have contacted MS but they won't help me without paying a fee. So I'm hoping you can help. When I go to resolution on Windows 8.1 it shows the resolution as...
Recently upgraded to Windows 8.1 on my Dell Inspiron 570 with an ATI Radeon HD 4200 graphics card. I can't get the resolution to go any higher than 1600 x 1200 - would prefer to go to 1980 x 1024. Please help!!!!
Hi guys, I have an ACER 3820TG-482G50nss notebook, which should have a switchable Radeon HD 6550M GPU. My problem started yesterday as I upgraded my OS from Windows 7 to Windows 8 Pro (it was not a clean upgrade as I did not want to re-install all the programs back to my computer). After I...
Hi, this is my first post!. I've been trying to install my old ATI X1400 in W8 With no Success.... After days of thinking, I installed W7 X64 and the drivers in CCC 9.3 modded as you can read in this post: ATi Mobility x1400 Build 7100 x64 - Windows 7 Forums It worked, but then I updated my...
This worked for me: Downloaded the R153383 driver package from Dell. Right clicked on it and selected Properties. Clicked the Compatibility tab and selected Vista Sp2 and clicked OK. Ran the installer and I have aero graphics. System Inspiron 9400, 32 Bit Windows 8
Eight Forums Android App Eight Forums IOS App Follow us on Facebook