Windows 8 and 8.1 Forums

Is it just me or does W8 not like giving people administrative access?

  1. #1

    Is it just me or does W8 not like giving people administrative access?

    Every time I try to copy a file or save a file it says that I need to provide administrative access or something, and it has a little admin shield icon next to continue, and 75% of the time it works, 25% of the time it keeps looping that window. I searched the actual message when I first installed W8 and someone provided a link to a script that installed in the windows folder (yeah I know, sounds safe!) and it added something to the right click menu that says "Take ownership" and when I do that to the folder it stops giving me the popup. But I don't have time to do that to the millions of files and folders on my first hard drive, let alone my storage hard drive. Is there some general way to fix this?

    I still have it in my context menu, I was just asking if there was a faster way to do it to all the folders/files on my computer. It took over 4 hours to do it to my program files x86 folder, and I have another hard drive to do still and every other folder in the first one.
    Last edited by Brink; 03 Jul 2012 at 11:10. Reason: merged

      My System SpecsSystem Spec

  2. #2

    Posts : 636
    Windows 7/8

    This would have been a LOT easier if you had (and in the future you should) transfer your user account from the old machine to the new machine. Then the permissions would be the same on both machines and no "take ownership" would be necessary.

    In the future, use the "Windows Easy Transfer" to transfer your user account to a drive or thumb drive or a network drive (Can also save your mail, browser settings and more if you want) then after the new machine is set up, import the user account there. Makes things like this 1000 times easier.
      My System SpecsSystem Spec

  3. #3

    Posts : 22,576
    64-bit Windows 10

    Hello Naphthalene,

    It's strongly not recommended to take ownership of these system folders or drives. It could cause unknown issues.

    Instead, you might consider enabling the built-in Administrator account, and sign in to it when you want full access to everything.

    Hope this helps,
    Last edited by Brink; 03 Jul 2012 at 12:13.
      My System SpecsSystem Spec

  4. #4

      My System SpecsSystem Spec

  5. #5

    Posts : 22,576
    64-bit Windows 10

    You're most welcome.
      My System SpecsSystem Spec

Is it just me or does W8 not like giving people administrative access?
Related Threads
Hello, Few days ago I have installed Windows 8, but found that there is no sound, windows can't detect audio card. I tried to find audio drivers for my card, but they don't work in Windows 8. After that I found some ways to fix this, but these ways were not helpful. After that I found only thing...
Enable full administrative power in User Accounts and Family Safety
I am the only user of my pc and When ever I install a program they asks administrative permission not only for that but for everything. I need to make my PC full administrative power and never ask me for open as administrator or anything. And also I dont want to see that administrative icon in my...
Hi.I am using Windows 8.1 Pro.I turned on bitlocker on one of my drives to secure it.i used fast method.after the encryption process the drive became inaccessible and giving access is denied messages.I tried to turned of the bitlocker but i cant because it just vanished.i cant find it anywhere on...
Hello, I have a lot of problems with installing different application like Adobe Reader, Microsoft Mathmatics, it keeps saying I don't have permission to write to ProgramData. I have tried giving myself adminsitrative rights through the security tab and using the tool Take Ownership. It...
hey guys i recently upgraded to windows 8, and for some reason within the control panel, i click any options that have the admin shield icon next to them, when i click them, absolutely nothing happens and i cant delete any folders from programdata/program files/x86 because it "requires...
Hi, I recently got a data plan for my HTC One S. The wireless hotspot that came with it will work on my family's iPods, iPad, and our family laptop, but not on my Toshiba laptop with Windows 8. I have tried my dad's iPhone's wireless hotspot, and it works on my laptop. When I try my hotspot, my...
Microsoft Is Giving People $100 Coupons For Standing In Line For The Surface Source A Guy
Eight Forums Android App Eight Forums IOS App Follow us on Facebook