Desktop asus crashed it is 8.1 (upgraded from 8) and after an error update to W10 (horrible nothing was working) then I went back within 2 days to 8.1. (mentionning this as I saw maybe this could have corrupted my partition^)

This week I got a black screen on start up and could only go into bios or recovery cd.after 1 week of different try and misses Im coming here hoping you will solve my problems :now I am desperate.
Have recovery cd. but auto repair doesnt work: says drive is locked. recovery gives another error messages ie I think to run ckdsk (did it via CMD and also with lazesoft which couldnt complete as it says drive locked). Reset gives a required drive partition is missing.tried several things such as lazesoft but it couldnt complete as it says drive is locked. but it read my files. I copied my documents(only as I dont care anymore) that were necessary for my life(ie WORK) the rest at this point I dont give a damn.would rather keep my job then videos or else!
after searching the net at work I did also all this:
tried several cmd commands (diskpath, ckdisk,(which does mention no error ) and bootrec too.
Folllowed some info on link that I was provided with no luck too:
Was told to also try asus bactraker. its downloaded (on my xp laptop)but I cant make it work on cd on asus. I got the files. burned them on cd and nothing happens. nowhere on internet it mentions how to make it work on cd.

I did unplug hard drive and waited a bit, and no luck

help help help, need to have access asap, refersh to factory I dont give a damn I just need it to work.

I just installed Ubuntu based on another thread help. and it loaded correctly and now I am back on my asus via Ubuntu so I can now answer promptly as I have internet again!

BUT MY goal is to fix Microsoft. Either without loosing my software or files OR by restoring to factory. (so how to do that without sending to Asus(not on warranty anymore) (and should I remove Ubuntu or will it do it when restoring^)

Right now I will not dare to shut my computer until it is solved. took me a week to get back access to it(should have done UBUNTU faster!)

Manufacturer: Asus
Model: M11bb-ca002s
OS: Windows 8 64 bits
CPU/Ram: AMD Quad-Core A8-5500 3.2GHz/ 6gb 1600MHZ