Windows 8 and 8.1 Forums


Remote Procedure Call Error in Windows 8.1

  1. #1


    Posts : 1
    Windows 8.1 64bit

    Error while using metro in Windows 8.1


    I am using Windows 8.1 and occasionally use the 'metro' or 'modern' functionality built into it to take a peek at my system settings.
    Today when I tried to open "Add or remove devices" or "Windows Update Settings", a full screen window displaying a gear pops up for a moment and then disappears followed by an error message which states:


    THE REMOTE PROCEDURE CALL FAILED

    Click image for larger version


    It had something to do with my account possibly as I could see my username and its associated data followed by the critical error.

    That's not all, I could not open "Change PC Settings" too. Now this wouldn't seem to be much of an issue as it would be possible to handle it via the traditional way of accessing control panel.

    If I remember correctly, the remote procedure call is a critical system service but I assume it has nothing to do with this, will it?

    Any idea on how this error occurred and means to rectify it without performing the dreaded system reset?
    Last edited by ashwyn; 28 Feb 2016 at 22:52. Reason: Title Change

      My System SpecsSystem Spec

Remote Procedure Call Error in Windows 8.1
Related Threads
Remote Procedure Call in Performance & Maintenance
I am running windows 8.1 and have had my computer since April 2014. Since about January, every few days RPC goes from using no memory to using all my 12 GB of memory in about a few seconds, then either a get a message that there was an error and the computer restarts or everything freezes and i...
Hi im new here and this is my first post. I am a MCP, MCTS, MCSA, N+, and A+. This is not for work its my personal PC. I have been having a problem with Windows 8.1 Pro for a few months now. Every time windows, java, drivers, or anything updates and the PC is restarted, after login, it acts...
Hai guys, i found this error when i launch call of duty ghost. i have try to update VGA card driver and instal direct but nothing change. it's alway happen again. Please help me, how can to do for fix this problem...:( you can look this rar file for the direct error...
Hi, I have windows 8 64 bit and I try to install to my pc, but when at the end of installation I obtain a "registration requirement". when I try to call the number for insert the my ID (try to insert the various group of number), at the second group the voices freezes and I cannot continue, can...
I Im getting an error when trying to add a components it says visual basic 6.0 object library not registered and underneath that it shows c\window\syswow64\mscomctil.ocx, how can i fixes this I have tried a lot of programs to fix the registry error fixes , but it still dose not work. What can I do...
when i try to run the game error dialog box appears saying : C:\Program Files\Activision\Call of Duty 4-Modern Warfare\mss32.dll is either not designed to run on windows or it contains an error. Error Status 0xc00012f Please help. . :cry:
Read more at: Microsoft: Don't call it Metro. Call it 'Windows 8' | ZDNet
Eight Forums Android App Eight Forums IOS App Follow us on Facebook