Windows 8 and 8.1 Forums


PC Doesn't Boot. No Beep - No Display - CPU Fan spins

  1. #1


    www.RLSARC.xyz
    Posts : 16
    Microsoft Windows 8.1 Pro 64-bit 9600

    PC Doesn't Boot. No Beep - No Display - CPU Fan spins


    Hi everyone! I have a Asus P8H61-M LE, x2 2 GB RAM, and i5 Processor.

    When I power on my pc, the cpu fan spins, the green mobo light is on, no beep, and no display on monitor.

    when i eject the 2 ram and power on again, still no beep.

    please help, thanks!

      My System SpecsSystem Spec

  2. #2


    If you don't get any beeps with all ram removed then it's either a mother board problem or a PSU problem. Do you have another PSU you can try?
      My System SpecsSystem Spec

  3. #3


    www.RLSARC.xyz
    Posts : 16
    Microsoft Windows 8.1 Pro 64-bit 9600


    Quote Originally Posted by Ztruker View Post
    If you don't get any beeps with all ram removed then it's either a mother board problem or a PSU problem. Do you have another PSU you can try?
    ahm, first of all. how to put the speaker in the mobo? should the speaker label face in the ram slot or face in the reset switch?

    i mean the speaker in the reset sw, power sw, hdd and power led.

    //i'll try another psu as soon as i can find one. thanks!
      My System SpecsSystem Spec

  4. #4


    Did it ever work or is this a new build?
      My System SpecsSystem Spec

  5. #5


    www.RLSARC.xyz
    Posts : 16
    Microsoft Windows 8.1 Pro 64-bit 9600


    Quote Originally Posted by Ztruker View Post
    Did it ever work or is this a new build?
    Been using this pc for 5 yes.
      My System SpecsSystem Spec

  6. #6


    You've been using it for 5 years but never connected the speaker? No beeps without a speaker for sure. I think I'm missing something here.
      My System SpecsSystem Spec

  7. #7


    www.RLSARC.xyz
    Posts : 16
    Microsoft Windows 8.1 Pro 64-bit 9600


    Quote Originally Posted by Ztruker View Post
    You've been using it for 5 years but never connected the speaker? No beeps without a speaker for sure. I think I'm missing something here.
    I've plug out the speaker to clean the mobo. When I plug it in, I forgot what should be the correct position of the speaker.
      My System SpecsSystem Spec

  8. #8


    AH, now I understand.

    The manual for your motherboard is here: P8H61-M LE R2.0 | Motherboards | ASUS Global

    Click image for larger version
    Click image for larger version
      My System SpecsSystem Spec

  9. #9


    www.RLSARC.xyz
    Posts : 16
    Microsoft Windows 8.1 Pro 64-bit 9600


    Quote Originally Posted by Ztruker View Post
    AH, now I understand.

    The manual for your motherboard is here: P8H61-M LE R2.0 | Motherboards | ASUS Global

    Click image for larger version
    Click image for larger version
    Not that audio #13. Got problems with #9 system panel connector. Top right 4 pin mobo speaker.

    BTW, I bought new PSU just now and try it but same problem, no error beep w/o the ram, CPU fan spins, no display. What is the the problem? Does CMOS has to do w/ this or the mobo it self?

    I badly need my PC to finish my project, please help.
      My System SpecsSystem Spec

  10. #10


    Posts : 1,121
    Windows 8.1 x64


    Have you changed anything inside? Any chance the 4 pin power cable was dislodged?

    New CPU .. maybe?

    I would probably disconnect all devices and see if you can even get into the bios.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
PC Doesn't Boot. No Beep - No Display - CPU Fan spins
Related Threads
I am typing this on my old computer. I wanted to put my new computer (which is a windows 8 hp desktop) into safe mode because i thought i had a virus and wanted to go into safe mode to see if i did. So i select the option to go into safe mode in the computer (i did the msconfig option being that...
I hope someone has enough OneNote experience to help me solve that. The thing is that when I copy-paste a webpage into OneNote (using 2013 version) everything is displayed properly. However after a system restart the previously pictures disappear and only text is left. See the screenshot: 51410...
Hello, I would like to ask a question about my desktop here. After upgrading to Windows 8.1, I noticed that there has been a problem with my display. It doesn't happen everytime, but randomly, when the computer is idle for 10 minutes and the screen is automatically turned off, it won't turn back on...
Hi guys, just found out this place, seems to be a good forum so I try it here. Last night I got hold of a 27" BenQ GL2750HM, so far so good. I have my main display from the DVI port to HDMI port on the screen and my secondary screen is my 60" TV which is connected through HDMI port on the...
Windows 8 metro Music app just does not display my music. As you can see, my music folder is included in the music library: http://i.imgur.com/zL50Siv.jpg but yet the Music app only recognizes two songs out of 1000+ that I own http://i.imgur.com/ystzPuP.jpg Windows media player, the...
Hi There, I have a brand new HP Envy dv7 (2 weeks old). I'm running Windows 8. I've read some similar posts on this board, but nothing that exactly fits my problem. Sometimes, not all the time, when my laptop goes into sleep mode I am unable to wake it without pressing power for 5 seconds to...
Hi I'm posting this to see if anyone else is experiencing this and if it's a Windows 8 issue. While using Windows 8 I've noticed that if I leave the computer on and not do anything on it the fan will start up and spin really fast. As soon as I move the mouse and start using the the computer it...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook