Windows 8 and 8.1 Forums


No Operative System boots. I deleted EFI Partition

  1. #11


    Posts : 12
    Windows 8.1


    Yes you are right. Previously the EFI partition was in the HDD and that handled the original Windows 8.1 and the Windows 8.1 that I installed in the SSD. Is there any way I can put that EFI partition in the SSD drive to boot like I tried? I will try your advice and repair the EFI in the HDD also, but I want to know if there is a way I can do what I asked you, that was actually why the EFI partition was deleted.

      My System SpecsSystem Spec

  2. #12


    Posts : 2,690
    Windows 3.1 > Windows 10


    shut down and remove HDD
    shrink the Partition on the SSD by 228MB
    diskpart
    list disk
    select disk # Note: Select the disk where you want to add the EFI System partition.
    list partition
    select partition # Note: Select the Windows OS partition or your data partition.
    shrink desired=228
    create partition efi size=100
    format quick fs=fat32 label="SYSTEM"
    assign letter="Q"
    create partition msr size=128

    bcdboot C:\Windows /s Q: /f UEFI
      My System SpecsSystem Spec

  3. #13


    Posts : 12
    Windows 8.1


    Thank you so much for your help. i have these three partiotions as in the picture do i still need to shrink the primary partition or can I use the ones I have already.
    Click image for larger version
      My System SpecsSystem Spec

  4. #14


    Posts : 879
    Windows 10


    Quote Originally Posted by DRFUTTER View Post
    i have these three partiotions as in the picture do i still need to shrink the primary partition
    No.

    First, try to fix the current EFI System partition.

    bcdboot X:\windows Note: Replace "X" with the volume letter of the Windows OS partition.

    - Here is more info: https://technet.microsoft.com/en-us/...or=-2147217396

    If that doesn't work, then recreate the EFI System partition.

    - How to create the missing EFI System partition. -> link

    How to delete the EFI System partition.

    diskpart
    list disk
    select disk #
    list partition
    select partition # Note: Make sure to select the EFI System partition.
    delete partition override
      My System SpecsSystem Spec

  5. #15


    Posts : 2,690
    Windows 3.1 > Windows 10


    you can use the 3 partition you already have,, follow as above post..

    Note: the EFI partition would be the 260MB partition
      My System SpecsSystem Spec

  6. #16


    Posts : 12
    Windows 8.1


    Thank you very much! I tried the mix of genet advice and KYHI advice and now th windows from the SSD is booting normally. However I still have one problem, I removed the HDD disk to complete the process, but now that I put it back I cannot access from windows, t is not being recognized. Please help me with this last part.
      My System SpecsSystem Spec

  7. #17


    Posts : 12
    Windows 8.1


    Hello guys, KYHI or genet can you please help me with the problem I am having that the HDD drive is not being recognized in Windows.
      My System SpecsSystem Spec

  8. #18


    Posts : 2,690
    Windows 3.1 > Windows 10


    Go into disk management - is it there ??
    use diskpart > list disk - is it there ?
      My System SpecsSystem Spec

  9. #19


    Posts : 12
    Windows 8.1


    It is does not appear in the disk management. and when I used the cmd inside Windows to list disks with diskpart it doesnt show either.
      My System SpecsSystem Spec

  10. #20


    Posts : 12
    Windows 8.1


    Hello guys, I solved it. First I went to check if in the BIOS the disk was recognized. And it did appear there. After booting I checked the Disk Management again and voila!! the disk was there. Thank you very much for all your help, especially KYHI and genet, I really appreciate it. This forums are the best thing we have as users, it gives us the chance to ask experts such as you when we get frustrated about a problem I tried several forums and online searches but nobody gave me a staright answer and support like in here. We can mark as solved and close this topic.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
No Operative System boots. I deleted EFI Partition
Related Threads
BSOD on New Build Shortly after System Boots in BSOD Crashes and Debugging
I just completed a new build. Shortly after the desktop loads it will BSOD. It's ever at the exact same time and there are a few different BSOD errors. It will usually happen once I try to run something. For example I went to download the Windows 10 upgrade in Windows update and it did it and...
So a few weeks ago I was screwing around with partitioning my HDD trying to get around some bad sectors that I had picked up in a chkdsk. In the process I accidentally deleted the System Reserve partition, so naturally now my windows wont boot. I've tried downloading a recovery disk but this didnt...
(Windows 8.1) I have seen a problem quite like this. IE is not my default browser. I uncovered this due to an application that is hard coded top open IE. When I open IE nothing happens. When I enter a url it just sits there like it is not connected to the Internet. No errors, nothing. When I...
Running Windows 8, the system boots into a user account without login. The launcher seems to work, I can bring up the desktop. From the desktop I cannot launch any programs, other than a non-admin DOS window- but from there I can't launch any other non command.com EXE. When I try and run any...
Hello I recently took my hard drive out of my laptop, and plugged it into an external USB drive to copy some files to another laptop. Upon putting the hard drive back into my laptop, windows 8 would no longer boot. It would get to the Operating System select screen (I also boot Win 7 on this...
Following a number of good tutorials I installed Windows 8 on a Samsung Series 7 tablet from a bootable USB thumb drive. I created a vhd on a 64 GB micro sdhc card. I was able to choose this vhd as the installation location and Windows 8 appeared to install as expected. However, when the system...
now i cant boot my win 8 i have dual boot with ubuntu so when i try to boot win 8 i get error massage that there is no such partition (because he try go find sda0 but cant) i try to insert usb with win 8 but i get that i need to insert repair disk how i can boot win 8 without reserved...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook