Windows 8 and 8.1 Forums

Error: "Missing operating system. No bootable device"

  1. #1

    Posts : 1
    Windows 8.1

    Error: "Missing operating system. No bootable device"

    For reference: Acer Aspire v15 Nitro running Windows 8.1

    I made a mistake. A friend gave me a USB drive and I wanted to format it, but the USB was actually broken and didn't show up. What I thought was the USB was a drive with a name containing the word "Pushbutton". I formatted it and the computer ran fine until I restarted it. Upon restart, I am getting the error:

    "Missing operating system.
    No bootable device -- insert boot disk and press any key"

    I've been working on this problem for a little while and at first suspected I messed up the MBR. I loaded the windows 8 startup disk on a USB and ran various repairs to no avail (including bootrec stuff in the command prompt).

    I have no idea what I did. I know all of my files are still in there somewhere. I didn't do anything to the main disk or partition. I think I formatted some kind of partition that is related to booting up the OS.

    I'm not sure if this changes anything, but my hard drive is full disk encrypted using VeraCrypt.

      My System SpecsSystem Spec

  2. #2

    I don't know about VeraCrypt, but with MS encryption, you need an extra BOOT partition that is not encrypted. Perhaps that is what got clobbered.

    If you have access to another working PC, then you should download the Minitool Partition Wizard Boot CD and make a CD or USB stick from it. To make a USB stick, you'll also need to download RUFUS and use that.

    Once you have that, boot your machine and see what partitions are on the drive.
      My System SpecsSystem Spec

Error: "Missing operating system. No bootable device"
Related Threads
I'm pulling my hair out trying to figure this one out. I'll try and explain my setup as its a little more complex than others. I use my PC in my room as a media server (Tversity), I connect to my Xbox One in my den using a power line adapter/wireless access point, It has worked in the past but for...
Hi I reinstalled windows 8.1 on my Samsung NP530U3C-A10EE. And now the problem this that I can't boot it without usb stick that contains windows installation files. I can boot up windows and remove the usb stick evertything is working perfectly, but if I try to boot up win without usb, it gives...
I have a Dell XPS 420 and I've just bought an SSD for it. Every time I boot the machine I see "Operating system wasn't found" now, despite having booted into Windows successfully just before. The only change I made was connecting a standard SATA 2TB drive - which it boots into fine - but now...
I have a multiple operating system and used to get the blue graphical boot menu with a rectangle with the name of each operating system in it. After a few boots it went back to the text menu, and only returned a couple of times. Is there a way to get the graphical boot menu back permanently? It...
Solved "Missing Operating System" in General Support
I'm selling my PC and long story short I went through thorough steps to ensure that I didn't leave any traces, I didn't do a clean OS install or format because I had a digital copy of windows 8 via upgrade and after using CCleaner to free space, uninstalling unneeded software, and manually removing...
Not sure if it's Lenovos only, but trying to migrate Windows 8 OEM to an SSD has been a huge pain in the ass. This process should not be as difficult as Lenovo/Microsoft has made it. I purchased a Y400 along with a 256G SSD. I'd like to clean install Windows onto the SSD, I did not want to copy...
Hi, I recently got an Exopc, and they had set it up as a dual-boot, with Windows 7 64-bit and Window 8 customer preview (32bit). When I initially got it, and powered it on, I'd get the blue, graphical "Choose your operating system" page, and I initially chose to go to Win8. Later, I chose...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook