Windows 8 and 8.1 Forums


Help needed with unusual internet problem and upgrade to10

  1. #1

    Help needed with unusual internet problem and upgrade to10


    For a long time, I had issues using the internet on my ASUS Windows 8.1 laptop. Browsing would be very slow with a lot of lag and if I were to type something into the search bar it would take some time to respond.


    A few months ago I managed to get around this problem by changing some setting (I think to do with power management but unfortunately I can't really remember). I use the software (that came with the laptop) power4Gear Hybrid and when the power setting is on 'Performance' web browsing is fine, but when it is on 'Battery Saving' it reverts to the original problem. When I'm using the laptop on battery I have to manually change the power setting to 'Performance'.

    I want to upgrade to Windows 10 but am worried that it will revert to the original settings and since I can't remember how I fixed it am concerned the problem may return. However I am wondering if the upgrade to Windows 10 will actually fix the problem completely. I had previously reinstalled Windows 8.1 in an effort to fix the problem but it had no effect.


    Also worth noting is that when I change all the settings (eg USB selective suspend) on the 'Battery Saving' mode to the same as 'Performance', this makes no difference and web browsing under 'Battery Saving' is still slow.


    Any advice would be greatly appreciated

      My System SpecsSystem Spec

  2. #2


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Stick with 8.1. Too many issues are rearing their head on 10, as people are using it. Video lagging is the biggest problem, the other is no compatible drivers for hardware that works with 7 & 8.
      My System SpecsSystem Spec

  3. #3


    St. Augustine
    Posts : 388
    windows 8.1 64, LT -Windows 10 Home 64


    Quote Originally Posted by broe23 View Post
    Stick with 8.1. Too many issues are rearing their head on 10, as people are using it. Video lagging is the biggest problem, the other is no compatible drivers for hardware that works with 7 & 8.
    I am in 100% agreement !

    If you think you have problems now, check out the 10 Forum. It seems even those that are happy with W10 are having minor issues. I have been running W10 on my HP Notebook (my secondary machine) since 7/29 and IMO it is not quite ready for prime time. It will be a long time before I move to W10 on my primary system.
      My System SpecsSystem Spec

  4. #4


    Quote Originally Posted by broe23 View Post
    Stick with 8.1. Too many issues are rearing their head on 10, as people are using it. Video lagging is the biggest problem, the other is no compatible drivers for hardware that works with 7 & 8.
    Ah right, cheers. Out of interest how long do you think it will be until most of the bugs are ironed out and its worth updating?
      My System SpecsSystem Spec

  5. #5


    St. Augustine
    Posts : 388
    windows 8.1 64, LT -Windows 10 Home 64


    Quote Originally Posted by jamesmerlin View Post
    Ah right, cheers. Out of interest how long do you think it will be until most of the bugs are ironed out and its worth updating?
    Depends on how fast MS addresses the issues. I would think at least a couple of months. I suggest you regularly browse the W-10 Forum to get an idea of the ongoing problems and the frequency of those problems.
      My System SpecsSystem Spec

  6. #6


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    Did the upgrade to 10 on my ASUS K75DE. No such issues. I don't use Power4gear though. I wiped the factory install and did a clean install of Windows 8.1 shortly after I got it. I chose not to reinstall Power4gear, along with a lot of the ASUS bundled utilities.. I just let ccc handle my switchable graphics.
      My System SpecsSystem Spec

  7. #7


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Alpha it is a hit or miss. I have run into resource hog on those machines we did an upgrade from 8.1 to 10. Cannot do a Clean install, because of certain software that has to stay.

    Videos has been an issue since 8, but mainly on older hardware. Now we are seeing it on newer hardware, regardless of the browser.

    I am looking at maybe six months before hardware mfg catch up on all of the driver fixes.
      My System SpecsSystem Spec

  8. #8


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    All I can tell you is I did 4 upgrades and no issues. My desktop PC's are long in the tooth too. One is an old Athlon II system. I don't mess with my systems though. No third party menu, reg hacks, or other similar tweaks. Not saying anybody here has, just saying, if you did, it can cause upgrade issues. What works for one OS may not work on the next. YMMV.
      My System SpecsSystem Spec

  9. #9


    Yes I upgraded an Z97 MB home built, I had a month or so clean install of 8.1 and run the upgrade from windows double clicking the Setup.exe
    I had Classic shell already on this machine upgraded to the latest version. I only have a couple of minor issues that I have noticed so far. Still I won't upgrade my other computers for some time. Edge seems to be a waste of time I guess its a Metro App rather than desktop program. My start and task bar and desktop are pretty much as I had them on 7 and 8.1. All main software works Office 2013 did some upgrade installs of there own everything stayed activated. CS4 all seems to work I have only check out Acrobat and Photoshop
      My System SpecsSystem Spec

Help needed with unusual internet problem and upgrade to10
Related Threads
Forced upgrade help needed in General Support
Recently I was forced to upgrade my Window 8 pro computers to 8.1. After the upgrade I no longer have the pro version with the new 8.1 OS :mad:. What is the remedy to this issue. I purchased the pro options for Win 8 but find no path to Win 8.1 Pro other than another purchase. Your advice and...
In 25 years of computing I have never encountered what I'm encountering currently with Windows 8.1. It's even difficult to explain it, but I'll try. One example: I go to Control Panel, click on "Sound", the window opens, and as it's displaying the info, everything scrolls up and vanishes. If I...
Greetings computer Gods and technology Wizards. I have been getting intermittent internet connection problems after my computer "automatically" upgraded to windows 8.1 It occurs at very random times and I don't really notice a "trigger" that starts it to happen. I've taken screenshots and will...
Dell true to form has made the cmos non-upgradeable for use with WIN8. So, with regrets, I need to know what motherboard, cpu and sound cards, memory, etc, I will need in order to upgrade this elephant. :dinesh: Then of course, I need to know if my graphics card, NVIDIA GeForce 6200, power...
On my all-in-one Dell inspiron I've noticed the sound is significantly higher when I have a device plugged in, whether it be my bamboo tablet or my phone, unplugging them during playing audio, I'd suddenly hear the sound drop a good 5-8 decibels(aka about 20-40 on the volume bar) and it doesn't...
Hey guys, About 3 months ago I installed windows 8 pro through the upgrade assistant, pretty sure I had the deal where it wad about $40? Basically I had to get my hard drive replaced as it broke now im back to the stock windows 7, and in desperate need of getting windows 8 back, but im not...
I have an unusual problem in General Support
How do you shut the blasted thing off?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook