Thanks for looking.

This problem has been driving me crazy, presumably since I got the SSD, 'though since I mostly suspend the computer, I wouldn't have noticed initially, which is why it took me so long to narrow it down.

The issue is as the title describes, but here are more details:

  • The computer will receive power.
  • The BIOS and OS become unavailable, intermittently. (no display on either, 'though it wakes the monitors)
  • The HDD light flashes only a few times.
  • The displays come on from their suspend modes.
  • I've tried resetting the BIOS.
  • I've flashed the BIOS; it's current and making no difference.
  • Having the USB devices in or out makes no difference to the problem.
  • I've checked the RAM, using different DIMMs and different lanesóno difference.
  • I've scoured the BIOS settings a number of times and cannot find anything out of place.
  • Windows 8.1 boots perfectly fine as well. (provided AHCI mode is enabled in the BIOS)
  • Suspending in Windows always works; it seems to entirely get around this issue.
  • I have no speaker, so I cannot report beep codes.

Welcome to ideas, 'though I fear I've tried it already. However! The reason I've said it's the SSD, is due to what I've just now experienced: I unplugged the SSD, and it booted up just fine, minus an OS, but once I plugged the SSD in again, it booted up, on par with what I had previously done as a temporary "fix".

Until now, I've had to unplug one or a few of my SATA cables from the motherboard (doesn't matter which socket the SSD is in) in order to get the computer to boot. I'll then restart it, either forcefully or within Windows. Once that's done, I'll boot again with the SATA lead reconnected, and all will typically be fine, until perhaps the next time I have to cold-boot or restart from Windows.

I'm pretty decent with computers, myself, having troubleshooted all sorts of problems over the years, so I'm trying to anticipate your questions. One thought I had, was that the PSU is failing, but that honestly makes no sense to me, because it's not old, it's of very good quality (Corsair TX750 Enthusiast Edition, I believe) has never had enormous amounts asked of it, I've never heard coil whine or any other noises from it, the fan works perfectly fine, I've enver smelled anything dodgy from it, and while gaming, both high and low, there's absolutely no problems typically associated with a failing PSU, such as freezes, crashes, and reboots.

I considered my CPU being at fault, but a similar deal as above: I have no issues with stressing the CPU and there are no signs that the CPU is having issues. The CPU has never overheated, currently sitting at mostly idle between 31 and 34 degrees celcius. The CPU was properly seated with pre-applied paste, which I know can be lackluster, but in this case it seems to have been perfectly fine.

Before today, I had arrived at the conclusion that the problem was the motherboard (ASUS Z97-K, only a few months old, like the CPU) which I assumed because:

I've flashed the BIOS twice (official source) and, despite all seeming to have gone well, something may have gone awry without me knowing. Since I've had the motherboard, the "EZ Mode" of the UEFI BIOS will freeze if I tried to move around the boot order, 'though this always worked via Advanced Mode so I let it go. (that particular problems still persists) Also, since the BIOS wasn't displaying and not allowing me access, I assumed the BIOS or motherboard itself was at fault; a false conclusion, I presume. I guess I'm still trying to get around to the whole UEFI thing; it seems to work quite differently.

I shan't type much more because I don't want this thread overlooked by people not keen on reading tons. Thank you for your time.