Windows 8 and 8.1 Forums


GWX.EXE - api-ms-win-core-heap-l2-1-0.dll missing

  1. #1


    Posts : 220
    Windows 8.1 Pro X64

    GWX.EXE - api-ms-win-core-heap-l2-1-0.dll missing


    Hi,
    I set up a dual boot Windows 8 & 10 system by initially setting up a dual boot with two Win 8.1 systems and then upgrading one to Windows 10.
    Now I find that the Win 8.1 system fails at start-up with a message from GWX.EXE:-
    "api-ms-win-core-heap-l2-1-0.dll missing"
    And that's as far as it goes. I've tried a number of dodges but there is just no way I can get into the 8.1 system so it looks like none of the normal repair options are available.
    I have tried the repair option from my 8.1 install disk but that takes me nowhere.
    I also tried recovering the 8.1 system from a backup but the problem remains.
    Since my Win 10 system can see the Win 8.1 disks, would it be possible to take advantage of that to fix the problem?


      My System SpecsSystem Spec

  2. #2


    Where can I download that dll file
    I really need it
      My System SpecsSystem Spec

  3. #3


    That file is part of the old update to win10 so you dont want it as the free upgrade has gone How to remove the Windows 10 GWX upgrade nonsense
      My System SpecsSystem Spec

GWX.EXE - api-ms-win-core-heap-l2-1-0.dll missing
Related Threads
Hi, I have two laptops made by the same manufacturer and same year, but one is a dual core laptop with an SSD harddrive and the other is a quad core laptop with a regular hard drive. Both laptops run Windows 8. I would like to transfer my programs and files from the dual core to the quad core....
Hi guys. I've been looking at 2 laptops, they are basically identical but one has an Intel Core i3-4005U mobile processor and 4GB of RAM, and the other one has an AMD A4-5000 mobile processor and 6GB RAM. The guy at the store and a couple other people I know told me that the Core i3 is better than...
I canīt install MVS on my Windows 8.1 due to missing core libraries. I've tried 2010, 2012 and 2013 versions and same error occurs anyway. I have a valid license and I have no idea how to solve this. Thanks
Hello all, I just did a clean install of Win 8 Pro x64 and I was surprised to find that the installation had defaulted to running with (or using) only 1 of my 2 logical CPU cores. The fix was to use msconfig to activate the 2nd core as shown in the image below: Processors - Limit Number Used...
I have installed windows 8 x64 consumer preview. Under the task manager performance, Im only seeing one cpu graph, and it reports one physical processor and two `logical` processors. Also under device manager, when I get the properties for `Computer` it says acpi x64 based pc, I think older...
Title says it all. Before I installed Hyper-V, Windows shows all 8 threads. . . After, only 1, and VMs were definately sluggish. Has anyone else had this issue or know how to fix it? This Windows 8 pre-release would otherwise be perfect for me as it's the only way I can have Hyper-V AND my internal...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook