Windows 8 and 8.1 Forums


BITS Service won't start Error 0x80070002

  1. #1


    Posts : 3
    Windows 8.1 Build 9600

    BITS Service won't start Error 0x80070002


    Hi guys,

    I have a nasty problem on Windows 8.1

    My BITS Service won't start (and therefor Update, Store, etc are all down).

    Event log shows two error events;

    The BITS service failed to start. Error 0x80070002.
    The Background Intelligent Transfer Service service terminated with the following service-specific error:
    The system cannot find the file specified.

    Addditionally another error appears every now and then:
    The ScRegSetValueExW call failed for FailureActions with the following error:
    Access is denied.

    I've tried so far:
    wsreset.exe
    Windows Update Troubleshooter -> first few times it just said it coudn't fix my problem, now it just hangs on starting BITS
    sfc /scannow -> no errors found
    Microsoft FixIT for Win Update
    System Restore
    Refreshing the image using DISM
    I checked all the registery keys for BITS with another build 9600 pc and made them matching, no effect.
    I cleared the Data Store folder and restarted Win update serv, no effect on BITS

    Any thoughts?
    Last edited by DutchWolf114; 13 Jul 2015 at 16:47.

      My System SpecsSystem Spec

  2. #2


    Posts : 3
    Windows 8.1 Build 9600


    Sorry for doublepost, found a possibly related error in event log:

    The server {4991D34B-80A1-4291-83B6-3328366B9097} did not register with DCOM within the required timeout.

    Source: DistributedCOM
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    OS X 10.10


    The ScRegSetValueExW message is a reasonably common error message, and one that can usually be safely ignored. I've noticed it when installing or uninstalling software and is related to an application trying to access a portion of the registry it shouldn't be.

    Have you tried a malware scan on the machine? BITS is a fragile service at times - given the file not found message, it might be worthwhile trying to start the service whilst running Process Monitor (available from TechNet, previously a Sysinternals product) to see exactly what Windows can't find.
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    Windows 8.1 Build 9600


    I have ran a virus check with Panda. I'll try the process monitor a try and report back.

    EDIT: I've never used this program, what exactly am I looking for?
      My System SpecsSystem Spec

BITS Service won't start Error 0x80070002
Related Threads
Greetings everyone, I've been struggling for the last 24 hrs with this. I first decided to perform a "PC Refresh" due to some instability. It turns out this operation removes all programs I had previously installed (I didn't know that, it's my 1st time dealing with win8). So I thought I'd just...
When I try to uninstall a program called, "Sony Improvement" I get the following error: "An error (-5005 : 0x80070002) has occurred while running the setup." I tried the Microsoft troubleshooter to fix uninstalls/installs. But that doesnt work. What do I do now?"
Hello! This is my first time asking for help; thank you for your time. I have an Asus N550JV laptop with windows 8. It has been working great the last year, but after a recent windows update, my audio completely stopped working. After running the troubleshooter, it stated the following: ...
The system log shows The Group Policy Client service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion. That tells me nothing. I can use the computer because I am the administrator, I can access files, programs, etc....
Windows 8.1 Error: 0x80070002 in General Support
Hi there, Since recently upgrading to Windows 8.1 for free via the Windows Store, my computer has not got "blue screen" but has frozen a couple of times which has forced me to turn off my computer either at the wall or by holding the power button down. This has happened about 3 times now since...
Hi Everybody, After updating to Windows 8.1 update 1 BITS Will not start. I have been unable to install the latest windows updates for about 1-2 months. When I try to start the service it says:"Windows cannot start BITS on local computer. For more information view the system event log. If this is...
Solved Cannot Install error code 0x80070002 in Installation & Setup
So i wanted to dualboot windows 8. I did the disk partition and downloaded the iso image 64 bit. Burned it and boot it up. Followed the setup and when it was intalling it gave me this error. It says: Cannot Install required files. Any suggestions?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook