Windows 8 and 8.1 Forums


USB Devices Don't Work in Windows

  1. #1


    Posts : 3
    Windows 8.1

    USB Devices Don't Work in Windows


    Hi All,

    So, I turned on my computer this morning and ran into a fairly significant issue - none of my USB devices will work. That means no keyboards, no mice, no nothing. I've tried about a half-dozen keyboards and mice, and none of them work. I've plugged them in before they were started up, after windows was booted, and into every port in the computer (including the USB 2.0 port directly on the motherboard).

    But here's the really, really weird part - when I boot into windows, the devices stop working entirely, including in the UEFI startup screen. The only way to get back into the UEFI menu is to press the CMOS clear button. Then, the keyboard works until I boot back into Windows, at which point it's completely useless and won't even light up.

    I'm running Windows 8.1 on an Asrock Z87 Extreme 6 motherboard.

    It's also worth mentioning that I was having some trouble where my new Corsair keyboard wouldn't work until I logged in, which had to be done with the mouse, but this is very different. Those issues went away a couple of months ago, and I haven't had anything like that since.

    I don't have a PS/2 keyboard on-hand, or an adapter, so I'm at a bit of a loss there. I also obviously can't login to the computer, so I'm not sure how to work on any drivers or anything like that.

    Thanks for any help!

      My System SpecsSystem Spec

  2. #2


    What USB devices are plugged in? Is it only mouse and keyboard? If you have any other devices plugged in, unplug them for now and see what happens. If that doesn't help you may be looking at having to reinstall 8.1.

    If so, you can get an ISO here to burn a install DVD or create a USB flash drive to install from: Windows 8 and Windows 8.1 ISO - Download or Create

    With the above, you can also try a System Restore from a booted DVD or flash drive:

    See:
    OPTION SEVEN

    Boot to Advanced Startup Options from Windows 8 or 8.1 Installation Media

    here: Startup Options Menu - Boot to in Windows 8
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8.1


    Everything is unplugged except for 1 keyboard at a time. I tried to boot into the windows 8 CD I have, but I have the same issue with my various keyboards not working as soon as I hit the windows CD screen, and I have to clear the CMOS.
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Maybe BIOS corrupted? Sure sounds like a weird problem.
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    Windows 8.1


    I also cannot boot correctly into an arch live USB. The keyboard fails to connect properly, then it tries to mount the live USB to the OS, which also fails, and implies to me this is more of a motherboard problem.
      My System SpecsSystem Spec

USB Devices Don't Work in Windows
Related Threads
I have checked everywhere online, and I haven't found a single explanation for this. I have 3 user accounts. 1. Administrator 2. initial user 3. new user So the initial user is the one you are forced to create when first setting up Windows 8.1. It's a local user meaning that I set it up...
My friend happened to look in Devices and Printers, and in the Multimedia Devices section he had about 10 devices showing up that he never heard of. Six of them were computers with names that he had never heard of, the others were devices that we could not tell what they were. I expect that...
An automatic update occured, and a blank box popped up continuously(Titled: C:/swsetup/sp59654/IDTSetup.exe) I was using my USB headset during that update, then all of a sudden they stop working and only my speakers were working, and no devices were being shown under playback devices nor under...
Alright guys, Windows update has been really messing with my pc lately. I ran update and when it installed the updates my integrated mouse ended up not working. I rolled back update and installed the updates one by one and the one I ended up not installing was the camera codec pack. Now the problem...
Alright guys, I have just refreshed my pc because I was having numerous problems with it and it turned out to be a bad stick of RAM. However, now I am having software issues. Whenever I try to make a call on the desktop version of skype, the program crashes. Whenever I try to open HP support...
After upgrading to 8.1 all of my previously listed devices are no longer listed under devices... in fact there are no devices listed. I can also not add a device. If I look in device manager they are listed there and if I go to print the printer shows up and I can print. The screenshot below...
I have a sony vaio vpcf12thx/h 64x 4gb I7 nvidia 310m I upgraded from w7 ult to win 8 x64 pro. Whenever I put a usb device such as a flash drive or an external hard drive in any of my usb ports they wont show up under computer, the autoplay doesnt pop up, nothing. I hae gotten the external hard...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook