I have what I imagine is a fairly strange error related to booting other Operating Systems and their interference with Windows.

So I have an ASUS zenbook UX32VD, where I have replaced the original HDD with a Samsung SSD. The laptop came with Windows 8 which I upgraded to 8.1. Everything has been working fine until one day I tried booting Linux from a CD (via an external CD drive connected by USB). Booting Linux was fine, but when I tried to boot Windows again I got:

"Error 0000x225: cannot find Winload.efi" (not the exact text, but something similar). I couldn't access Windows at all, so all I could do was go back to BIOS.

After a lot of Google searching, I found that that I could fix this with a Windows 8 recovery CD and apply the following in Cmd Prmpt:

bootrec /scanos (Returns Successful)
bootrec /rebuildbcd
bootrec /fixmbr
bootrec /fixboot
Then Windows will boot normally. The same issue and fix occurred when I tried to boot Linux again.

What's really strange is that this happened a third time; when I made a bootable Windows 8 on USB 3.0 (got tired of borrowing my friend's recovery disk). I tried to make sure my USB worked (it did), but my normal Windows version had the 225 error again. Worst thing was that I couldn't repair it from my USB 3.0 version of Windows since (even though it loads), the USB 3.0 is not recognized by the recovery and therefore bootrec /rebuildbcd cannot find the proper files.

My main question is: Why is this happening? Why would booting a different OS from a CD/USB cause the Windows on the SSD to encounter this error? Can I fix this? Also, is it possible to have a recovery Windows on a USB 3.0? (I don't think so based off on other threads).

Ideally I would like to be able to boot Linux from a CD without crashing my Windows. Any ideas?