I have done a bit of searching on this, and tried everything that i could. But the few threads i found pertaining to this exact problem required individual fixes. I would consider myself pretty good with computers, but this is over my head and i just cant figure it out.

As the title states, i use the sleep function constantly - and all of a sudden 2 days ago this problem started. Relatively new build, about a month old.
Login screen is usually there for about a second before it goes back to sleep, usually it is an endless loop that can only be stopped by turning off power supply switch and fully restarting, although sometimes after the second try it will restart on its own.

I have looked through event viewer and i can not find any one thing that gives an error every time i put it to sleep, its easy to test - happens every single time i put it to sleep, immediately. Although i am not an expert and could be missing something. Also from what i can tell a minidump is only created when the computer restarts itself - not every time it resets to sleep or even when i turn the power off.
I have tried -
Unplugging all usb devices.
Restoring default power schemes
Updating windows
Restoring default bios settings.
Disabling hybrid sleep mode.
Ran troubleshooter on power, no issues other than screen saver on.
Turned off hibernation.

also i was getting an lgdcore.exe error in event viewer regularly so i completely uninstalled the logitech gaming software that my mouse and keyboard uses with no difference

asus z97-ar
asus strix gtx970
crucial mx100 ssd
corsair ax760i pwr
crucial balistix memory 8g

The only things that i know were changed this week were
New monitor (asus rog swift)
Nvidia drivers were updated
Although i do not believe the problem started near either one of these two things i could be wrong.
Also i just uninstalled the nvidia driver and installed the older version with no change