Hey guys,

I shut my computer down two nights ago and when I started it back up, I'm getting the reboot and select proper boot device or insert media message.

I have cruised through numerous forum topics that addressed this, however none of the solutions has solved my problem.

What I have currently attempted:

Switch out the boot options on the bios
Tried booting in legacy only
Used the windows 8 installation disk repair
Tried the bootrec on cmd prompt
Reset my bios, by removing the CMOS battery

and a few others that I just can't remember after eight hours of trying.

A few questions that I have are:

1) Is this a motherboard problem if it performing the POST?
2) Is it a hard drive problem? Some of the options I tried I gained limited sight of my windows files and they are all there, but could it still be a hard drive problem?
3) Could the boot files be corrupt?

When I tried the self repair it diagnosed and attempted to fix but cut to the screen that said it couldn't repair and gave me a blank log file.

I'm pretty much at a loss right now. I don't have extensive computer knowledge but can follow directions and navigated what made sense to me.

My motherboard is a Gigabyte GA-970A-DS3P

Any help or a push in any direction would be helpful thanks.