So I have a 2TB hard drive in my desktop at the moment that has permissions issues. A while ago I had a hardware issue with my computer where my SSD did not play nice with my Z77 motherboard at the time (kind of a long story, sometimes my SSD wouldn't show up in the BIOS, and BIOS updates never fixed it, and it wasn't the SSD's fault because the SSD worked fine in other computers and my new motherboard). While I was waiting for a new Z77 motherboard to ship, I installed Windows 8 onto my 2TB WD Green drive that I had previously used for mass data storage.

So now that I no longer use the HDD as a system drive, I've had trouble copying files to the drive. Specifically, if I try to copy files to the root of the drive, Windows will tell me I don't have privileges ("a required privilege is not held be the client"). I can only copy folders to the root of the drive. I tried messing around with the permissions and ownership, and tried using my third HDD's permissions as a reference, but still have copying issues.

Is there any way to solve this without reformatting the entire drive?