Windows 8 and 8.1 Forums

Problem copying files to USB drive or stick

  1. #1

    Posts : 1
    Windows 8.1 pro

    Problem copying files to USB drive or stick

    Hello, when copying files to any usb drive or stick, I often (but not always) get an error message: 'The semaphore timeout period has expired'. When this happens, windows explorer just freezes till I disconnect the drive. Sometimes I can give it another go after reconnecting, but sometimes I have to restart the system as explorer won't react any more. This also recently messed up the file system on my external USB 3 drive, as it was not shut off properly.

    It does not happen all the time and seems to occur randomly. Usb 2 or 3 does not make any difference. Also it happens that when trying a second time the same file gets copied without any problem. Or not.

    I hope someone can give me a hint about how to get this problem solved, it's driving me crazy. I can't find anything helpful online. I already reinstalled Windows 8.1, tried different usb drives and sticks, tried different ports, but all to no avail. I am not sure since when this problem occurred, I guess somewhere between 6 to 8 months. After all this time I still don't know how to reproduce the problem, but it seems to get worse...

    Please help...

      My System SpecsSystem Spec

  2. #2

    By the Ocean
    Posts : 177
    Windows 8.1 Pro x64
      My System SpecsSystem Spec

Problem copying files to USB drive or stick
Related Threads
I have the Tuff N Tiny - Verbatim 8GB memory stick. Similar to this one: I was copying some files from Windows 8.1 to a Mac OS X, did all safe removal stuff. But then plugged it into Mac and ... nothing. Plugged it again......
Hi, i bought a Micro SD Card 32GB from eBay. Im trying to copy files to it so i can transfer them from my PC to my Laptop, however whenever it finishes copying files and i plug it into my Laptop, it needs formatting. I have tried copying files to it and them plugging it back into my PC but it says...
Okay, here are the simple instructions from "Windows 8 for Dummies" (p. 109): So I insert a blank CD into my new Dell Inspiron's D drive. Nothing happens. No "Notification box" or anything else appears in the screen's upper-right corner. So what am I supposed to do, please?
Can someone help me? I finally got a CD to work in my new Dell computer. The files on the CD that I want to copy onto my computer are shown listed on the Windows 8 desktop or rather whatever the page is called that shows "Library," "Documents," "Music," etc. But there is nothing that shows me how...
Hello everyone, Recently I've been following the news about the latest windows 8 (pro) tablets and I'm very interested in buying an asus transformer book (if they finally decide to release it...). Now, on my main pc and laptop, I still use windows 7, so I don't exactly know how windows 8 works...
Hi All, I have been having an issue with Windows 8 RTM (N Version). I get BSOD everytime I try to copy files to an external hard drive (1 TB Seagate Freeagent). I was trying to copy 500 GB of data, but it keeps failing with a BSOD. I have also tried copying files in smaller sizes (20 GB each),...
Stuck at copying files in Installation & Setup
So I downloaded the Release preview from Microsoft website. I burn it onto a DVD and boot it, but when it got to copying files, it stucks at 95% and won't go further. What might happen?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook