Windows 8 and 8.1 Forums

Error Installing a Print Driver - Happens every boot up

  1. #1

    Posts : 86
    Windows 8 Home Premium

    Error Installing a Print Driver - Happens every boot up


    I have been having problems with my computer ever since I hooked my Wireless Printer up to it. The error I am trying to fix right now is in the event viewer, every time I boot my machine I get the error below 4 times.

    I do not know why I keep getting that error, and I really would like it fixed. The thing I do not understand is that the printer works fine, I tell it to print, and it prints. However, I always get an error message on the computer saying it was unable to print. Even thought I have the documents right here.

    The Printer is a HP Photosmart with ePrint. I only turn the printer on when I need to print, and I would like the computer to only communicate with it when I need to print. I found that if I disable the Print Spooler Service, the problem is fixed. The issue is I need to Print Spooler to print, so its not worth turning off.

    Log Name: Microsoft-Windows-PrintService/Admin
    Source: Microsoft-Windows-PrintService
    Date: 1/27/2015 9:26:50 AM
    Event ID: 215
    Task Category: Installing a printer driver
    Level: Error
    Keywords: Printer Setup,Printer
    User: SYSTEM
    Computer: Jimmy-PC
    Installing printer driver - failed, error code 0xBC8, HRESULT 0x80070BC8. See the event user data for context information.
    Event Xml:
    <Event xmlns="">
    <Provider Name="Microsoft-Windows-PrintService" Guid="{747EF6FD-E535-4D16-B510-42C90F6873A1}" />
    <TimeCreated SystemTime="2015-01-27T14:26:50.250209200Z" />
    <Correlation />
    <Execution ProcessID="1664" ThreadID="3120" />
    <Security UserID="S-1-5-18" />
    <SetupInstallPrinterDriver xmlns="">
    <Message>Unable to find core dependency (see additional info for driver GUID)</Message>
    <ProcessorArchitecture>Windows NT x86</ProcessorArchitecture>
    <PackageAware>Package aware</PackageAware>

      My System SpecsSystem Spec

  2. #2

    Posts : 86
    Windows 8 Home Premium

    Any ideas?
      My System SpecsSystem Spec

  3. #3

    Yeah I have ideals...check to see if HP is loading anything during startup, if so, remove it from starting up and see if the error goes away. Also, look at the following folder and see if there are any files inside the folder: c:\windows\system32\spool\printers - if you see any files in that folder, delete them, as they could be an old print job that never finished and could be trying to print to a printer that doesn't exist. If there are files you will need to stop the spooler service before deleting: net stop spooler, then delete the files, and then net start spooler (from an elevated command prompt). Hope this helps.
      My System SpecsSystem Spec

  4. #4

    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit

    May I know the model of the Photosmart printer?
      My System SpecsSystem Spec

  5. #5

    Posts : 86
    Windows 8 Home Premium

    Nothing is in Startup pertaining to the printer, I did go into Autoruns and disable a few things there from the printer. Nothing was in the Print Spooler folder. The printer is HP Photosmart D110 Series. Just took a long time to access "Control Panel > Hardwear and Sound > Devices and Printers". Was loading devices and printer for a long time, wondering if the issues are related.

    I will restart and see if disabling those things helped.
      My System SpecsSystem Spec

  6. #6

    Posts : 86
    Windows 8 Home Premium

    Shockingly enough, after rebooting a few different times I found the errors stopped. I have one more issue as well now that this one is taken care of. Just like the printer issue, I am getting another Error in event viewer every boot up. This one is "Distributed COM". I have googled it with no luck. Its Event ID 10016 and I will paste the details below. Also, should I make a new thread? Thanks to play2mefish and Nuccii by the way.

    The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
    and APPID
    to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
      My System SpecsSystem Spec

Error Installing a Print Driver - Happens every boot up
Related Threads
so i keep getting 8 of these at the same time a few times daily my parents got an old limax printer which is connected to the wifi but ive never used nor will i. ¨does anyone know how i can stop these errors from constantly comming=? example of error - Installing printer driver Microsoft...
I have a Gigabyte BA-B85N Phoenix Wifi rev 1.1 motherboard, so when I try to install the WLAN driver off of Gigabyte's website, I get to the install screen and get "error update.cpp 1185". I have tried letting windows install the driver through device manager and opening the local folder, but to no...
I have a fairly new PC computer running Win 8 64bit. Initial setup went off without a hitch. Wireless printers and such all worked fine. Now, I select "print" from Microsoft Word, or Notepad, or any program for that matter, nothing happens, i.e. no print que, no printer page, nada. My...
when i try to install a driver for the serial port PCI i get this error message : " Windows found a driver for your device but encountered an error while trying to install, installation of this device is forbidden by system policy. contact your system administrator . " knowing that i am the...
yesterday I got annoyed by win 8 on my Samsung NP900X3D and I started to instal windows as I normaly used to do on my older laptop...and here the problems started: - as the ultrabook doesn`t have a optical unit I must use an bootable USB - I delete and redo the partition with the previous...
Windows 8 Print Driver Issues :( in Drivers & Hardware
My printer won't work at all on Windows 8 :( I get the following message: The print driver is not compatible with a policy enabled on your computer that blocks NT 4.0 drivers Any assistance would be appreciated. Thanks Anne
Hello guys im wake up today and try find my cd drivers for printer canon mp250.... but i can't find installation cd... but im plug printer in windows developer preview and in 2 minutes him recognize the printer and install drivers... him show me the printer model and automatically installl all...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook