Windows 8 and 8.1 Forums


Way to distinguish ISO's without loading?

  1. #1


    Posts : 50
    Windows 7 64bit

    Way to distinguish ISO's without loading?


    I have quite a few spanish 8 and 8.1 ISO's built up and its a mix of single language and regulars. Is there any files I can look at in the ISO's to see which they are? I know 7 had a way but I havent ever messed much with 8 or 8.1.

    Single language is a stupid key setup and I wonder why microsoft did it and didnt just leave oem keys all the same.

      My System SpecsSystem Spec

  2. #2


    Redmond
    Posts : 651
    Windows 8.1 x64


    Windows binaries themselves are (almost all) language neutral, and thus it uses language packs to choose a language (in this case, applied during setup). An easy way is to use the actual ISO name, as ISOs from original sources are generally named in specific ways that would tell what was going to be installed. Failing that, you could look to see what language (or languages) is/are listed in the WIM file itself via DISM (where X is the drive letter of the mounted ISO) to be applied when installed:

    dism /Get-WimInfo /WimFile:X:\sources\install.wim /index:1
      My System SpecsSystem Spec

  3. #3


    Posts : 50
    Windows 7 64bit


    Guessing there is no way to distinguish which key type the iso uses?

    I do see about language packs how you can download them from microsoft. It used to be that the packs wouldnt change everything inside of windows. Has that changed? Its been years since ive done it.

    Would be nice to be able to switch a english windows 8.1 system to full spanish without having to fully reload and all.
      My System SpecsSystem Spec

  4. #4


    Redmond
    Posts : 651
    Windows 8.1 x64


    The type of install is also included in the dism command, so you would get the version. You won't know if it's retail or OEM though, although installation of a matching Windows 8 version onto a machine with a Windows 8 sticker matching said version should activate even if the ISO is retail. I'd recommend getting your ISOs from the page here, though, as ISOs created using the "Create Media" button here are guaranteed to work OEM or retail.
      My System SpecsSystem Spec

  5. #5


    Posts : 50
    Windows 7 64bit


    Good link to have, but do you know if full languages can be installed to a oem install after its loaded? Or if reloading is still the way to do it like it was back in the past?
      My System SpecsSystem Spec

  6. #6


    Redmond
    Posts : 651
    Windows 8.1 x64


    Yes, but it's not trivial:

    Create a Multilingual Windows Image

    and

    Add and Remove Language Packs Offline Using DISM

    Doing so would require the language pack .cab files and some work with unattended files to get things to install properly via setup.
      My System SpecsSystem Spec

  7. #7


    Posts : 50
    Windows 7 64bit


    Yea, I was talking about something to run in an active window installation to change the language next reboot. Guessing that isnt possible still tho. I have Spanish images already.
      My System SpecsSystem Spec

  8. #8


    Redmond
    Posts : 651
    Windows 8.1 x64


    If you want to change the language to a running system, just install the LP and set it as the default.

    Windows 8 How To: 11. Install Language Packs for Multilingual Support - Dr. Z's Blog - Site Home - MSDN Blogs
      My System SpecsSystem Spec

Way to distinguish ISO's without loading?
Related Threads
pages are not loading in Browsers & Mail
Please help me.My OS is windows 8 and browser is google chrome.pages are loading after refreshing about 30-40 times and even if they load,it is not proper (ie images not displayed....etc).here is the link to video showing the problem.Any help would be greatly appreciated.thanks...
Solved user not loading! help! in User Accounts and Family Safety
I have 3 users set up, however we only use one of them. Today this user will not load, it allows you to sign in but then flashes every 3 seconds on and off, and shows only 5 tiles, so it is not loading the profile. Now when I just tried to switch users it doesn't even do that but flashes back out...
Not loading certain websites in Browsers & Mail
Ok, just got a new laptop at work. It is a Toshiba Satellite running windows 8. When the computer is connected to my workplaces wifi it loads some websites fine, like google.com. But there are others that don't load, such as facebook.com or ab.com. This is the same issue whether I'm on Internet...
Hey, Just got a new laptop in the past few days - HP Pavilion g6-2213sa. For some reason there's one website in particular that won't load for me - a webmail login service. It won't load on any browser (Chrome, Firefox, IExplorer), but it does work on my phone which is connected to the same...
Browser Not Loading in Browsers & Mail
Hi, Anyone else have difficulty with web browsers (particularly those that operate on port 80) not responding for a while (like 5-10 minutes) when Windows starts? The browsers will say LOADING but after 5-10 minutes, it will fail as operation timeout. Then when I refresh, it will load properly...
Solved Help with no loading apps! in Software and Apps
Hi, I recently installed Windows 8 on my laptop from Windows 7. Everything is fine except when i click on any of the apps on the start screen or the app store itself it just has the load symbol and nothing else happens after that. I'v done all the updates etc but to no avail. I'v read about...
.ICC Profiles not loading in Graphic Cards
I've tried to fix it on my own through the power of google, but alas ... I'm out of ideas. So I have a dual monitor situation and I'm running Nvidia GTX 670s in SLI (SLI on or off doesn't seem to make a difference-- neither does disconnecting a monitor). I know how to go into color...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook