Windows 8 and 8.1 Forums

Windows Explorer won't load; can't "Run As Admin"

  1. #1

    Windows Explorer won't load; can't "Run As Admin"

    OK. Weird stuff.

    Windows 8.1 x64.

    When I directly click on the Taskbar Explorer icon, it flashes for a bit, then nothing. If I right click and select a pinned folder, it opens instantly.

    I also have a CMD prompt pinned to the task bar. If I right click, then right click on the CMD again and then select Run as Admin, it doesn't load. It will load non-admin instantly. (I also tried running as admin from the Start Screen with a long press- that doesn't work).

    However, I can go into the advanced properties of the CMD shortcut and check to run it as an admin. That works.

    I have tried a utility to purge missing mount points in the the Registry, and an SFC scan, which showed no problems.

    Any ideas?

      My System SpecsSystem Spec

  2. #2

    Posts : 1
    windows 10

    This sounds the same as my recent reason for coming to this forum. "THIS PC" folder taking forever to display.

    The fix turned out to be a hosed Explorer.Exe. I went to task manager (by right clicking the bottom tasks bar) and selected the Windows Explorer under apps (Explorer.Exe) and right clicking it and doing a restart. Cleared it up instantly for me.
      My System SpecsSystem Spec

Windows Explorer won't load; can't "Run As Admin"
Related Threads
Is there any way to load the "Screen Saver Settings" dialog/ control panel at boot-up/ login in a similar fashion to applications? If not, then would I need to write a software program of some type via OS-specific commands (I presume) for opening this dialog to be executed at boot-up/ login...
Hi all, So I'm kind of stuck.. I currently have the problem where I am in an endless cycle of "loading files" -> "Windows Boot Manager" (see: How To Boot Into Safe Mode On Windows 8 (The Easy Way)). I have tried to load all of the options -- and none successfully load. I also end up at...
I am running Windows 8.1x64 on an HP DV6 laptop with 8GB RAM & 720GB HDD. Sys Specs - Imgur Every time I try to open the "Computer" folder (formerly "My Computer,") the window shows that it's loading for a very long time. It'll eventually come up and show me what drives are mounted. This has been...
Hello people. I have joined this site hoping to get to help with the issues I have after updating from windows 8 to 8.1. I have been pulling my hair out because after loading this update it has screwed up my laptop. Firstly after my laptop eventually starts I get the following error message ...
Hi All. I'm running Windows 8.1 (standard/ home edition) and can't download a couple .exe files. I get "You'll need to provide administrator permission to copy to this folder". errors. I'm the only user on this computer and have administrator access. The file resides on mediafire and via my...
Good day all, I've done a quick search (here and google) but can't find a solution for the following: Windows 8 pro: I have a user account with admin rights. It used to work fine till one day, after rebooting, I had no tiles in the start view. I ran chkdsk and it seems to have fixed the...
Windows 8 Install "Load Media Driver" in Installation & Setup
Hi all, I am trying to install a oem copy of windows 8 64 bit onto my desktop, using a microsoft install dvd. I've installed xp, vista, and windows 7 onto it without any issues whatsoever, however when trying to install windows 8, I keep getting an error in windows setup that states the following:...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook