Windows 8 and 8.1 Forums


2TB Ext HDD 1021 shows in device manager, won't play

  1. #1


    Posts : 1
    Windows 8.1

    2TB Ext HDD 1021 shows in device manager, won't play


    I've had this 2TB Ext hdd 1021 for about a year and it's worked perfectly up until today. I don't want to reformat or anything like that, as I have nearly the entire 2TB worth of memory filled with films and TV shows. It won't read when it's hooked up to any of the ports, it doesn't show up in disc management, but it does show up in device manager. But now that I have it showing up there - now what? The drive still won't open nor (obviously) play any of my films/shows on it. I want to - at the very least - extract the data from it and move it elsewhere.

      My System SpecsSystem Spec

  2. #2


    Probably the cheapest way to figure out if it was the enclosure or the drive that crapped out on you is to buy one of those drive dock devices that looks like a mini-toaster. Then pull apart the enclosure, extract the drive, and stick it in the dock. If the drive works, you're in business. If it doesn't, short of sending it to a recovery service (which would probably cost a couple grand) the data's as good as gone.
      My System SpecsSystem Spec

2TB Ext HDD 1021 shows in device manager, won't play
Related Threads
If you have ever wanted to change that boring "HID-compliant Mouse" title to something more descriptive, this tutorial is for you. The name of any device can be modified with this method and can help you organize your devices better in Device Manager. First, open Device Manager by opening a run...
Unknown device in Device Manager in Drivers & Hardware
My friend's fairly new computer has started showing an unknown device in Device Manager. The hardware id in properties shows USB\VID-08B1&PID_0018&REV_1501 I've tried to find this on the PCI Database website but have been unsuccessful, as has a Google search. Any ideas how to find out what...
Okay - two hours later.. after what was likely the mangling of my Registry due to thinking this was a problem with the specific shortcut that was doing it. (i removed all entries with "razer" in them and if they arent all reinstalled by razer i may be in trouble). Anyhow, to be clear... I have...
Brand new here. I have a complex problem. I started having trouble with my text to speech program playing in Win 8.1 - as the audio started breaking up when played. When trying to resolve this I noticed that task manager showed the HD was running at near 100% most of the time. I suspected that the...
My computer is a Sony VAIO with Windows 8.1 and is less than 7 months old. While looking at the Disk Manager today I realized that not only did I have 5 partitions which is annoying in itself but it appears 4 of them are empty. I made a Recovery Disk when I first got it and had to use it several...
Hello, I have an M-Audio midi-uno and it isn't popping up anywhere in windows 8; it plugs in via usb 2.0. When I plug it in a light on the device turns on and slowly flashes on/off. When I plug it into my piano and play notes the indicator lights that show key presses flash on/off Yet when I...
Hi, On a fresh clean Windows 8 image, my software driver (signed) installs fine and shows up properly in the Device Manager. However once i uninstall it , subsequent reinstalls show up as 'Unknown Device' in the Device Manager. From the device details, I find that it refers to /looks for the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook