I have created some symlinks (not hardlinks or JP) on my system, everything worked fine, but after restarting the system I get the message:

You don't currently have permission to access this folder.
Click Continue to permanently get access to this folder.
[Continue] [Cancel]


You have been denied permission to access this folder.
To gain access to this folder you will need to use the security tab.
I've created:
C:/Users/my_username <=> C:/my_username
C:/Users/my_username/Downloads <=> C:/dls
And they have stopped working. When I right click any of my symlinks and check for the owner (Security ->Advanced) it says Administrators group (which is fine, cause my account is and administrator). However I am missing "Special permissions" (screenshot below)

also when I'm in Adavanced security settings and I click change permissions add, remove, view buttons appear, but they are greyed out.

What I've tried so far?
Created a new folder
symlinked C:/aa <=> C:/bb
and I can't access C:/bb (same error)

How can I solve this?

btw. I've used Symlink Creator to make symlinks (ran as admin).