Windows 8 and 8.1 Forums

Default file association not working with some extensions

  1. #1

    Posts : 3
    Windows 8.1

    Default file association not working with some extensions

    Hello 8Forums Community,

    I'm having file association issues.
    I've have tried troubleshooting this for hours without any avail. I'm coming here as a last that I think of it, maybe I should have come here first.

    On to my issue:

    I recently lost file association capabilities with .torrent and GDrive items (.gdoc, .gforum, .gsheet, etc). These are the two that I have at least noticed.

    1. When I click on either of those files, it gives me a prompt to choose a file association. Since the correct program isn't listed, I go and click on the option to find the program manually. However after I select the correct program for each of the above files listed, nothing happens. Nothing opens, nothing changes, nada happens.
    2. I have also tried right clicking on each of the files above mentioned, going to properties, under the general tab I click change next to the part where it says "Opens with:". Same thing as in part #1. Nothing happens, nothing changes. It says in that slot "Pick an app" and says the same thing after I pick an app.
    3. Then I went to Control panel, Default Programs, Associate a file type or protocol with a program. The interesting part here is that I cannot find among the huge file extension list the above referenced file extensions (.gdocs, etc). It's like they are not baked into the system. However, when I go to regedit (registry editor) and look at this key "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts" I can find all the file extensions listed above. I even deleted the .gdocs one to see what would happen (deleting the whole extension file in the reg editor under the above reg edit address) and nothing happened. I still cannot associate anything with a .gdoc file.
    4. Other common file extensions such as .pdf work great. I can change between the default program without an issue. If I change a default program for a .pdf file, it sticks and does not give me headaches as the above file extensions.

    I'm running out of options. I have a suspicion that maybe running Advanced SystemCare 7 may have done something strange to those file extensions. Just a hunch, but I don't know how to further look into this. I cannot do a file restore as this has been going on for a while, and I don't remember which restore to use or how far back to go or if I even have a restore option that could fix this.

    Your help is much appreciated.



      My System SpecsSystem Spec

  2. #2

    Posts : 3
    Windows 8.1

    Just checking in to see if anyone has had any thoughts on this topic. I really hope the fix isn't having to do a full reinstall....that would suck. Please, if you have any suggestions, they are welcomed.

      My System SpecsSystem Spec

  3. #3

    Have you tried uninstalling and reinstalling your torrent and GDrive programs?
      My System SpecsSystem Spec

  4. #4

    Posts : 3
    Windows 8.1

    Quote Originally Posted by Ztruker View Post
    Have you tried uninstalling and reinstalling your torrent and GDrive programs?
    Yes, with no avail. Thanks for the thought.

    I'm thinking the problem is deeper...maybe registry issues. However, I don't have registry smarts to know how to dig into this. I'm hoping someone else has some thoughts.

      My System SpecsSystem Spec

  5. #5

    See what the defaults are set to now using the assoc and ftype commands in a Elevated Command Prompt;

    For example, this is for a .txt file:

    C:\Users\xxxxxxxx>assoc .txt

    C:\Users\xxxxxxxx>ftype txtfile
    txtfile=%SystemRoot%\system32\NOTEPAD.EXE %1
    You would do this for .torrent, .gdoc, .gforum, .gsheet, etc

    This is how you could change the default program for them:

    C:\Users\rrkurtz>ftype /?
    Displays or modifies file types used in file extension associations

    FTYPE [fileType[=[openCommandString]]]

    fileType Specifies the file type to examine or change
    openCommandString Specifies the open command to use when launching files
    of this type.

    Type FTYPE without parameters to display the current file types that
    have open command strings defined. FTYPE is invoked with just a file
    type, it displays the current open command string for that file type.
    Specify nothing for the open command string and the FTYPE command will
    delete the open command string for the file type. Within an open
    command string %0 or %1 are substituted with the file name being
    launched through the assocation. %* gets all the parameters and %2
    gets the 1st parameter, %3 the second, etc. %~n gets all the remaining
    parameters starting with the nth parameter, where n may be between 2 and 9,
    inclusive. For example:

    ASSOC .pl=PerlScript
    FTYPE PerlScript=perl.exe %1 %*

    would allow you to invoke a Perl script as follows: 1 2 3

    If you want to eliminate the need to type the extensions, then do the


    and the script could be invoked as follows:

    script 1 2 3
      My System SpecsSystem Spec

Default file association not working with some extensions
Related Threads
I recently found many application would not save to correct type. Some software icons would come out to a blank or white block, but those software actually there. For example, realrecorder is running, it would come out a white block on taskbar on bottom. I tried use 'access and program default'...
HI. I want to setup my build to change reg key(s) so that each new user that logs on sees the file extensions in Windows Explorer Checking this thread Show File Extensions and Hidden Files for all Users - Windows 7 Help Forums I hoped it would be a case of changing one key in...
file association in General Support
I'm having a pickle with file associations. For example, 7zip has file associations built in to its options, yet it has no effect. I get a perameter error when trying. also, VLC media player won't take over certain file types(AVI) for axample for me either. This is the only problem I've had...
Hi guys1 I'm about to create a .reg file that will set path in registry to my own icon for specific file extensions. E.g. I want my own icon as a default icon for .ini extension. And not only for one extension but for more of them, in a single .reg file. As always I don't want to mess it up,so I'm...
Hello all, I hope this isn't a repeat thread - I didn't find any others that were having this issue. On the first day I received my laptop, I went into folder options and selected to show hidden folders and show known file extensions just as I have in 7, and Vista before that. It seems...
Hi I have accidently changed the default file association for cursor files. Can you recommend a solution please? I am running Windows 8 Steve C
Dear all, I have recently installed Windows 8 Enterprise RTM x86 on FSC V3505 laptop and so far the OS has been working for a month. However, Recently I tried to access "Control panel -> Indexing options -> Advanced -> File types" which caused the Indexing options windows to close. Similarly,...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook