Windows 8 and 8.1 Forums


Can't Mount ISO Files Natively Anymore

  1. #1


    Posts : 14
    Windows Server 2012 R2 Datacenter

    Can't Mount ISO Files Natively Anymore


    My OS formerly mounted ISOs with an Enter or double-click in File Explorer.
    Now I get an error
    Click image for larger version
    Most remedies from a quick Google search don't apply:

    • the ISO files don't have a sparse flag set Click image for larger version, so
      Code:
      fsutil sparse setflag filename 0
      does nothing, copying does nothing
    • the native Windows handler is already set as default, hence the above error
    • utilities like 7-zip can open these files
    • non-native ISO mounters can mount these files
    • Code:
      sfc /scannow
      didn't help
    • Code:
      dism /cleanup-image /online /restorehealth
      didn't help
    • the OS was installed yesterday
    • Microsoft Security Essentials isn't the issue (I just checked a virtual machine running only my version of the OS and MSE: it can mount ISOs); MSE is necessary since the server edition doesn't include a built-in AV

    A week ago, I thought it was time to do a fresh install of Windows in case I had corrupted the ISO mounting driver somehow.
    I got the updated install media from Microsoft (2012 R2 Update, the server edition 8.1 Update), wiped the hard drive, installed it, and fully updated it, expecting it to work.
    To my shock, it does not.
    I'm beginning to think an update or a driver is at fault here, since I haven't installed anything unusual.

    If anyone can solve this problem for me, then it would be utterly heroic.
    It's been bugging me a while.
    Can't Mount ISO Files Natively Anymore Attached Files
    Last edited by l0mars01; 18 Oct 2014 at 11:14.

      My System SpecsSystem Spec

  2. #2


    Posts : 22,582
    64-bit Windows 10


    Hello mars,

    You might see if downloading and merging the .reg file for the ISO option in the tutorial below may be able to help. It will restore the default associations and registry entries for ISO files.

    Default File Associations - Restore in Windows 8
      My System SpecsSystem Spec

  3. #3


    Posts : 14
    Windows Server 2012 R2 Datacenter

    Standard user account can no longer mount ISOs natively


    Thank you!
    My administrator account can mount ISOs!
    I wasn't sure until I switched to an administrator account.

    New problem: my standard user account still can't mount them.
    It requests administrator credentials and still does the "Sorry" business from before.
    It's probably a security permissions issue or a profile-specific issue.
    I tried importing your registry entries on a standard user account and got an error.
    Only an administrator can do it entirely.

    A virtual machine running only a fresh install of my OS does allow standard users to mount ISOs after they enter administrator credentials.
    It's definitely not the default permissions.

    The only permissions I'm aware of changing are disabling "Enforce password complexity", giving everyone permission to shutdown the computer, and allowing shutdowns without logging in.

    I'm still happy the administrator can mount ISOs now. That's progress!
      My System SpecsSystem Spec

  4. #4


    Posts : 22,582
    64-bit Windows 10


    Are the ISO files located in a folder that the standard user doesn't have access allowed by chance?
      My System SpecsSystem Spec

  5. #5


    Posts : 14
    Windows Server 2012 R2 Datacenter


    They're in either the standard user's folder or "Public" user's folder.
      My System SpecsSystem Spec

  6. #6


    Posts : 22,582
    64-bit Windows 10


    As a test, copy the ISO file to anywhere, then try to mount it afterwards.
      My System SpecsSystem Spec

  7. #7


    Posts : 14
    Windows Server 2012 R2 Datacenter


    Thanks for looking into this.
    It still fails to mount like before.
      My System SpecsSystem Spec

  8. #8


    Posts : 22,582
    64-bit Windows 10


    Just to make sure, you did copy (right click "Copy") and "Paste" the ISO and not drag and dropped or any other method?
      My System SpecsSystem Spec

  9. #9


    Posts : 14
    Windows Server 2012 R2 Datacenter


    I pressed CTRL as I dragged and released.
    The UI tells me this performs a copy as I do it.

    If it helps, I can fetch you some entries from the Event Viewer.
    I was looking there before, but I didn't know what to look for (source name, log name, etc).
    I was also thinking of using Process Monitor to get some clues, but that dumps a ton of information.

    PS Sorry for the delay. I had to take a snooze.
      My System SpecsSystem Spec

  10. #10


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Instead of---

    Click image for larger version

    Try---

    Dism /Online /Cleanup-Image /RestoreHealth

    Then run sfc /scannow
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Can't Mount ISO Files Natively Anymore
Related Threads
Solved Mount iso missing in General Support
Hello everyone, Am having a trouble with iso files. When I select the .iso files the Manage is not activating or enabling. pls suggest me to solve this. 15169 Thanks in Advance!
How to mount ext hdd in Drivers & Hardware
So I am running Ubuntu on my laptop which has been my primary computer for the past two years or so. My issue is this: I bought a new computer, I was in the process of setting everything up then when I realized my HDD wasnt there, I figure I didnt plug it in all the way. No, it is in, the computer...
mount .bin.cue files in General Support
hi , having trouble mounting files in w8 always used diamond tools before (in vista) without any trouble. but now its not working at all, i´m mounting the file and all that happens is audio file(1kb) in the viritual drive. have been sitting here for like 4h and whatever i do nothing works..
Not able to mount iso file in Virtualization
Hi, I didn't install any 3rd party app to mount iso. Yesterday, i tried to mount a iso file, it didn't worked. Then googled about it, tried sfc /scannow, no success. Then i checked "Default programs - associate file extension...", there is no entry for .iso. Please help. 27780 Tried Daemon...
couldn't mount image in Virtualization
i use windows 8 professional edition, when i want to mount the image, the warning message came and it says "couldn't mount image because its in use" although i'm not mount it, do you have any answers ? thanks :D
WOW Windows 8 mount the ISO in Software and Apps
What a nice surprise , you can mount the ISO … I just finish to install Visio .... http://i554.photobucket.com/albums/jj432/dataxpert/mount.jpg
Eight Forums Android App Eight Forums IOS App Follow us on Facebook