Windows 8 and 8.1 Forums

Can't Mount ISO Files Natively Anymore

  1. #11

    Posts : 14
    Windows Server 2012 R2 Datacenter

    I think that's what I did, and I recalled the command incorrectly when I wrote about it.
    I'll correct that shortly.
    Just in case, here's the output.
    PS C:\Windows\system32> dism /cleanup-image /online /restorehealth

    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031

    Image Version: 6.3.9600.17031

    The restore operation completed successfully. The component store corruption was repaired.
    The operation completed successfully.
    PS C:\Windows\system32> sfc /scannow

    Beginning system scan. This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection did not find any integrity violations.
    Unfortunately, ISO mount still fails for my standard user.

    I really want this to work.
    Can I provide you any more information?

      My System SpecsSystem Spec

  2. #12

    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center

    Go out & buy a full retail version.
    Then you'll have no problems.

    I'm not rich.
    I spent some money & have 8.1.1 Pro WMC installed & working good.

    Just my 2¢.
      My System SpecsSystem Spec

  3. #13

    Posts : 14
    Windows Server 2012 R2 Datacenter

    I think you misunderstood: it is a full retail version.
    "User Accounts" offers 2 types of accounts:
    • Administrator
    • Standard

    Both types can mount ISOs on a completely fresh install of my OS without updates. (I've checked on a virtual machine.)
    Brink helped me get Administrators mounting ISOs again.
    My standard account still can't.
      My System SpecsSystem Spec

  4. #14

    Posts : 14
    Windows Server 2012 R2 Datacenter


    I traced a possible cause of the problem, but I don't know what to do about it.
    The community's insight here would be extremely valuable.
    With Sysinternals Process Monitor capturing data, I attempted to mount an ISO, then dove through the results.
    Here's the log:
    I'm terribly inexperienced, so please examine it if you think you can get better insights.

    In a way, it shows me attempting to mount the ISO as a standard user, then a request for credentials, and an attempt to mount the ISO as the administrator I selected (named "Elevated").
    Here's where I see it clearly go wrong
    Click image for larger version
    It attempts to act on path "C:\Users\Elevated\Downloads\temp\Windows XP x64.iso" when my ISO is located at "C:\Users\Luis\Downloads\temp\Windows XP x64.iso".
    "Elevated" is the administrator I select when the UAC requests permission.
    Windows is replacing the original user's profile path with the administrator's.
    It's no wonder it fails to mount my ISO: it's going to the wrong location!

    Just to check, I made a hardlink from "C:\Users\Elevated\Downloads\temp\Windows XP x64.iso" to "C:\Users\Luis\Downloads\temp\Windows XP x64.iso" and tried mounting "C:\Users\Luis\Downloads\temp\Windows XP x64.iso" again.
    Sure enough, it "works".

    tl;dr Windows is mangling an ISO's path when a non-administrator attempts to mount.

    What can be causing this, and how do I fix it?
    Last edited by l0mars01; 26 Oct 2014 at 03:47.
      My System SpecsSystem Spec

  5. #15

    Posts : 12

    I have the same issue right now.

    I think some of my old images work as expected, the new ones, downloaded AFTER I did complete win 8.1 reinstall ( a few days ago). Moving them to external hard drive is a king of semi-solution, because then they do work.

    I0mars01 - did you solve that issue?

    Tried different approaches that I have found searching through web, but nothing helped. Just reinstalled windows 8.1 proffesional x64 and guess what? Nothing has changed, fresh windows install, no drivers , no updates and it fails to load ISO.
    Moreover, I do have problems with burning those images to my external USB drive. Some images work, some do not, All of them work when copied to external HDD.
    Last edited by kuki; 14 Mar 2015 at 07:33.
      My System SpecsSystem Spec

  6. #16

    Posts : 14
    Windows Server 2012 R2 Datacenter

    No, I never solved it, and our experiences match.
    The best solution I know is no solution at all, but workarounds: either
    • log in as an administrator (which defeats the purpose of security restrictions, right?), or
    • keep ISOs off paths under the logged-in user's profile.

    Then switching security contexts (when you choose an administrator in the UAC) for a mount operation won't mangle the ISO file's path:
    • In the former case, you don't switch security context as you're already an administrator;
    • in the latter case, the file-path is safe from profile changes that come with switching security context: i.e., file-path transformations from C:\Users\standardUser to C:\Users\administrator do nothing to paths lacking C:\Users\standardUser

    However, I've never reported this problem to Microsoft. They might properly fix this if they knew.

    As far as I know (I've never had to try this), clearing the sparse flag
    fsutil sparse setflag filename 0
    addresses the same problem copying does.
    You can check for the sparse flag in the file's attributes:
    • GUI: File properties, Details tab, Attributes, P
    • command-line:
      fsutil sparse queryflag filename

    If you move the ISO off the logged-in user's profile (or log in as an administrator), and clear any sparse flags on it, then it should mount.
      My System SpecsSystem Spec

  7. #17

    Posts : 148
    Windows 8.1 Update 1

    Why don't you use a third party app to mount Isos? I have always used Daemon Tools (the free version) and so far it has never let me down.
      My System SpecsSystem Spec

  8. #18

    Posts : 14
    Windows Server 2012 R2 Datacenter


    I spoke to a tech support agent, and she points this out to me:
    If you open C drive in Windows Explorer and navigate to an ISO file under your user profile, then it opens!
    You can't start from your profile (where Windows Explorer starts) and navigate straight to your ISO.
    This appears to be a Windows Explorer bug.
      My System SpecsSystem Spec

  9. #19

    Posts : 14
    Windows Server 2012 R2 Datacenter


    But seriously, because it's broken and I want to fix it, which is pretty much the whole point of this board. Sure, I'll workaround it (with ImDisk) until I learn how to fix it, but the moment I learn how, I'll still fix it.
      My System SpecsSystem Spec

  10. #20

    Posts : 1
    Windows 8.1 Pro

    I have seen a few fixes to this problem in this thread ... I know the thread is a little aged but since it is still referenced on a google search I feel I should add some technical information to this thread that should resolve the issues ...

    Your ability to not mount the .iso image is caused by Microwhat? file security system ...

    how to make .iso's mountable ...

    There are a couple of things that might occur when you right click on an .iso file ...
    1. there is no mount option
    2. there is a mount option but when you click on it it gives you an error about some lack of ability of microsoft developers that prevents you from performing a valid function ...

    here are a couple of methods to fix either or both of the problems above ... users choice ...

    1. simple and easy ... get 7zip it opens the archive which should allow you to install whatever ... (it is free and easy to use and should not contain any malware)

    2. right click on the .iso file > select Properties at the bottom of the list > Select the Details tab at the top > Click the link at the bottom that says ( Remove Properties and Personal Information ) > a new box will pop up with two options at the top ... the first default option is the best option but both options work ... > select ok ... when it is done you will see a new file ... "Original file nam.iso - copy" right click on the one that says copy ... you will now have the option to mount the file even if you did not have the option before ... mount and enjoy ...
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Can't Mount ISO Files Natively Anymore
Related Threads
Solved Mount iso missing in General Support
Hello everyone, Am having a trouble with iso files. When I select the .iso files the Manage is not activating or enabling. pls suggest me to solve this. 15169 Thanks in Advance!
How to mount ext hdd in Drivers & Hardware
So I am running Ubuntu on my laptop which has been my primary computer for the past two years or so. My issue is this: I bought a new computer, I was in the process of setting everything up then when I realized my HDD wasnt there, I figure I didnt plug it in all the way. No, it is in, the computer...
mount .bin.cue files in General Support
hi , having trouble mounting files in w8 always used diamond tools before (in vista) without any trouble. but now its not working at all, i´m mounting the file and all that happens is audio file(1kb) in the viritual drive. have been sitting here for like 4h and whatever i do nothing works..
Not able to mount iso file in Virtualization
Hi, I didn't install any 3rd party app to mount iso. Yesterday, i tried to mount a iso file, it didn't worked. Then googled about it, tried sfc /scannow, no success. Then i checked "Default programs - associate file extension...", there is no entry for .iso. Please help. 27780 Tried Daemon...
couldn't mount image in Virtualization
i use windows 8 professional edition, when i want to mount the image, the warning message came and it says "couldn't mount image because its in use" although i'm not mount it, do you have any answers ? thanks :D
WOW Windows 8 mount the ISO in Software and Apps
What a nice surprise , you can mount the ISO … I just finish to install Visio ....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook