Windows 8 and 8.1 Forums


Loading slow when playing Videos and Audios

  1. #1


    Posts : 11
    Windows 8.1 Pro

    Loading slow when playing Videos and Audios


    Hello,
    First of all, I'm sorry if I posted in the wrong forum.

    I have windows 8.1 installed on my laptop and recently I can't play videos and audio's properly, it usually takes 30-40 seconds to load them up on my video players and sometimes the player hangs (mostly use Media Player Classic and VLC), it also happens with youtube videos as well, I haven't tried with other streaming sites. Those videos and audios I'm trying to play aren't necessarily large by the way, it happens with all of them as far as I know.

    I am not experiencing any bad/lower performance other than that, what might be the problem I'm facing?

    My specs :
    Core i5 (1st gen)
    4GB RAM
    ATI Radeon 4650 (1gb)

      My System SpecsSystem Spec

  2. #2


    Canada
    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit


    Is loading programs giving the same effect? Your anti virus program may be the culprit.
      My System SpecsSystem Spec

  3. #3


    Posts : 11
    Windows 8.1 Pro


    Quote Originally Posted by Nuccii View Post
    Is loading programs giving the same effect? Your anti virus program may be the culprit.
    No problem with loading programs, and also I have only Windows Defender, no other anti-virus installed. Turning it off doesn't seem to help
      My System SpecsSystem Spec

  4. #4


    Canada
    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit


    Try another browser to see if the effect is the same.
    Run the file cleaner and registry cleaner with CCleaner Free:
    https://www.piriform.com/ccleaner/download
      My System SpecsSystem Spec

  5. #5


    Posts : 11
    Windows 8.1 Pro


    Quote Originally Posted by Nuccii View Post
    Try another browser to see if the effect is the same.
    Run the file cleaner and registry cleaner with CCleaner Free:
    https://www.piriform.com/ccleaner/download
    Tried that and problem's solved.! I've been using iobit Advanced System Care for registry fixing and cleaning unnecessary files, CC Cleaner seems to be a lot more better from the experience I had just now , even restarting the PC is a lot faster than before. Uninstalled iobit ASC =.=, thank you very much.
      My System SpecsSystem Spec

  6. #6


    Canada
    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit


    Your welcome
      My System SpecsSystem Spec

  7. #7


    Posts : 11
    Windows 8.1 Pro


    Came back because I realized the problem is still there after downloading a new video file. Videos I've already played before has no problem loading but new downloads which I haven't played causes the player to hang, frame skips so I have to close the player like after 10 seconds of the first time playback and then re-open it to play properly. This is seriously annoying as I download many short videos, anymore ideas?
      My System SpecsSystem Spec

  8. #8


    Canada
    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit


    Strange one indeed. All I can suggest is uninstall your video players and reinstall them or try another video player.
      My System SpecsSystem Spec

Loading slow when playing Videos and Audios
Related Threads
BSOD playing games, or watching videos in BSOD Crashes and Debugging
Been getting a lot of BSODs lately, they used to happen frequently then they kind of just stopped, and now they seem to be starting up again for some reason, so I decided to finally try and get some help. I've attached the minidump file and I did a driver verifier which resulted in a BSOD...
This problem seems to happen when I play videos, or games. it doesn't happen every time, but it has happened 4 times in the last week, and started after resolving another BSOD issue, which was apparently driver related. As this seems to happen with games, and videos, I'm thinking it may be...
I just recently updated from Windows 8 to Windows 8.1 and now on IE11 some of the videos will not play on Youtube what should I do to fix this
Solved 8.1 slow loading in Browsers & Mail
Hi, This topic must be located here somewhere as it's such a common problem but I don't see it. Since installing Windows 8.1 (and I can't go back to 8 for various reasons) web pages quite frequently simply hang as they try to connect. I have to wait, at times, for as long as 30 seconds...
How do I get IE to let me play embedded videos? I can watch vids on Youtube, but if I go to a web site where they have embedded videos, it doesn't show them. What I mean is that it doesn't even acknowledge there is a video there. I even had someone with sight look at the site I was on, and she...
problems playing videos in Browsers & Mail
Hi, i just got a new computer with windows 8 and can't seem to watch any videos on youtube. It plays the sound but I can't see anything. I've searched other posts similar and done a google search for this problem and some answers seem to recommend drivers or codec or something. I don't know how to...
Hi Everyone, Just seeing if anybody else is having this same issue. When I play an Mpeg2 video file thru Media Player, its plays the sound fine, but there is not video. The video played with no problems with Media Player in Windows 7. I have loaded VLC & the video played fine, but I like to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook