Windows 8 and 8.1 Forums

"Secure Boot Violation" error after recent Windows Updates

  1. #1

    Posts : 4
    Windows 8.1

    "Secure Boot Violation" error after recent Windows Updates

    Hello all,
    I own an Asus laptop with pre-installed Windows 8.1 and, after downloading & installing recent Windows updates (20th of September 2014, if memory serves me correctly), I am unable to access desktop because system freezes at boot sequence returning me this error: "Secure Boot Violation. Invalid signature detected. Check Secure Boot Policy in Setup" printed inside a small red box.

    After googling around, someone suggested to disable "Secure Boot" from BIOS and enable "Launch CSM". I performed such operations but I got no results (BIOS menu automatically appears after every reboot). Someone else suggested to change boot sequence and start system from a Recovery CD but I got no CD supplied with my laptop as Asus stopped providing CDs from very long time AFAIK.

    I am quite sure problem relies on Windows Updates because I used this Laptop very little times and no p2p or hacked programs are installed. In addition to that, as far as I read, it seems other Win users experienced the same issue after installing WinUpdates but they have different BIOS so is not easy for me to understand my BIOS accordingly to what they do in their own BIOS in order to solve issue.

    What annoys me most is that I bought this Laptop in July 2014 and, just three months later, it got freezes because of official Windows Updates and not because of bad behaviour of user.

    Thank you all for reading.
    I appreciate your help very much.

      My System SpecsSystem Spec

  2. #2

    Turn off Secure Boot, but do not enable CSM.
      My System SpecsSystem Spec

  3. #3

    Posts : 4
    Windows 8.1

    Thanks for your hint, I just tried to do what you suggested.

    Unfortunately, it didn't solve my issue: now BIOS menu appears every time I turn on PC.
    I get same effect if I disable "Secure Boot", "Launch CSM" as well as "Fast Boot" option.

    Wish I could get another hint...
      My System SpecsSystem Spec

  4. #4

    Posts : 4
    Windows 8.1

    I gave up. After I disabled "Secure Boot", I ran Ubuntu 14.04.1 from USB, then I formatted hard disk and I installed Ubuntu OS which is more free and reportedly stabler than Windows 8.1.; issue not formally "solved" but I consider it "solved" for lack of interest. Thank you all for your kind attention.
      My System SpecsSystem Spec

  5. #5

    I know it's too late to help but there was a lot of info concerning August update problems which fortunately did not effect me. Could this have been the problem - I wonder?
    Microsoft Removes Problematic August Windows 8.1 Updates | Digital Trends

      My System SpecsSystem Spec

  6. #6

    Posts : 1,121
    Windows 8.1 x64

    Your situation does not seem to pop up very often. I am a little surprised the ASUS system came with 8.1 pre-installed since many of them only come with 8.0, but it really should not be relevant.

    If you want to see how your system reacts when booting to a non-certified OS, you can try booting to a Windows 7 DVD. That should give you the normal indications when violating the Secure Boot restrictions. On my ASUS motherboard, it bounces me back into the Bios to make changes, and even might make those changes automatically. Enabling the CSM should allow Windows 7 to boot normally, even if you are using UEFI. No Windows change has ever caused any of my Windows 8 systems to exhibit the behavior you seem to have encountered.

    If the message was accurate, you may have had something malicious interfering with the normal Windows 8 boot. So, I suppose I would check if the system could boot the Windows 8 or Ubuntu media in the Secure Boot mode. If you installed Ubuntu in UEFI mode, you would have already tested. If it can boot, that might mean the Firmware is OK but something else was involved in the original install.

    I have seen comments about actual firmware updates coming through the Windows Update system, but not sure if that is currently being done. If such an update had be done, it could account for problems with Secure Boot. Checking the ability of the system to boot in Secure Boot mode, should tell you for sure.

    If you reinstall and it happens again, maybe checking the certification of a couple of drivers might help track down the problem.

    I am not familiar with your Anti-Virus, but I suppose it never alerted? Did you get an update for it?
      My System SpecsSystem Spec

  7. #7

    Posts : 4
    Windows 8.1


    I'm afraid I don't know the answer to your question.

    As far as I remember, I just downloaded a bunch of updates and then I installed all of them after proper computer shutdown; two days later, I turned on laptop and, since that moment, I had been welcomed with this hateful red box:

    Click image for larger version

    No BSOD nor looping system restarts as reported in that website you linked to me: only this red box or BIOS menu when "Secure boot" was disabled. I really had no chance to do anything. I couldn't even run Windows in safe mode. Nothing at all.

    A few more words of disappointment: I was "victim" of Microsoft mistake and not of my negligence (that is what made me upset the most) and I also tried to download official Windows 8.1 iso file from official Microsoft website in order to make some kind of recovery/boot disk but neither my original product key printed under my laptop nor any of "generic product key" supplied in some geek websites were accepted from download program.

    My laptop is just 4 months old and I really couldn't accept it becoming unusable like that. Since my main worry was to retrieve some important data, my good luck made me think of Ubuntu as a portable OS for emergency cases and this is why I decided to move to Ubuntu and to definitely push Windows 8.1 out of my laptop after I retrieved those important data.


    I'd like to thank you for your info but now I guess everything is going fine for me. Actually I don't have any plan for future of my laptop as long as I feel comfortable with Ubuntu. However, if I find cheap Win7 serial key available for purchasing, I think I might make dual boot option (Ubuntu/Win 7). Surely I will not move anymore to Win8. As far as it concerns my Antivir, as you correctly guessed, it was already updated and never alerted (it never alerted "false positive" as well).
      My System SpecsSystem Spec

  8. #8

    Posts : 2

    if you want to solve this problem read here. After a long struggle, I solved this problem with the following words. I hope it will be useful to those who like me.
    Secure boot violation, invalid signature detected, check your boot policy error solutions | Knowers Tech
      My System SpecsSystem Spec

"Secure Boot Violation" error after recent Windows Updates
Related Threads
Hi all, So I'm kind of stuck.. I currently have the problem where I am in an endless cycle of "loading files" -> "Windows Boot Manager" (see: How To Boot Into Safe Mode On Windows 8 (The Easy Way)). I have tried to load all of the options -- and none successfully load. I also end up at...
Hi I reinstalled windows 8.1 on my Samsung NP530U3C-A10EE. And now the problem this that I can't boot it without usb stick that contains windows installation files. I can boot up windows and remove the usb stick evertything is working perfectly, but if I try to boot up win without usb, it gives...
Hello, Following the forum guidelines I am posting a compressed file from your SF Diagnostic tool. This was done shortly after a BSOD. Thanks for your support in helping me understand what is the cause of those frequent BSOD. Joce
Anyone successfully fixed the Could not reconnect all network drives error at boot? I get it most of the time with a wired Ethernet connection. I've done a lot of searching and tried different things but nothing seems to work. This started a few months ago, was not there initially with Windows 8,...
Windows 8.1 pro "0xC000021A" error at boot in BSOD Crashes and Debugging
hello everybody, suddenly today when i tried to boot my pc pc i faced the "0xC000021A" error. I have tried a lot of things such as safe mode, windows auto repair and "bootrec /fixmbr" & "bootrec /fixboot" commands but nothing worked...I am desperate... Thanks in advance for your help :)
hello all. I just got my new pc with MS Windows 8. I tried to set up the "People" app and I keep receiving an error which tells me that "Your password has changed. Please enter your password." Howvever there is no place to re-enter my password nor did I change my password. Since I get...
Co-posted at SevenForums: HTG Explains: How Windows 8′s Secure Boot Feature Works & What It Means for Linux - How-To Geek Microsoft Secure Boot Could Ban Windows From PCs | Wired Enterprise | ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook