Windows 8 and 8.1 Forums


Boot Menu is Always Shown During Bootup

  1. #1

    Boot Menu is Always Shown During Bootup


    So I may have touched some boot configurations before, I kind of forgot, I thought it was a good idea to always have the boot menu show up then. I was wrong, it was terrible. As it doesn't boot in to the system automatically, no countdowns were present.

    I'm trying to get rid of this issue, and I'm having a really hard time doing so.

    At first, I checked bcdedit, after Googling around, I thought maybe if I delete the entry "showbootmenu" in bootmgr it would solve the issue. Apparently not, it's still there.

    I had my bootmenupolicy set to Legacy, but even if I set it to standard, it still does the same thing.

    I tried using Easy BCD to reset my entire bcd, that led me to the point where I had to recover my boot partition.

    Tried setting msconfig to "Normal startup", it just keeps going back to "Selective startup" with everything checked.

    So yeah, I have no idea how to solve this, if anyone could help that'd be great.
    The following attachment is the BCD settings I currently have.
    Boot Menu is Always Shown During Bootup Attached Files

      My System SpecsSystem Spec

  2. #2


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Did you forget to add the attachment or is it coming soon ?
      My System SpecsSystem Spec

  3. #3


    Quote Originally Posted by David Bailey View Post
    Did you forget to add the attachment or is it coming soon ?
    Oops, fixed.
      My System SpecsSystem Spec

  4. #4


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    First, your bcd.txt is incomplete. From Admin command prompt, type: bcdedit /v /enum all
    will give more detailed info.

    Second, try to open msconfig and look in the boot tab and check if you have multiple entries in there. You should only have one entry on the list as shown in the screen shot:

    Click image for larger version
      My System SpecsSystem Spec

  5. #5


    Quote Originally Posted by topgundcp View Post
    First, your bcd.txt is incomplete. From Admin command prompt, type: bcdedit /v /enum all
    will give more detailed info.

    Second, try to open msconfig and look in the boot tab and check if you have multiple entries in there. You should only have one entry on the list as shown in the screen shot:

    Click image for larger version
    Updated, and msconfig appears to be normal.
    Boot Menu is Always Shown During Bootup Attached Files
      My System SpecsSystem Spec

  6. #6


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Yes the bcd.txt does look normal to me. We can try the Visual BCD to see if it can fix the problem:
    Download Visual BCD

    NOTE: If you are running Windows 64 bit, you'll get an error message pop up, just ignore it. Go thru the menu first and make a backup of the BCD first before attempt to do any repair.

    Good Luck. !!!
      My System SpecsSystem Spec

  7. #7


    Quote Originally Posted by topgundcp View Post
    Yes the bcd.txt does look normal to me. We can try the Visual BCD to see if it can fix the problem:
    Download Visual BCD

    NOTE: If you are running Windows 64 bit, you'll get an error message pop up, just ignore it. Go thru the menu first and make a backup of the BCD first before attempt to do any repair.

    Good Luck. !!!

    Oh thank gosh, this worked!
    EasyBCD broke my BCD configuration before, this didn't. No more boot menu, finally, that was annoying.

    Thanks! And now I know that such thing exists.
      My System SpecsSystem Spec

  8. #8


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Good to hear !!!
    BTW, do me a favor: Please re-run bcdedit /v /enum all again and attach it. I would like to take a look to see what got changed.
    Thanks.
      My System SpecsSystem Spec

  9. #9


    Quote Originally Posted by topgundcp View Post
    Good to hear !!!
    BTW, bcdeddo me a favor: Please re-run it /v /enum all again and attach it. I would like to take a look to see what got changed.
    Thanks.
    Here you go. I still couldn't quite tell what it has changed though.
    Boot Menu is Always Shown During Bootup Attached Files
      My System SpecsSystem Spec

  10. #10


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    I can see the differences:
    From the Boot Manager, it took out 2 entries:
    1. integrityservices Enable
    2. displaybootmenu No

    In addition, it re-created the Windows Bootloader for Windows 8.1 with new identifier

    Thank you for reporting back !!!
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Boot Menu is Always Shown During Bootup
Related Threads
Hello guys, I have dual booting Windows with Ubuntu, when I made something wrong to both of them, I had to reinstall both of them but then there are 2 Ubuntu boot option left in Boot Manager, the one with capitalized word is actually not working (itís boot into Windows instead of Grub). So my...
I've been dual booting both 7 and 8x for years, and both have been reinstalled as upgrade in-place repairs, and as far as 8 is, concerned, upgraded several times. I have always preferred the text mode, legacy boot menus, not least because they do not warm reboot when an OS which is not windows...
Hi guys, My sincere apologies for the long post but I'm trying to be as clear and detailed as possible from the start. I have W8 installed on 2 Samsung SSDs - one is 840 Pro and the other is 840 Evo. This is because I work on both video and music production and would like to keep things...
My Windows user has a pretty colour assigned in Metro and previously that was the only colour ever shown at boot-up. The Welcome screen and My avatar against that nice shade which I picked. But ever since I had to enable the Administrator account, an UGLY purple blue shade is shown for most of...
I have installed Blue 8.1 on a separate drive in my system along side 8.0. When I restart the 8.0 boots unless I manually select the 8.1 drive in bios. How can I alter the Boot menu to add the option to boot from either OS?
Graphical boot menu gone in Performance & Maintenance
Hi there. I am trying my best to get the graphical boot menu back, the one in blue. All I have is the text version, of black and white. I have followed the tutorial 5245-startup-options. Done it twice, with no success. Settings show all according to the tutorial: default is 'current', identifier is...
Ubuntu is not shown in boot options in Installation & Setup
hello i ace installed ubuntu 11.1 but i have no option to boot it after install ?!! i have installed it on: D>ubuntu i think the problem is in the windows boot system i tried: run:msconfig
Eight Forums Android App Eight Forums IOS App Follow us on Facebook