I have a new HP Envy laptop that came pre-installed with Windows 8.1 on a traditional hard drive.

Immediately on booting it up the first time, I connected an SSD to the laptop via a USB cable and used the Samsung-provided drive imaging software to image the entire HDD to the new/empty SSD.

Turned around & replaced the HDD w/the SSD in the drive 1 bay, followed by placing the original (but now secondary) HDD in the drive 2 bay.

I wanted to re-map the "My Documents" folder on the SSD to store files in that folder on the secondary HDD, so I remapped that folder ("c:\users\Brad\Documents") to point to "f:\users\Brad\Documents" instead.

So, moving on, for whatever reason now when I go to the Search item on the desktop and try, for example, to search for "Remove Apps", which results in it finding something like "Uninstall apps to save hard drive space" or something like that, and I click on Uninstall apps to save hard drive space", I get a msg. similar to this:

[Window Title]

Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.

I'm not sitting on my laptop right now, but I found the info. above online and it's very close to the error msg. I'm receiving, with the exception that instead of "c:\Users\bmccollum\AppData\...", the title of the msg. I'm receiving starts with "f:\Users\bmccollum\AppData\...". I don't recall remapping any other location at all aside from the "My Documents" location, so why is this search activity trying to search for the "AppData" folder on my now-secondary hard drive?

This same error msg. occurs when I search for another couple of items, but most everything I search for and click on works.

For the couple of items that I search for and I click on the item found and I get this error message, if I go into the items the "long way" but just clicking "Control Panel" or whatever else and go on from there, the items open up fine, it's just when I try to click on a couple of items after I've searched for something that they fail w/the similar error msg. from above.

I've searched around online and have tried the trick of "rebuilding indexes", and this seems to resolve the search-related errors for just a little bit, then a few minutes later I can search for the same thing that was previously causing the "Immersive Control Panel" error and bam, it's back again with that msg. similar to the one mentioned earlier.

Seems like something's pointing to "AppData" being on my "f" (secondary) drive when I don't believe I've moved anything but my "My Documents" folder from primary drive "c" to secondary drive "f".

I'm quite lost. Any other ideas on what the cause/resolution of this may be?

Thanks in advance.