Windows 8 and 8.1 Forums

Windows explorer Search doesn't work for Google drive fold

  1. #1

    Windows explorer Search doesn't work for Google drive fold

    When I open Windows Explorer (Windows 8.1) the search box on upper-right corner doesn't work in the Google drive folder. It works on all other folders. That is: when I enter the name of a file inside this folder, the search returns "0 items".
    Click image for larger version

      My System SpecsSystem Spec

  2. #2

    Posts : 1,875
    Windows 10 Pro Prieview x64
      My System SpecsSystem Spec

  3. #3

    You might also be interested in Agent Ransack:
    Agent Ransack - Free File Searching Utility

      My System SpecsSystem Spec

  4. #4

    Quote Originally Posted by adamf View Post
    Thanks Adamf, but I tried it and it doesn't work. I've also rebuiilt the index and made sure Google drive folder was included in the indexing ("C:\Users\ANTONIO\Google Drive") and it doesn't work either.
      My System SpecsSystem Spec

  5. #5

    SOLVED (for Windows 10, I guess for 8.1 it should work as well)!.
    I got this answer in google drive forum:

    Hello Antonio,

    Thank you for contacting us. Try this:

    Go to the actual folder in its C:\Users\<your name>\Google Drive\ (NOT the Google Drive folder listed under 'FAVOURITES' which is a shortcut).
    Right click 'Google Drive' > Security tab > Advanced > Click your username (mine showed <not inherited>) > Click 'Change Permissions' > Check the 'Include inheritable permissions...' box > Click ok.
    Search indexing of Google Drive should then begin in the background.

    On Windows 10, the steps might be slightly different: After selecting your username on the Advanced page, click 'Enable inheritance' on the bottom left corner. After pressing 'ok' go back to indexing options and add the Google Drive folder (again, not the shortcut, but from the Users folder)

    Let me know if that helps. Best of luck to you!

    Just to add: A user pointed out that you may need to set permissions.

    First check the permissions of the "Google Drive" folder. If you do not see an entry for "SYSTEM" with full permissions then follow these steps to set it up:

    1. Navigate to the location of the "Google Drive" folder. It will be something like "C:\Users\[USERNAME]"
    2. Right click on your "Google Drive" folder and select "Properties".
    3. Select the "Security" tab.
    4. Click "Edit"
    5. Click "Add"
    6. Type "system" (case is NOT sensitive) and Click "OK"
    7. Check the top box for "Full control" (this should select all the boxes able to be modified)
    8. Click "OK" and wait while it applies the permissions. (the time this will take depends on the speed of your computer and the number of files in your "Google Drive" folder)

    Hope that helps. Best of luck to you!

    -Tyler M

    It worked!: I had to remove and then add the
    google drive folder in indexing though, then it instantly indexed and search worked.Many many thanks, I've been chasing this problem since Windows 7 and Windows 8 then 8.1 (I think I tried something like this in 7/8.1, though, advised in another forum answer, strange). I didn't need to permissions for system, just the inherit stuff for my administrator user.

      My System SpecsSystem Spec

Windows explorer Search doesn't work for Google drive fold
Related Threads
Hello, I find when I press the Windows key, or open the Start Screen and start typing, nothing happens. Usually the sidebar opens with search results, but recently it has stopped working completely. Also, the search charm on the sidebar, and the search button on the Windows 8.1 (update) Start...
Sounds odd, I know. But if I try to load up a Windows Explorer screen after I've closed and re-opened my laptop at any point post-startup, it doesn't work. Just a blank window and the blue loading circle next to my cursor. It also means that I can't double click a shortcut to load an...
I recently upgraded my 3 computers to Windows 8.1. Only 1 PC (INTEL) is working as it should. The other 2 PC's are AMD based and the search function is acting funny. When I search it gives my the results, but when I click on says I'm looking for DEVICES AND PRINTERS and I search "printers", it...
Hi everyone, I've had this problem for the better part of a month now, I was hoping the update from 8 to 8.1 would fix it but no luck.In a nutshell: Windows search for Files stopped working out of nowhere, searching for Apps/Settings works fine, but searching for Files yield no results, not only...
Windows explorer doesn't work in General Support
Just updated to 8.1 yesterday. Since then, there have been issues. If I left click on the Folder Icon in the task bar or right click and select "File Explorer" I will get the usual blue circle telling me to wait, except the window never appears. Instead the screen changes "purple" as if the...
Solved Search doesn't work in Performance & Maintenance
My search feature isn't working.:shock: This is the main search that should start with you typing while the metro screen is up. Some time ago it just disappeared. I've tried a couple of things to get it to work, but I can't. Can anyone run me through trouble shooting it? Thanks, Gn13l
Eight Forums Android App Eight Forums IOS App Follow us on Facebook