Windows 8 and 8.1 Forums


laptop win8 pro stops at start up with 4 GB memory

  1. #1


    Posts : 5
    win 8.0 pro NL

    laptop win8 pro stops at start up with 4 GB memory


    HI forummembers,
    i'm new here, but have a big problem with my laptop.
    due to the fact that it is a compaq610 notebook pc and i have upgraded him to win 8 pro the machine was going veeeeeery slowly. so i bought 2x 2GB DDR2 PC2 6400 sodimm ram.
    when i put in 1x 2GB there is no problems except its still to slow.
    HP says that there can be a upgrade till 4 GB 2x2GB, so i bought that and when i installed it the win 8 start up hangs when the win8-loge appears and than the dotted circle stops and everything freezes!

    when i go into the bios, i can check the memory so check of 4 GB of memory goes well until 24% than the grafics does strange blocked screen n different colors.
    Stranga that each mem of 2GB single placed works fine.

    so who can help me to get the 4GB working on my laptop?

    thx in adv
    hitman1961

      My System SpecsSystem Spec

  2. #2


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    As long as it is known good RAM, unbuffered, non-ecc, dual channel it should work. Where did you get the new RAM from? Does it show up in the Bios, when you look in there, to see if the total RAM installed is correct.
      My System SpecsSystem Spec

  3. #3


    Posts : 5
    win 8.0 pro NL


    hi broe23,
    ik bought the mem in a store.
    in the bios it appears as 4GB!

    grs
    hitman1961
      My System SpecsSystem Spec

  4. #4


    The 4GB module may be bad. Wouldn't be the first new one to be defective.
      My System SpecsSystem Spec

  5. #5


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Quote Originally Posted by Ztruker View Post
    The 4GB module may be bad. Wouldn't be the first new one to be defective.
    Nor will it be the last. Same as a store giving the wrong type of RAM module to a customer.
      My System SpecsSystem Spec

  6. #6


    Posts : 5
    win 8.0 pro NL


    Ztruker,
    its 2 x 2GB memory.
    both modules work fine seperatly and also changing from slot.
    So i thnik there is nothing wrong with the memory itself.
    also it is recognised in the BIOS!

    further it is accordingly to HP specs.

    HP i have seen in many topics, but they don't have a satisfactionary answer/solution.
    BUT it has to work they say!

    i read something about the processor that maybe can't handle 4GB???? mine is a intel celeron 560 2,13GHz
    never heared about this, maybe its true.

    hope that someone can help me.

    o yeh,
    i renewed my win8.0 pro installation.
    to bad, it didn't help

    hitman1961
      My System SpecsSystem Spec

  7. #7


    Posts : 22
    Windows 10 1703


    If it's a laptop and the manufacturer told that it can handle 4GB of RAM, I really don't see a reason why any of its parts (CPU included) won't.

    Ztruker might have a point here, maybe the RAM itself is faulty (this would also explain the graphic glitches during tests, as maybe the video card shares the onboard RAM).

    Have you already tried doing a Memtest, just for the sake of being sure? You could burn an ISO on purpose, or (more convenient if you already have one at hand) you'll find it on any Linux Mint install media (and I believe in many otherdistros).
      My System SpecsSystem Spec

  8. #8


    Posts : 5
    win 8.0 pro NL


    thx Julio for the reply,

    but i told the forum that the mem is recognised in the BIOS! 2 or 4 GB no problem
    also the mem i tested separetly in both slots and again no problem.
    BUT 2x 2GB = 4GB the laptop starts win 8 untill the start of the logo with the circle turned half way.

    indeed i did a memtest from the BIOS.
    as mentioned it stops at 24% and gives blocks on screen and strange colors.
    with both 2 GB seperate trying no problem.

    so what can it be?

    hitman1961
      My System SpecsSystem Spec

  9. #9


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    Are they matched modules? Two different speed modules can cause issues when run together. Modules from two different manufacturers , even if they have the same specs, can also cause issues when run as a pair. It doesn't happen very often but it does happen from time to time. If the BIOS has a dual channel option that can be turned off I would disable that function. You may have to buy another identical module from the same manufacturer to get it to work.
      My System SpecsSystem Spec

  10. #10


    Showing in BIOS or passing Memtest is not anywhere near as good a test of RAM as running windows.


    I still think you should remove 1/2 (2GB) and test. If the same, swap ram and test again. Doesn't cost you anything but time.

    Just my $.02 worth.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
laptop win8 pro stops at start up with 4 GB memory
Related Threads
I have been having an issue recently with my Windows 8 HP laptop (i'm not too sure of the exact model at the moment) where it'll just stop playing videos (whether if streamed through the internet such as you tube or if played on the actual computer as a downloaded video) or the sound for said...
Hey. I've experienced a problem with windows 8.1 ever since building this pc. Basically, when using my pc, at random times the start menu stops working. I.e, when I click the start button, the menu does not come up, right click does not also work to bring up the power menu. The sidebar ...
Hello everyone, I have a problem with the updating of my adapters. This happens sometime after one hour sometimes after a week. The computer works just fine afterwards aside that I can not use any Lan adapter anymore or any other adapter like usb. When I shut down my Laptop afterwards it always...
Hi All I have a clean install of windows 8.1 and the sound was working but the sound quality was poor/bad so I did some digging around to try and fix the sound quality which didn't work by the way and now my sound randomly stops eg. watching YouTube pause then come back and no sound, restarts...
I have 2 network hardrives attached to my router as central storage. I mapped these drives on my PC and pinned shortcuts to Win 8 Start menu. But everytime I hibernate the PC and come back afterwards, the shortcuts are somehow disconnected to the source. I keep pinning these shortcuts but also...
Win8 Setup does not recognize memory in Installation & Setup
Hello, I tried to install different versions of the windows 8 preview (everything 64bit) and it always shows me the error that my system needs at least 2gigs of RAM and Windows cant be installed. I have 2 sticks of 2gb ram installed, tried using only one of them, but nothing seems to work. Is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook