Windows 8 and 8.1 Forums


PC hangs at post screen when external HDD is attached

  1. #1


    Posts : 14
    Windows 8

    PC hangs at post screen when external HDD is attached


    I'm running 8.1 on a newly purchased Acer TC-603. It's a dedicated machine for a networked video recording system. It runs Blue Iris, and records from about 25 IP cameras, storing the images on an external 4TB USB3.0 HDD.

    Everything works as it should, until the system reboots or powers up. At that point, I get past the post screen, where it detects two SATA drives (the internal SSD and the internal DVD), but then hangs. It will not continue. I have to turn off the PC (or ctrl-alt-del) and pull the USB cable from the external drive before it will load into W8.

    I've read other accounts of this happening, and have tried the various suggested solutions (i.e. disable USB legacy support in BIOS), but nothing seems to be working.

    I'm quite familiar with changing the boot order on all of my other PCs (W7). But on this machine, the options are limited to "Windows Boot Manager", removable media, LAN. But how does one tell the WBM to only look at the internal SATA connected drive, and ignore the USB drive?

    I've never seen a BIOS that had Windows Boot Manager listed.

    I've turned off secure boot. I've disabled legacy USB. I've disabled the Launch CMS feature (with then allowed the PC to detect USB thumbdrives on the f12 boot menu). But no matter what I do, I HAVE to remove the external HDD for the system to boot.

    Needless to say, for a security-sensitive application, having a PC that relies on the HDD for storing video removed is not an option.

      My System SpecsSystem Spec

  2. #2


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    If your HD is corrupted then it might cause the PC to hang at boot up. I suggest that you run chkdsk from the elevated command prompt:

    chkdsk X: /r /f where X is your external HD.
      My System SpecsSystem Spec

  3. #3


    Posts : 14
    Windows 8


    Thanks, TG. I am currently moving the files off of the drive. Once that finishes, I'll do the chkdsk. FWIW, I tried to convert the disk to dynamic - at which point it warned me that the drive would no longer be able to boot an OS (YEA!) - but when I committed to the task, it reported "Virtual Disk Manager: The operation is not supported by the object." It's currently formatted with a single partion, GPT.

    1hr 15 min to go on the transfer. I will post back what I find.
      My System SpecsSystem Spec

  4. #4


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Why would you want to convert to dynamic disk ? Dynamic disk provide features such as the ability to create volumes that span multiple disks (spanned and striped volumes) and the ability to create fault-tolerant volumes (mirrored and RAID-5 volumes). Are you using any of those features on an external HD ? I doubt it.
      My System SpecsSystem Spec

  5. #5


    Posts : 14
    Windows 8


    I just want to do something, anything, so that the OS recognizes this as a non-bootable drive. Other than formatting, I don't see any other options that explicitly cause the drive to be non-bootable. Admittedly, I am not familiar with what the other pro/con issues are.
      My System SpecsSystem Spec

  6. #6


    Posts : 14
    Windows 8


    Ok, so the elevated command prompt chkdsk completed:


    C:\WINDOWS\system32>chkdsk H: /r /f
    The type of the file system is NTFS.
    Volume label is BlueIrisA.

    Stage 1: Examining basic file system structure ...

    256 file records processed.
    File verification completed.
    0 large file records processed.
    0 bad file records processed.

    Stage 2: Examining file name linkage ...

    280 index entries processed.
    Index verification completed.
    0 unindexed files scanned.
    0 unindexed files recovered.

    Stage 3: Examining security descriptors ...
    Security descriptor verification completed.

    12 data files processed.
    Stage 4: Looking for bad clusters in user file data ...
    240 files processed.
    File data verification completed.

    Stage 5: Looking for bad, free clusters ...

    976646166 free clusters processed.
    Free space verification is complete.
    Windows has scanned the file system and found no problems.
    No further action is required.

    3815316 MB total disk space.
    113728 KB in 7 files.
    0 KB in 14 indexes.
    0 KB in bad sectors.
    186208 KB in use by the system.
    65536 KB occupied by the log file.
    3815024 MB available on disk.

    4096 bytes in each allocation unit.
    976721151 total allocation units on disk.
    976646167 allocation units available on disk.

    C:\WINDOWS\system32>
    After 7 hours, no errors found. My father, who bought a similar acer model (TC-605 vs. my TC-603) has the exact same issue. With any external drive attached, the PC hangs at the post screen just after recognizing the two internal SATA drives.

    Any other ideas on how to get Windows Boot Manager to ignore the attached HDD?
      My System SpecsSystem Spec

  7. #7


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    I don't think you can disable to bypass the USB at boot. Let us try something else:
    1. Run regedit and go to: HKEY_LOCAL_MACHINE\SOFTWARE\Intel\InfInst
      the version should be: 10.0.20
      if not, then download the latest version of Intel Chipset drivers. This will updates all the drivers on your MB including the USB.
    2. Check with ACER if you have the latest BIOS firmware installed.
      My System SpecsSystem Spec

  8. #8


    Posts : 14
    Windows 8


    Apparently my Intel version is 9.2.0.1015. Going to upgrade now...

    Edited to add: The version is actually 9.4.0.1017, which Acer claims is the most recent version. Intel's website doesn't have support for this board as it's an Acer product. If I were to guess (Series 8 board), I could download the 9.4.0.1027 driver - which was released the same month of 2013.
      My System SpecsSystem Spec

  9. #9


    Posts : 14
    Windows 8


    And, it would appear the BIOS installed is the most recent (P11-A4).
      My System SpecsSystem Spec

  10. #10


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    The version is actually 9.4.0.1017, which Acer claims is the most recent version. Intel's website doesn't have support for this board as it's an Acer product. If I were to guess (Series 8 board), I could download the 9.4.0.1027 driver - which was released the same month of 2013.
    The Intel chipset drivers will work with any intel based MB. It does not matter if your laptop is ACER, DELL etc...
    Since it came from Intel, the manufacturers sometimes fail to update it, therefore You would have to download directly from Intel
    https://downloadcenter.intel.com/Det...eng&ProdId=816
    The latest version listed from Intel is 10.0.13.
    FYI, since the latest version is: 10.0.20, for my MB, I downloaded this version from a european site:
    Intel
    If you wish to try this. Make sure you create a restore point before the installation.
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
PC hangs at post screen when external HDD is attached
Related Threads
So... I've got one of the older 64-bit mobos that Windows 8 does not like for some reason. Everything installs fine up until reboot, when Windows 8 hangs on the splash screen. Google reveals many people having this problem and after trying many things I was able to get it install by setting...
Windows 8 Hangs/Freezes Splash Screen in Installation & Setup
Hi guys! I am having trouble installing windows 8 on my PC. I would say I am quite experienced with installing windows operating systems and I have done so many times successfully but this time I need help and advice! So I slow burnt the ISO as I always do, and verified the contents. Now I...
Hi, while I am not new to Windows 8, I am new to Windows 8.1 Pro. First I installed 8.1 Pro from a dvd, restarted it, no problems... then installed the updates, then when I restart, it hangs on restart screen.... so I have to reboot. I got fed up doing that so I formatted the hard drive,...
Hi there i looked through many netflix error post here. but could not find a solution on my problem My netflix metro app just hangs on the red start screen with the Netflix logo I tried many things to fix. Like empty cache for metro apps, rename files to .OLD and so on.. I of course...
Whenever I go to empty my recycle bin, my external seagate spins up. I looked at the properties and the drive is there listed as primary. I change it to "C" and it eventually defaults back to the external. why is this happening and how can I fix it permanently
The short story: I've got two Windows 8's on a machine: one OEM and one retail Pro which I just installed. The light-blue "OS Selector" screen which it boots to will hang after about 10 seconds. Within those 10 seconds, I can click to boot the OEM Windows 8, and it will boot fine. If I select the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook