Heres the deal, i had windows 7 laptop with all my things it worked great until it got wet. The HDD was in perfect condition, I took it out the HDD and started using it on my ubuntu computer, (via sata to usb adapter) i had 2 partitions on this drive, /C with windows and all my important documents and files and /D with movies. I hooked it up to my ubuntu an i was able to access /D but not /C after searching around i found out i had to use a few cmd`s to get it to work and it worked (yay) i was able to access everything and do anything on both partitions. Now fast foward a few months later i have a windows 8 laptop. I am able to read and write on /D , which as changed to the letter /G. I am UNABLE to access my /C (which is now /F).

When i try to open it it says "/F is not accessible. access is denied"
I cant see how much data is used or free.

i have searched the internet for a few hours and found no solutions
i have tried taking ownership, but nothing happens
i have tried going to properties>security and adding permissions, and get:
"An error occurred while applying security information. F:/ Failed to enumerate objects in the container. Access denied" followed by "unable to save permission changes to local disk (F Access denied"
i have tried going into device manager and uninstalling the drivers then restating the computer, but nothing changes.
there is a windows action center notification saying something "scan drive for errors" but again nothing happens

I CAN use it on my ubuntu laptop without a problem.

Im at the end here so im turning to the windows 8 forum community
Hopefully someone can help my here
(i am not super techie but i can handle the basics)