Windows 8 and 8.1 Forums

"Add or Remove Programs" doesn´t work anymore (in Metro)

  1. #1

    Posts : 3
    Win 8.1

    "Add or Remove Programs" doesn´t work anymore (in Metro)


    I had an issue with the general user folder name, which was shown as "Alex_000".
    Although this was a cosmetic issue only, I wanted to change this to "Alex".
    I successfully managed this by changing about 50 entries in the registry (via regedit).

    So fine so good.

    Now I found out that there are still some leftovers with "Alex_000" in the Windows system, although I have tried to find every bit and peace, where possible:

    When I try to open "Add or Remove Programs" in the Metro surface, I get an error message:

    Windows cannot find

    'C:\Users\alex_000...\Classic_{a lot of weird numbers and chars}.settingscontent-ms'.
    Make sure you typed the name correctly, and then try again.

    From another forum topic, i also tried this command via Metro and RUN to see, if the Remove service has a general problem:

    C:\WINDOWS\System32\rundll32.exe C:\Windows\System32\shell32.dll,Control_RunDLL "C:\Windows\System32\appwiz.cpl",Add or Remove Programs
    --> With this, i can open the Remove service without a problem.

    Somewhere in the system, there must still be the Alex_000 info hidden.

    How can i find this? (Tried the registry, tried a simple search on C: disc, but without success)

    How can I solve this?

    Thanks a lot!


      My System SpecsSystem Spec

  2. #2

    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit

    The obvious answer is to change it all back to Alex_000. Renaming a system folder doesn't usually go well.
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Win 8.1

    Quote Originally Posted by alphanumeric View Post
    The obvious answer is to change it all back to Alex_000. Renaming a system folder doesn't usually go well.
    Well, as you can see from my first post, I didn´t just change the user folder name. I was also making the changes to the registry.

    Everything works fine - except of starting the apps from the metro surface for "remove software", or "user accounts", and maybe some other system apps, which I haven´t discovered yet. If I do the same from the desktop, no problem - all these apps work well.

    So where are the referring links for such system apps within the metro surface stored? Obviously not in the registry...

    Last edited by alleex; 17 Jul 2014 at 04:07.
      My System SpecsSystem Spec

  4. #4

    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    Hi there

    To get the names of these Metro apps and where they are stored - you don't need any Registry manipul;ations.

    If you follow my post on creating cascading menu for metro apps it shows you with screen shots on how to get the names of these things - you can then do with them what you like.

    Metro apps - desktop / taskbar / create cascading menu

    (You don't have to create the toolbar -- but in the post are shots of how to obtain the names and where they are located - No registry stuff neeed).

      My System SpecsSystem Spec

  5. #5

    Posts : 3
    Win 8.1

    That looks very promising - will look at this in the evening, when I have access to my private laptop again. Thanks!
      My System SpecsSystem Spec

  6. #6

    In case someone else is also facing the same problem, the solution that worked for me is
    go into the metro PC settings, then to Search and Apps and clear the history
    Source: Cannot access immersivecontrolpanel? : techsupport
      My System SpecsSystem Spec

"Add or Remove Programs" doesn´t work anymore (in Metro)
Related Threads
I hate it when I double click a file and Windows 8.1 pops up a message saying I have other apps that can handle this extension. I disabled this notification through GPEDIT.MSC, it works now when I open pics/docs/etc.... but let's say I install another app, for example, when I install Pale Moon...
i installed a video converter sometime ago named "wondershare" video converter & I recently noticed in "internet options" under the "security" tab when i select "trusted sites", a website is listed that I have never entered & allowed. I remove the website and when i apply the changes then close the...
Hello all, am running Win 8.1 Pro x64. Today I noticed that the "Eject" option from the right-click menu doesn't work for either of my 2 CD-Rom drives, nor for a "virtual" drive - I get the same error message on all 3: "An error occured while ejecting ". Device Manager shows no errors, and I've...
I recently installed Windows 8.1. I didn't like all the folders under Computer so I registry tweaked it to remove all the libraries folders. However, later on, I accidentally dragged the Downloads folder from Favorites onto the Computer tab and now there's a Download folder listed under Computer...
Just wondering if Win 8.1 somehow made available a "all programs" list view (as per win 7 start) versus the highly undesirable Metro all programs view ? Can't find any evidence of it ? Is there a way to boot into desktop view directly (as opposed to metro view) yet ? Or am I going to have to buy...
Hey guys! I am new to this forums, and I have my metro apps basically sitting there in start menu, and pretty much none of them works. Mine is Windows 8 pro and I can't even login to a Microsoft account in Users settings. The only thing that seems to work is Windows Update, and no app that needs...
Read more at: Microsoft: “Metro” out, “Windows 8-style UI” in, amid rumors of a trademark dispute | Ars Technica
Eight Forums Android App Eight Forums IOS App Follow us on Facebook