Windows 8 and 8.1 Forums


Weird External HDD Bug On Windows 8.1

  1. #1


    Posts : 8
    Windows 8

    Weird External HDD Bug On Windows 8.1


    Well, everytime I try to plug up my External HDD this is how it looks.







    Link: Gyazo - 63e9f366e17d16003614ab592f2429e3.png if the picture can't be seen above.

    Windows reads it as being plugged up but a "Please insert a disk into Removable Drive (F):" comes up when I click it. It also looks and acts the same way when I unplug the External HDD as if it is still plugged in my PC. I have tried googling a solution to this problem but I have had no luck. Any help would be appreciated and thanks in advance.

      My System SpecsSystem Spec

  2. #2


    Is that external HDD formatted ? Does it need drivers ? Can you see it from disk management ? Looks like win thinks it's a CD/DVD drive.
      My System SpecsSystem Spec

  3. #3


    Posts : 8
    Windows 8


    Quote Originally Posted by CountMike View Post
    Is that external HDD formatted ? Does it need drivers ? Can you see it from disk management ? Looks like win thinks it's a CD/DVD drive.
    Never been formatted. It's worked before actually but one day it started acting like this, so as of right now no clue if it needs drivers. This is what I get in Disk Management: Gyazo - e8d04fc313d9e0282e2130a0b321f9c7.png. Thanks for the reply.
      My System SpecsSystem Spec

  4. #4


    Looks like it does not have partition defined and is not formatted if it works at all. If you don't have anything on it worth bothering to try to retrieve, you can try to make a partition in disk management.
      My System SpecsSystem Spec

  5. #5


    Posts : 8
    Windows 8


    Well, I actually need everything on it. I'm not sure what went wrong actually as it was working fine before. I mean it can't be the External HDD because when I unplug it from the PC, the Removable Disk (F): thing still remains there as if it was still plugged up and gives me the same error I mentioned at the start of this thread. I'm at a loss on what to do here :/.
      My System SpecsSystem Spec

  6. #6


    Quote Originally Posted by WestsideOutlaw View Post
    Well, I actually need everything on it. I'm not sure what went wrong actually as it was working fine before. I mean it can't be the External HDD because when I unplug it from the PC, the Removable Disk (F): thing still remains there as if it was still plugged up and gives me the same error I mentioned at the start of this thread. I'm at a loss on what to do here :/.
    Maybe, just maybe, can you change letter for it ?
      My System SpecsSystem Spec

  7. #7


    Posts : 8
    Windows 8


    Tried that but no luck
      My System SpecsSystem Spec

  8. #8


    Ok, how about trying this program to salvage data from it: http://www.***********/datarecoveryw...y-software.htm after, you can format or do whatever it takes to get it working.
      My System SpecsSystem Spec

  9. #9


    Posts : 2,627
    win8.1.1 enterprise


    Quote Originally Posted by WestsideOutlaw View Post
    Well, I actually need everything on it. I'm not sure what went wrong actually as it was working fine before. I mean it can't be the External HDD because when I unplug it from the PC, the Removable Disk (F): thing still remains there as if it was still plugged up and gives me the same error I mentioned at the start of this thread. I'm at a loss on what to do here :/.
    it might have worked before but hdd are like people ,working one minute gone the next , you need to plug it into another computer it check if it works ,if it fails to work then ,its issues are serious ,and need to be looked at by someone in the know
      My System SpecsSystem Spec

  10. #10


    Quote Originally Posted by caperjack View Post
    Quote Originally Posted by WestsideOutlaw View Post
    Well, I actually need everything on it. I'm not sure what went wrong actually as it was working fine before. I mean it can't be the External HDD because when I unplug it from the PC, the Removable Disk (F): thing still remains there as if it was still plugged up and gives me the same error I mentioned at the start of this thread. I'm at a loss on what to do here :/.
    it might have worked before but hdd are like people ,working one minute gone the next , you need to plug it into another computer it check if it works ,if it fails to work then ,its issues are serious ,and need to be looked at by someone in the know
    Like very finicky people too.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Weird External HDD Bug On Windows 8.1
Related Threads
Weird MSI/Windows 8.1 error? in Installation & Setup
I recently had to reinstall Windows 8.1 because of a boot issue, but now the way the PC boots has changed. Here's the boot issue before I reinstalled: 42865 It takes longer, and this time I see flashing white lines before Windows 8.1 boots. In particular, MSI Fast boot no longer works,...
Solved weird external usb drive problem in Drivers & Hardware
i have to external usb HDD one 2tb and the other 1tb. before i installed win 8 i copied all the info from the 1tb to the 2tb and then formatted the 1tb to NTFS using Gparted in manjaro. installed win 8 and it could see the 1tb hdd and i could access it. i have to use paragon to access the 2tb...
Weird problems after restoring Windows 8 in Performance & Maintenance
Hello, I had some heating problems with my laptop and it turned out that it is the hard disk and I had to replace it. To keep my configured Windows and all applications I have made a backup which I installed on the new hard drive. Now I have some issues with my Windows that I can't resolve -...
Weird Windows 8 problem?! in General Support
Hi everyone, hope somebody can help me here... I booted up my laptop as normal and all of my programs and documents are missing. Desktop background and all settings are ok, my internet connected is still saved and my deleted items are still in the recycle bin. Really odd. Got about 6 months...
Windows 8 weird after updates in General Support
Hello :) After i updated my Windows 8 a few days ago, i have some issues now, it is confirmed on other PC's aswell. 1. Language is now strange, see screenshot: 1721817219 2. Cannot uninstall programs (sorry is in Dutch, but it states: Something went wrong when trying to unistall ARMA 2...
Weird Weird Problem! in Network & Sharing
I have the strangest problem with my internet since updating to W8. My internet works absolutely fine all day, up until later in the day (not sure what time exactly this happens) but it stops working! It says it is connected but it simple can't find a network. I am connected via LAN to an...
Weird Windows 8 DP BSOD. in BSOD Crashes and Debugging
I installed the Windows 8 Developer Preview, then, after switching to desktop mode, and leaving the computer in idle for some minutes... this BSOD appears: "SYSTEM_THREAD_EXCEPTION_NOT_HANDLED". - It doesn't point to any driver or program, nor gives me any error code. It then saves the memory...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook