Windows 8 and 8.1 Forums

Opening WinExplorer with pre-defined dir does not work

  1. #1

    Posts : 17
    Windows 8

    Opening WinExplorer with pre-defined dir does not work

    I want to setup a shortcut which (when double clicked) opens Windows Explorer with a pre-defined directory.

    Under Windows 7 users could setup a shortcut with auto-expansion and auto-marking that directory (sample: C:\data) in left side tree view with the following command:

    %windir%\explorer.exe /n,/e,C:\data

    It works fine in Win 7.

    When I try to setup the same cmd/shortcut in TaskBar of Windows 8 it does not work resp. does work only partially.

    Yes, on the right side the content of C:\data is shown.
    But on the left side tree view the tree is NOT expanded and the directory C:\data is NOT marked.

    How else can I achieve auto-expansion + auto-marking in Win 8 analog to the Win 7 command?


      My System SpecsSystem Spec

  2. #2

    Posts : 22,565
    64-bit Windows 10

    Hello Peter,

    You could have Expand to current folder turned on for the navigation pane to have it expand to Data.

    Navigation Pane "Expand to Current Folder" - On or Off

    In addition, you could use this below instead to also have it do so without Expand to current folder turned on, but it opens Data as a separate group in the navigation pane.

    %windir%\explorer.exe /n,/e,/root,C:\data
      My System SpecsSystem Spec

Opening WinExplorer with pre-defined dir does not work
Related Threads
I have checked everywhere online, and I haven't found a single explanation for this. I have 3 user accounts. 1. Administrator 2. initial user 3. new user So the initial user is the one you are forced to create when first setting up Windows 8.1. It's a local user meaning that I set it up...
Alright guys, Windows update has been really messing with my pc lately. I ran update and when it installed the updates my integrated mouse ended up not working. I rolled back update and installed the updates one by one and the one I ended up not installing was the camera codec pack. Now the problem...
Alright guys, I have just refreshed my pc because I was having numerous problems with it and it turned out to be a bad stick of RAM. However, now I am having software issues. Whenever I try to make a call on the desktop version of skype, the program crashes. Whenever I try to open HP support...
Facebook not opening. in Browsers & Mail
I have internet explorer and chrome. i did everything, reinstall, restart, deleted cache, deleted browsing history, but facebook would not load though it works fine for sometime after I do any one of the above solutions. All other websites are working perfectly fine!
Solved Programs not opening in Software and Apps
Hi everybody I've just recently got a new laptop with windows 8 and everything was working fine until today. I tried to install google chrome but the launcher won't open and now this is happening for most program's. I checked the task manager and the program's I try to run are in background...
I wanted to install the CP to a partition I defined on my eSata drive. But it never gave me any option to select a partition. It just installed it into my Win7 C partition. Fortunately I had anticipated trouble and had made a Win7 image before I tried to install the CP. Now I got rid of the bugger...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook