Windows 8 and 8.1 Forums

Class not registered

  1. #1

    Posts : 1
    Windows 8.1

    Class not registered

    For the past couple of days I have been trying to fix an error I am getting when I try to open folders and drives in file explorer and things like recycle bin, control panel, programs and features, system etc where it says "class is not registered" and won't open. I have tried sfc /scannow which completes with no errors but when i try the dism tool it says source files cannot be found and I have checked the log file and it says this:
    Operation: Detect and Repair
    Operation result: 0x800f081f
    Last Successful Step: Entire operation completes.
    Total Detected Corruption: 47
    CBS Manifest Corruption: 1
    CBS Metadata Corruption: 46
    CSI Manifest Corruption: 0
    CSI Metadata Corruption: 0
    CSI Payload Corruption: 0
    Total Repaired Corruption: 0
    CBS Manifest Repaired: 0
    CSI Manifest Repaired: 0
    CSI Payload Repaired: 0
    CSI Store Metadata refreshed: True

    Could this be causing the class not registered error? I would be really grateful if anyone could help me with this as it's been driving me crazy the past couple of days. I have included the cbs.log and the dism log also.
    Class not registered Attached Files

      My System SpecsSystem Spec

  2. #2

    Posts : 9
    Windows 8.1

    Hi cunny, can you try creating a new user profile and seeing if it has the same issue in the new profile? You could have a corrupted windows profile. Those are a bit more difficult to repair on Microsoft accounts, but it can be done. If you confirm to me that the profile is corrupt I'll tell you how to repair one.
      My System SpecsSystem Spec

Class not registered
Related Threads
Read more... Download at: VLC for WP Beta | Windows Phone Apps+Games Store (United States)
Whenever i click on an app it says class not registered i have tried everything system restore dosent work and i cant run cmd as administrator to change anything apparently both of them have the same problem (class not registered) i even tried download .reg files that didnt work.... ive...
PC not registered in APP Store in Software and Apps
One of my students deleted my PC from my all store. Now, I cannot open existing apps, nor download new ones. What I gonna dooo?
Hello everyone, thank you in advance for your assistance on this. I just spent about an hour searching this forum and other places on the web and have not been able to find any kind of solution to my problem. Here's my issue; I am a math and science teacher in a public middle school and am...
Hello everyone, I recently purchased an SSD to upgrade my Dell Inspiron 17R SE 7720 that runs Windows 8. This is the SSD I purchased and it came with cloning software: Samsung Electronics 840 EVO-Series 250GB 2.5-Inch SATA III Single Unit Version Internal Solid State Drive...
First class in Chillout Room
Today I am attending the first class of my degree..
Eight Forums Android App Eight Forums IOS App Follow us on Facebook