I searched the subject in this and SevenForums. Things start on Windows 7 and move on to Windows 8.

I have a Windows 7 64bit system with internal and external hard drives. I bought 2 X 3Tb external hard drives and they worked fine so I bought 2 X 3Tb internals and formatted them as GPT etc and they worked fine. I then bought a 4Tb external and that too worked perfectly.

So I bought a 4Tb internal fully expecting it to work but, try as I did, I could NOT get the 4Tb drive to be recognised as such. I tried GPT and everything suggested by everybody.

The system would see the drive as 3,815Gb but create a partition 1,718Gb in size. Everybody talked about the 2.2Tb limit and GPT and UEFI bios. But I had a 4Tb external working perfectly. I contacted Gigabyte, they said I should be able to create a data disc of 4Tb but I couldn't. Nobody could explain why.

My W7 desktop was getting old and my 2Tb drives were slowly failing so I had to buy a new system that would accept 4Tb drives.

I bought a new system and the 4Tb drives were accepted easily and perfectly.

Then I thought, with all the extra ports, I would crack open one of the 3Tb externals and install it internally. I did, the w8.1 new system couldn't see the drive.

Looking in Disk Management the drive showed as 3 partitions. The first RAW and the second and third "unallocated".

A bit of thought and the answer presented itself.

The 4Tb was accepted on the W7 system because the USB to SATA interface created 3 partitions and hid this from the system. DM saw the EXTERNAL as one partition but saw it with 3 partitions as an internal.

Hopefully this thread will answer the question for anyone else who follows.