Windows 8 and 8.1 Forums

No boot device found

  1. #1

    No boot device found

    Working on a HP Envy M6 laptop. Getting the "no boot device found" error when booting. Only thing I can access is bios. Its a windows 8 preinstalled machine so I do not know the product key nor have an install or recovery disk.

    I am able to access the drive when hooking up it externally to my win 7 machine ( had to save some files on the drive ).

    Was only able to find a 8.1 install disc so I made a bootable USB to try and do a refresh. Still got device not found. Had to turn on legacy support in the bios. Detects the USB except repair isn't helpful. Tried the refresh and ...yep, hard drive is locked ( imagine because I am in legacy mode ).

    So what do?
    Legacy - hard drive gets locked
    Non legacy - hard drive / usb not detected

    Really stumped on what to do. Don't think I can downgrade to 7 either.

      My System SpecsSystem Spec

  2. #2

    Central IL
    Posts : 3,468
    Linux Mint 17.2

    Means that the hard drive is either not working (ie no power, not installed, or just a dead drive). The other would be a blown IDE/SATA controller on the motherboard.
      My System SpecsSystem Spec

  3. #3

    Quote Originally Posted by Delease View Post
    I am able to access the drive when hooking up it externally to my win 7 machine ( had to save some files on the drive ).
    Welcome to Windows EightForums, Delease.

    I can see you know it isn’t the HD for you tested that by hooking up externally. Did you check the power pins on the lappy to see if it’s getting power? If it is then odds would have it it’s the controller or a component of the controller. Do you see anything that looks as if it fried on the MoBo?
      My System SpecsSystem Spec

  4. #4

    Nothing fried looking/smelling.
    Made a win 8 disc itself instead of USB and was able to get into recovery so far. Doing a chkdsk on the system now. Should take a while ( 3 hrs left )

    Will update
      My System SpecsSystem Spec

  5. #5

    OK. Cool. Thanks for posting that.
      My System SpecsSystem Spec

  6. #6

    Chkdsk finished.
    Got "Selected boot image did not authenticate".

    Running sys diag tests then going to try and refresh from the disc
    Edit: Tried to refresh and got drive is locked. System restore can't find a restore point. Repair is unable to repair the machine.

    This is an absolute mess and apparently I am not alone judging by google searches
      My System SpecsSystem Spec

  7. #7

    A black screen with that message?
      My System SpecsSystem Spec

  8. #8

    Yes when I boot I get the black screen with a blue dos based message in the middle. Tells me to click enter, then shuts down.
      My System SpecsSystem Spec

  9. #9

    Are you still running the diag test? Secure boot may be messed up.
      My System SpecsSystem Spec

  10. #10

    I am really at a loss for words.
    Diag test finished. Mem & Hard drive passed.
    Going to disable secure boot in the bios and see if that helps.
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
No boot device found
Related Threads
I've recently replaced my secondary HDD in HP Pavillion dv7 (primary is SSD@W8.1) and as soon as I booted up computer, I got error "no bootable devices found". The first thing that I tried out was bootable USB with Windows 8.1 whereas I ran "automatic repair" several times, without any luck. ...
My control panel sounds option says that I don't have audio devices installed so I tried troubleshooting it but it says : 50869 but my device manager says this: 50872
hi everyone, ive had this happen twice already on my custom built pc, first time around i was able to access the bios and select the correct sequence for the hdds to read properly. now im running into this issue again after i had previously just did a shutdown of my system with no issues before...
How can I solve Playback & Record device not found in windows' sound? Sound driver status in device manager still has no conflict and Realtek Audio manager can detect only plugged in jack. I have tried to reinstalled audio driver without any conflict but still nothing in windows' sound. If I...
So, I bought a new computer in April, and Windows 8 lasted for about 8 weeks before refusing to start. With the help of another thread here, I managed to get into a dos enviornment and copy my data (about 7700 photos). Who knew that I still remembered xcopy! Anyway that whole sad story is...
Windows 8 unknown device found in Drivers & Hardware
Hi everyone, So first I'll give you basic information about my computer and then I will tell you the rest. First my computer when bought came pre installed with Windows 7. As soon as Windows 8 came out I upgraded to Windows 8. My system is BIOS not UEFI. I have about 3gb ram and 500gb hdd...
Strange network device found in Network & Sharing
Hi all, Does anyone know who I delete network devices from my local network? For some strange reason there is a phone listed even though no mobile phones are connected to it. Just a little worried. Thanks a lot!
Eight Forums Android App Eight Forums IOS App Follow us on Facebook