Windows 8 and 8.1 Forums

File permissions issues

  1. #1

    Posts : 4
    Windows 8 CP

    File permissions issues

    For whatever reason, the default account reports that it is an admin account, but it doesn't always act like it.

    I have 3 SATA drives, each partitioned in 2 (all NTFS), C/D, E/F and G/H. C had Windows 7 installed on it and it was running fine. I tried the CP in Virtualbox when it was released and decided to do a clean install. Imaged my 7 drive elsewhere and booted up 8 from USB. I ran through the installer and created a local account (not the Live/Hotmail/Email option). In User Accounts it reports as Admin in the same way as Windows 7. First thing I did (as always) was to disable UAC and reboot.

    I tried using CMD to disable hibernation with 'powercfg -h off' but it was rejected due to requiring elevated access. Same deal for any Powershell commands. Then I installed WinRAR and tried extracting an existing archive on E, but that failed due to lack of permissions. Navigated to 'Program Files' and tried making a new text file but it wasn't even an option, only 'Folder' was given. Same deal with the AppData folder. Next I installed KMPlayer and tried adding media files from G to a playlist but it was blocked, so I tried changing settings. They changed fine while I had the player opened, but when I restarted it they had reset (the ini file in the program folder wasn't being written to).

    I went back and performed a clean install of 7 on C with the same options as 8 and everything I tried worked. Another format of C and then installed 8 again, same problems. The account says admin but it's acting like a regular user account. That said, I can take control of drives and files if I go through the 'Properties > Security' dialogs, and if I explicitly run programs with 'Run as administrator' then they behave as normal, but I shouldn't have to do this.

    Does 8 have an extra security layer that 7 doesn't? Can anyone else run something like 'powercfg -h off' without being blocked?

    Any ideas? Thanks.

      My System SpecsSystem Spec

  2. #2

    Posts : 7
    Windows 7

    gavin19, I have also noticed similar file permission issues. It seems as if an admin account in Windows 8 doesnt have the same default powers that an admin in Windows 7 does. I am also using a local account with UAC disabled. I was able to get 'powercfg -h off' to run by using an elevated command prompt. One simple way to access that is to right click in the lower left corner where the start screen is accessed. There you get a whole menu of commands like event viewer, device manager, and disk management to name a few.
      My System SpecsSystem Spec

File permissions issues
Related Threads
Yesterday I removed Windows 7 & did a clear install of Windows 8.1 x64. Now whenever I try to save a file on different partition like D,E, etc I get the dialog box that I do not have permissions to save the file to this location even though I am clearly the administrator & I have disabled UAC. All...
Hi, I have two networked PCs. On PC1, I have a program file (.exe) that I want PC2 to be able to access, open and use, but not copy or move from it's location. What would be the best permission settings to adjust on PC1 to protect the file? Thx.
I recently updated two of my computers to W8.1 and have been in awe of the headaches that come with it. One thing that seems to be a public nuisance is having to use a Microsoft Account to have a syncing onedrive folder. This aside I have been trying to get File/Printer Sharing working between a...
I'm having trouble with the environment configuration on my new Win8 machine, I don't remember running into problems like this on 7, but I can't seem to find much useful online.. I have 4 dll files that need to go into the Windows\System32 folder in order for one of our applications to run. This...
Solved file upload issues in General Support
I'm having trouble uploading files. The reason I think this is an operating system is because this happens when I try to upload an attachment to my Yahoo mail, Gmail mail and account. It starts and I get a spinning wheel with no progress. Can someone point me to some things I can try? ...
I've recently got a new laptop with windows 8. I am in the process of trying to upload my cd collection to my computer. Some of my cds are old mix disks that when ripped by windows media player do not have all of the information properly loaded such as artist/album/etc... So I started manually...
File Permissions and Read Only in Network & Sharing
Two user accounts, both administrator level. I have a file in my documents that my wife's account can READ but cannot SAVE. I've gone in through User Accounts and given her account full permissions (full control with all the boxes checked), but it always reverts back to her not being able to save...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook