Windows 8 and 8.1 Forums

Unable to execute files on subst'd drives

  1. #1

    Posts : 12
    Windows 10 Pro 10586

    Unable to execute files on subst'd drives

    As well as my C: drive, I have a large (2Tb) Z: drive on my PC. I then use the "subst" command (using XSubst as the GUI) to create virtual drives pointing to various directories on Z:. For example, P: actually points to Z:\PHOTOGRAPHS, M: points to Z:\MUSIC and O: points to Z:\DOWNLOAD.

    I can do everything to the files in these virtual drives EXCEPT execute them. So I can copy, paste, edit, change permissions, etc, but when I try to "Open" or "Run as Administrator" a .EXE, I get the error message "The specified path does not exist. Check the path and try again."

    The above configuration worked fine under Windows 7, but I can't understand why it doesn't work under 8.1, especially as the error message makes no sense.

    Any help appreciated!

      My System SpecsSystem Spec

  2. #2

    Why are you using subst (Xsubst)? Do you change the drive mapping often? I'm trying to see an advantage to doing this and can't come up with one.

    Wouldn't it be simpler to partition the 2TB drive permanently? That would get rid of the problem you are having I'm sure.

    I did find this via Google: Link Shell Extension

    Q: I have created a symbolic link to an .exe and when I double click on it, I get the following error message:
    The specified path does not exist. Check the path and try again.

    A: Unfortunatley this is a bug in Explorer, and I don't have a clue how to come around this in explorer.
    If you start the symlink to an .exe from a command prompt it works fine, and even third party explorers like SpeedCommander can do this, but explorer seems to have a limitation
    Does anybody know the registry hack to enable this in explorer.exe? Drop me a line.
    I suspect subst drives suffer from the same problem. I can't fid an answer though.
      My System SpecsSystem Spec

  3. #3

    Posts : 12
    Windows 10 Pro 10586

    Thanks for the response. The reason for using Xsubst is that it allows me to effectively partition my hard drive dynamically, whereas if I did it permanently then I would need to decide how much space to give to each partition.

    As I mentioned, it worked fine under Win 7, so it looks as if it's something that Microsoft have broken in 8.1.
      My System SpecsSystem Spec

  4. #4

    Okay, thought it might be something like that, thanks.

    Almost has to be a security change they made in 8. What does the security setting look like for the subst drive (Properties, Security tab)? Maybe do a Take Ownership or use CACLS after setting up the drive to make it work.
      My System SpecsSystem Spec

  5. #5

    Posts : 12
    Windows 10 Pro 10586

    OK. I've spent some time trying to get this problem down to its bare essentials, and this is where I am:

    When using the SUBST command, some executables will not work, giving the error "The specified path does not exist. Check the path, then try again". It is not clear why some executables work and others do not. The error message makes no sense, as the executable file can be renamed, have its permissions changed, etc.

    - I have this issue on two separate Win 8.1 machines.
    - I did not have the problem under Windows 7
    - I can find no difference between the two executables when I look in the "Properties" screen; all permissions, etc are identical
    - Both executables are 32-bit
    - Neither executable has a digital signature
    - Using "Run as administrator" makes no difference

    Create a directory (I'll call it C:\TESTDIR) and use the subst command (I have tried using both XSubst and Visual Subst to do this) to create a drive letter pointing to this directory (I'll call it "K:").

    Download 2 executables [see below] - call one AAA.exe and the other BBB.exe. Place them both in C:\TESTDIR. Use File Explorer (or a Command Window) to navigate to C:\TESTDIR and try to execute both AAA and BBB. Both should work. Then navigate to K:\. Try to execute both AAA and BBB. AAA will work as before, but BBB gives the error message stated at the beginning.

    I wouldn't expect anybody to download any executables that I would upload, but hopefully the following are well respected examples with links to their author's web sites for downloading:

    AAA - I have used KeePass-1.26-Setup.exe, available from SourceForge via the link on Downloads - KeePass

    BBB - I have used xsubstsetup_2_3_22.exe, available as an installer from GTH Main - Downloads

    (Both of these executables are installers, so they can be cancelled on the first screen, where they ask you to choose a language.)
      My System SpecsSystem Spec

  6. #6

    I tried your scenario using Speccy64.exe from Piriform.

    Created C:\Testdir
    Did a subst Z: C:\Testdir
    Ran Z:\speccy64 and it worked
    Opened Windows Explorer, navigated to Z: and double clicked on speccy64.exe
    It worked as expected.

    Next I downloaded KeePass from SourceForge (the installer version). It started correctly from C:\Testdir\KeePass-1.27-Setup.exe and Z:\KeePass-1.27-Setup.exe both.

    I am running Windows 8.1 Pro update 1 on a Lenove IdeaCenter 450, booted from a 250GB SSD.
      My System SpecsSystem Spec

  7. #7

    Posts : 12
    Windows 10 Pro 10586


    Thank you VERY much for trying this out.

    I'm now totally confused, as I have downloaded speccy64.exe and I get the same error message (which you don't) when I try to execute it from the subst'd drive (but not from the "real" drive).

    I thought that perhaps it might be down to the version of Windows (I didn't have Pro), but I bought a new laptop yesterday (Dell XPS 13) which came with 8.1 Pro, and even with a vanilla out-of-the-box installation I am still getting the error!

    There's obviously SOMETHING different between your setup and mine (on all three of my 8.1 machines), but I am really struggling to think what it could be, especially given that the latest is exactly as it arrived.

    The only thing I can possibly think of is that I am only logged on with a local account on all 3 PCs. Are you logged on locally, or with a Microsoft account?

    Any other suggestions very welcome, as I am all out of ideas at this stage!
      My System SpecsSystem Spec

  8. #8

    Lets see:

    I do use a local Administrator level account.
    I have UAC completely disabled via a registry hack so I don't use any of the Metro/Modern stuff at all.
      My System SpecsSystem Spec

  9. #9

    Posts : 12
    Windows 10 Pro 10586


    I'm using a local (Admin) account, I have UAC switched off (although just through the interface, not via the registry) and I don't use any Metro, etc, apps.

    I try to make Win 8.1 look as much like Win 7 as I can :-)

    Actually, the wording of the error on the Win 8.1 Pro machine is slighly different - it says "Windows cannot find 'X:\Speccy64.exe' Make sure you typed the name correctly, and then try again." whereas on my other laptop it had complained about not finding the path. Hmmm.
      My System SpecsSystem Spec

  10. #10

    If you want to try the registry hack:

    Change the following registry key:

    Key: EnableLUA
    Value data: 0
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Unable to execute files on subst'd drives
Related Threads
Hi eighforum, I have trouble with my laptop, This is a win 8 fresh installation(PS. I test with win 7 fresh installation, and the issue es the same) The laptop crash with bluescreen or face screen. I'd appreciate if you could look through my minidump and see if anything can be gleamed. ...
Attempted execute of no execute memory in BSOD Crashes and Debugging
Hello eightforums, I have another recurring issue, this is a fresh install of windows and I am not sure what the problem could be besides hardware. I'd appreciate if you could look through my minidump and see if anything can be gleamed.
After seeing a couple files permanently delete at unseasonable moments, I now at least enabled deletion confirmation messages. The bug is with the HDD I use for storage, the SSD hosting the OS works according to the recycle bin settings. I tried the classic subterfuge of switching these settings...
I have 2 machines connected via my router/hub (wired). One is running Windows 8.1 and the other Windows 7. Previously I had them sharing perfectly until I did a reinstall of Windows 8 (upgraded to Windows 8.1). I get this message on both machines whilst trying to access shared drives (permissions...
35406 Getting this message every time I start up my computer. Really annoying. I tried deleting my appdata/local/temp and that didn't work. The exe is in a different folder (this time it is in s3ic) every time this pops up, but the folder is no where to be found when I look in...
Hello, I recently did a clean install of Windows 8.1 x64. I have a Synology DS213+ NAS server in my LAN. Before doing the clean install (had Windows 8 installed before), all hardware being identical, I could launch setup programs from the NAS volume without any problem. Now, after the clean...
Can somebody help to solve this mystery? I had a Seagate MyBackup 1TB external drive. When it was half full I decided to buy another one, the same Seagate, same model, same 1TB. So I copied the files to the new one and I do backups every week or so for the changes. Today I noticed that the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook