Windows 8 and 8.1 Forums


Unable to execute files on subst'd drives

  1. #11


    Posts : 1
    Windows 8.1


    Hi. I'm totally new to Windows 8, but I'm having the exact same problem:
    I use lots of portable apps, and I use PowerPro to launch them, and I keep all of that in an encrypted TrueCrypt file container.
    So I mount the TrueCrypt volume, and let's say I mount it on X:, then I run
    subst B: X:\ (don't forget the \ or it won't work)
    And then I can configure tons of things (including PowerPro) just using absolute paths. (Come on! Nobody has a 5 1/4'' floppy anyway!). I also use other substs for similar reasons.
    That's been working like that for me for ages in Windows 2000, XP, and 7. Now I'm getting the same problem than WinAte: some programs will launch without a problem from PowerPro, others will give the "The specified path does not exist. Check the path and try again." error.

    I found what seems to be an important clue, and a workaround:
    the subst command (just subst, with no params, to list the substituted drives) when issued from a normal CMD will show something different than from an admin command prompt. So now, I check it in both command prompts and make sure that both have all my substs, and then everything works.

    I believe that that UAC thing is related. Can any of you point me to a good explanation of it (Something more technical than Wikipedia)?

    --
    Wences

      My System SpecsSystem Spec

  2. #12


    Posts : 12
    Windows 10 Pro 10586


    Quote Originally Posted by Ztruker View Post
    Change the following registry key:
    Magic! That seems to have done the job - I've tried it on all 3 of my PCs, and I can now run the executables on subst'd drives that I could not run before.

    Rich - thank you very much for all your help, and for trying out my problem on your PC.

    Like Wences above, I'd love to understand why some executables work while others don't, but at least I can now get on with configuring my new desktop.
    --
    Philip
      My System SpecsSystem Spec

  3. #13


    Has to be due to the security "improvements" in Windows 8

    I had a similar problem with Object Rexx, a programming language from IBM. Once I got to Windows 8, it would not run correctly until I completely disabled UAC with the registry hack.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Unable to execute files on subst'd drives
Related Threads
Hi eighforum, I have trouble with my laptop, This is a win 8 fresh installation(PS. I test with win 7 fresh installation, and the issue es the same) The laptop crash with bluescreen or face screen. I'd appreciate if you could look through my minidump and see if anything can be gleamed. ...
Attempted execute of no execute memory in BSOD Crashes and Debugging
Hello eightforums, I have another recurring issue, this is a fresh install of windows and I am not sure what the problem could be besides hardware. I'd appreciate if you could look through my minidump and see if anything can be gleamed.
After seeing a couple files permanently delete at unseasonable moments, I now at least enabled deletion confirmation messages. The bug is with the HDD I use for storage, the SSD hosting the OS works according to the recycle bin settings. I tried the classic subterfuge of switching these settings...
I have 2 machines connected via my router/hub (wired). One is running Windows 8.1 and the other Windows 7. Previously I had them sharing perfectly until I did a reinstall of Windows 8 (upgraded to Windows 8.1). I get this message on both machines whilst trying to access shared drives (permissions...
35406 Getting this message every time I start up my computer. Really annoying. I tried deleting my appdata/local/temp and that didn't work. The exe is in a different folder (this time it is in s3ic) every time this pops up, but the folder is no where to be found when I look in...
Hello, I recently did a clean install of Windows 8.1 x64. I have a Synology DS213+ NAS server in my LAN. Before doing the clean install (had Windows 8 installed before), all hardware being identical, I could launch setup programs from the NAS volume without any problem. Now, after the clean...
Can somebody help to solve this mystery? I had a Seagate MyBackup 1TB external drive. When it was half full I decided to buy another one, the same Seagate, same model, same 1TB. So I copied the files to the new one and I do backups every week or so for the changes. Today I noticed that the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook