Windows 8 and 8.1 Forums


Icons in folders taking too long to display correctly

  1. #1


    Rio
    Posts : 85
    Triple Boot Win7, Win8.1 and 10

    Icons in folders taking too long to display correctly


    Whenever I open a folder with more than a couple of icons it takes about 10 seconds
    for the icons to appear correctly. Sometimes some icons won't even display the way
    they should even after those 10 seconds, it's just a generic blank icon.

    Is there a way of correcting this?

    My Windows is the 8.1 Pro 32-bit (6.3, build 9600)

    Thx in advance!

      My System SpecsSystem Spec

  2. #2


    Posts : 22,564
    64-bit Windows 10


    Hello Rafael, and welcome to Eight Forums.

    Is this a network folder? If so, it may take a moment for it to sync with the network location.

    If you have Windows set to turn off idle hard drives, then it could be waiting on the hard drive to spin back up.

    Hard Drive - Turn Off Hard Disk After Idle or Never - Windows 7 Help Forums

    Hope this helps,
    Shawn
      My System SpecsSystem Spec

  3. #3


    Germany/Florida
    Posts : 4,514
    Vista and Win7


    It could also be your on-board graphics being a bit slow. How is it when you open a folder with pictures. Are the pics also slow to display.
      My System SpecsSystem Spec

  4. #4


    Rio
    Posts : 85
    Triple Boot Win7, Win8.1 and 10


    Quote Originally Posted by whs View Post
    It could also be your on-board graphics being a bit slow. How is it when you open a folder with pictures. Are the pics also slow to display.
    My onboard graphics is not exactly a GTX but it can play games such as GT Legends with a full grid without any problems. Also I can play Splinter Cell Chaos Theory on medium no problem at all. So I don't know whether it's the onboard graphics or not. But it does take a while to show thumbnails inside folders, as does my GT 430 1Gb on my desktop on Windows 7. Pictures are shown very quickly on this laptop, it's just some icons that will take a little longer to display.

    I'll try disabling the idling hdd thing and see what happens.

    Thank u so much for your responses!!
      My System SpecsSystem Spec

  5. #5


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    This may help:

    Click image for larger version

    or not.
      My System SpecsSystem Spec

  6. #6


    Rio
    Posts : 85
    Triple Boot Win7, Win8.1 and 10


    Quote Originally Posted by David Bailey View Post
    This may help:

    Click image for larger version

    or not.
    It's already like that on my system, that's the default setting, but thanx anyway! ;-)
      My System SpecsSystem Spec

  7. #7


    Gold Coast (Australia)
    Posts : 702
    Windows 8.1 x64


    In your system specs, you have stated 3 GBytes DDR3 Dual Channel memory.
    Is that a typo?


    Edit:

    never mind
      My System SpecsSystem Spec

  8. #8


    Rio
    Posts : 85
    Triple Boot Win7, Win8.1 and 10


    Quote Originally Posted by antspants View Post
    In your system specs, you have stated 3 GBytes DDR3 Dual Channel memory.
    Is that a typo?


    Edit:

    never mind
    It's what CPU-ID says about my memory.
      My System SpecsSystem Spec

  9. #9


    Posts : 2,627
    win8.1.1 enterprise


    system specs show you are duel booting ,does it behave like this in win7 ,also Toshiba support for you laptop ,shows no win8.1pro drivers ,what drivers are you using for your video device ,this could be a driver issue
      My System SpecsSystem Spec

  10. #10


    Germany/Florida
    Posts : 4,514
    Vista and Win7


    Quote Originally Posted by caperjack View Post
    system specs show you are duel booting ,does it behave like this in win7 ,also Toshiba support for you laptop ,shows no win8.1pro drivers ,what drivers are you using for your video device ,this could be a driver issue
    Right, driver problems are often the cause of such problems. But here it is strange that only the icons are singled out and all other video operations seem to be fluent.
      My System SpecsSystem Spec

Icons in folders taking too long to display correctly
Related Threads
Why is windows update taking so long? in Windows Updates & Activation
It's been stuck on "downloading 68 updates(0 KB total, 0% complete)" for like 15-20 minutes now. How do I find out if it's frozen or if it's actually downloading?
Laptop taking a very long time to do updates in Windows Updates & Activation
My laptop started installing updates when I powered down for four hours I have had this message on the screen - keep your PC plugged in until this is done. Installing update 17 of 24..... How long do I leave this or can I power off and try and restart?
I have been using Stardock's IconPackager for a while, and after a lack of updates with that, it has eventually stopped working with most of the main icons within Windows 8.1. I have followed many tutorials and have used RegEdit to change the icons, and have checked them with their 64 bit...
So, I have been running 8.1 pro for some time now. During the last 2 or 3 weeks, I started having a login issue. It loads bios loads windows fine. I get to the login screen, and it seems to take forever to recognize internet connection. Gives me the little "!" over the internet. I put in...
Check Disk taking a long time in Performance & Maintenance
Hi I tried to run Check Disk in W8 but it did not complete saying it could not complete the scan, so I tried to run Chksdk from the CMD prompt, I got a message that could run Chkdsk and repair errors on the next boot, I select Y and the scan started on the next re-boot. It went okay until...
Hi, i was playing a game (The Sims) and i minimized it to check if my downloads were complete but after i clicked on the game to play again it didnt display correctly. the text was fuzzy and all the item boxes were just blue squares. The windows that pop up in the game did not display at all but...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook