I have an Alienware M17xR4, with an Intel 3740QM, 16GB RAM and 1TB Hard disk. I bought it in Feb 2013 and immediately upgraded the OEM Windows 7 to Windows 8. I used Stardock's Startup8 and ModernMix to get an enjoyable Win8 experience for a year.

The windows update for Flash would keep failing to install since mid last year and I was unable to upgrade to Win8.1. So to cut a long story short - after trying Windows Troubleshooter, Disk Cleanup, SFC and DISM I had tried chkdsk in frustration, just to see if there were disc errors. I know now this was a big mistake. Anyways I waited for chkdsk to finish for 5 hours, got bored watching it stuck at 27% and did a hard reset. Incredibly I was able to login just once after that but I got access denied for any file I tried to move/delete. So I rebooted and have not seen my original Win8 installation since.

I then tried to use the repair options from the install disc and decided to "Refresh" my PC - so that my Windows installation would be repaired and my data would be preserved. It seems to have worked EXCEPT - I have not got a clean installation back. What seems to have been done is this -
1) Win8 cleaned out 3rd party software from my installation
2) It then locked my C: drive which has all my data
3) Created a 1.8MB partition, placed boot files there and uses it boot me in to a crippled Win8 environment. I however have no access to the C: drive or my data.

I would have just reinstalled Win8 again instead of ranting here except I have Ubuntu on a USB. For kicks I used it on my laptop. Amazingly while windows couldn't access itself the partition was available easily and intact through Ubuntu!!! I was able to backup my data. Woohoo!

This has me angry. I have checked and the NTFS filesystem on the partition looks fine but the bootloader is apparently gone or hidden behind the partition lockdown. There is absolutely no reason for me to be locked out of the original partition unable to login and access my data. Unless I can do this, I might just say goodbye to Windows. At best I'll run it in a VM under Ubuntu or ArchLinux, since I have a subscription to Office 365.

Can anyone help me get back into my original Win8 installation? Also what will happen if I try to restore back to a restore point created on 10 Mar 2014, prior to all this happening? I'm guessing it won't do much if anything at all since the 3rd party apps have been kicked out.