Windows 8 and 8.1 Forums

(Accidentally) Deleted EFI Partition, can't boot.

  1. #1

    (Accidentally) Deleted EFI Partition, can't boot.

    I recently partitioned my Asus ROG G750JW into 2 main parts: One 300GB for a mackintosh, and one 6** (remaining space) for windows 8. That worked fine, until I tried to format what I thought was random partition with a size of 128MBs. I believe this to be the EFI partition, and you know what that does. I cannot boot to windows 8 or mac, and windows boot manager no longer shows up in BIOS. I have a windows 8 reinstall disk and the hackintosh install disk. When trying to refresh from the windows reinstall disk, I get an error saying that the disk is locked. What I need to know is if there is any way to restore this without erasing my hard drive. I do not have access to a windows computer (I can if I have to, but it wouldn't be ideal), but do have access to a mac. I don't have restore points, even if I did they are on the now one-huge partition, which by the way is listed as MBR format. Thanks in advance, -AJ

      My System SpecsSystem Spec

  2. #2

    Posts : 1,121
    Windows 8.1 x64

    Do you have something you can boot and get into a command prompt for Windows? If so, you may be able to recreate the MSR partition.

    If you can, run Diskpart and list the disks and select the correct one with the install, probably disk 0. Then list the partitions and copy that listing and post it next time.

    lis dis
    sel dis 0
    lis par


    What might be happening is you removed a partition in a sequence which changed the partition number the boot manager is looking for..but just a guess. Restoring it may or may not help the situation now... You may end up having to run a bcdboot command to reset the boot entries for Windows 8.
      My System SpecsSystem Spec

  3. #3

    Thank you for your response Saltgrass,
    Lis Dis returns:
    Disk 0 Online 931 GB
    Disk 1 Online 14 GB
    Disk 2 Online 7663 MB

    sel dis 0 and lis par:
    Partition 1 Primary 931 GB 512 B offset

    I think what has happened is, without the EFI partition, Windows doesn't know where each partition stops and starts. Therefore it's all one big partition, with no stops and starts like there should be. Hopefully the data is still there, but I don't know how to access it. So what can I do now?
      My System SpecsSystem Spec

  4. #4

    Also, I have tried to write partition wizard to a flash drive to restore that partition, but I get a boot error: Reboot and select proper boot device… This is probably due to me writing it on a mac, and the format being different.
      My System SpecsSystem Spec

  5. #5

    Posts : 1,121
    Windows 8.1 x64

    Partition Wizard needs to boot as Legacy. If you have Windows 8 Secure Boot enabled, you will need to change and allow Legacy boots as well as UEFI. But you comment about the Apple situation may also be correct.

    I am not sure what to tell you where to start. But I think you need to boot into something related to Windows, like the install media for Window 8 or 8.1.

    The 128 MB partition is the Microsoft Reserved partition and is usually on all GPT configured hard drives. But it almost sounds like you have removed the GPT configuration info from the drive, although I don't remember if it would even read any partitions, just say it was uninitialized. When you used Disk Management, did the drive show up with an asterisk indicating it was a GPT drive? You can copy the information from a command prompt, just right click and select mark, then highlight and right click again to copy.

    But the first step in trying to recover a system is to have good information about its current status. Partition Wizard (pictures) would help, or even all the info from Diskpart would be very useful.

    You might start thinking about reinstalling, depending on what you can discover about your situation.
      My System SpecsSystem Spec

  6. #6

    After disabling safe boot and enabling launch PXE, etc, I'm still getting the "reboot and select proper boot device" error. I knew that I could mark text in command prompt, but I can't put it anywhere if I can only boot from the install disk, right? I'll keep trying with Partition Wizard, but in the meanwhile; is there any way I can copy the files from my laptop to my Mac via some cable? I have ethernet, and I can order a thunderbolt cable if need be. I doubt I can but I thought it worth mentioning.
      My System SpecsSystem Spec

  7. #7

    Posts : 1,121
    Windows 8.1 x64

    Quote Originally Posted by ajthemacboy View Post
    I'll keep trying with Partition Wizard, but in the meanwhile; is there any way I can copy the files from my laptop to my Mac via some cable? I have ethernet, and I can order a thunderbolt cable if need be. I doubt I can but I thought it worth mentioning.
    You might try a version of Ubuntu that you can boot to and run but not install. I don't know in your situation if it would be able to access the files either.

    You might want to try to find someone with a PC to set up the Partition Wizard bootable version. It is available in a bootable CD, so I assume an Apple could make that using the .ISO

    When you boot into the bios or use the boot device menu, do you see anything that might be bootable listed?
      My System SpecsSystem Spec

  8. #8

    Nothing at all. There isn't even a boot loader listed, like there normally is. One thing I'm about to try is fdisk /mbr. I tried using the mac disc burner to write the iso to a blank CD, with no luck. I'll pursue that too.
      My System SpecsSystem Spec

  9. #9

    Posts : 1,121
    Windows 8.1 x64

    If you do not see anything, that probably means you still have the UEFI only boot enabled. If you had enabled the Legacy boot options, at least the DVD should show up. If you had UEFI capable boot media in the DVD, it should show up as both Legacy and UEFI.

    Look for any CSM entries and enable that and Secure Boot entries and select both Legacy and UEFI. But different bioses handle the settings differently so hard to give specific instructions.
      My System SpecsSystem Spec

  10. #10

    The DVD (Actually a CD) shows up in boot, but when I boot from it I get the 'restart and select proper boot device' error. Windows is almost done writing to a flash drive, then I can use fdisk.
      My System SpecsSystem Spec

Page 1 of 4 123 ... LastLast
(Accidentally) Deleted EFI Partition, can't boot.
Related Threads
Hello guys, I have Accidentally formated partition C and D and now my HD has only 1 partition (1 TB). I had windows 8.1 installed in partition C and i had all my files in my partition D. How can i restore just partition D files? (i have some immportatant stuff in here) For security...
Hello there, I axidently deleted my Fast Boot boot options and when I enable it my laptop restarts and shows the BIOS, without booting into my system(s). However, when I enable CSM boot it gives me option of booting into my systems. I want to restore my Fast Boot options so my laptop boots up...
Misread the drive label and deleted the partition on an USB external 80GB SATA drive. Nothing else has been done to the drive. I did this when using Macrium Reflect Rescue disc. I know I've seen mention of a program that can recover the partition table but I've not found it yet. I tried...
So I was trying to install a program which required I delete a single item from the wow6432node but I accidentally tried to delete the entire folder from the registry. Now my computer starts with a bunch of weird symbols on thee screen and I cannot sign in. I have tried staring while holding...
What should I do to re-install them? Please help.
accidentally deleted administrator, what to do now? in User Accounts and Family Safety
i accidentally changed my admin account into local account now i can't install apps and do anything with it. help please 25767 whenever i try to install some apps it always say.. type an administrators password but then i dont know how to. all i remember was that before i change my account into...
I formatted a HD that had the bootmanager on it. The Win 8 disc can't repair it. I'm also getting a message that my C: drive is locked. Can you help me? PRSNRS
Eight Forums Android App Eight Forums IOS App Follow us on Facebook