Windows 8 and 8.1 Forums

Right click -> open on shortcuts doesn't work

  1. #1

    Posts : 3
    Windows 8.1 Pro x64

    Right click -> open on shortcuts doesn't work

    Hello guys!

    First post here , so, cheers to all!

    Here's my problem:

    I upgraded from Windows 7 Ultimate x64 to Windows 8 Pro x64 and then to 8.1 (too many installed programs for a clean install)

    Now, when I right click a shortcut and do "Open" or "run as administrator" it does nothing. If I double click it, it works fine. Also, if I try to open a cmd from the bottom left context menu it also doesn't work. I've no problems though to do "open" or "run as administrator" on the actual executable files, the problem is the shortcuts. Obviously there's something in the registry that needs fixing, but I've no idea what. I've tried all the usuals, sfc scanning, ccleaner, etc, but no luck. I tried with shellexview to check what is registered where in the context menu, but I didn't find that very helpful either. The same happens in safe mode too.

    Any idea guys? Plz help!





    I did assoc .lnk at cmd and returned "lnkfle" and then I did ftype lnkfile and returned that nothing is associated with this. Dunno if that's how it should be in 8, but that's the same winxp returns.
    Last edited by vultureg7; 09 Mar 2014 at 07:17.

      My System SpecsSystem Spec

  2. #2

    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center

    Maybe this will help:

    Run as Administrator - Add or Remove from Context Menu in Windows 7 - Windows 7 Help Forums

    or, run:

    Dism /Online /Cleanup-Image /RestoreHealth

    in an adminisrtator command prompt.
    Then run sfc again.
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8.1 Pro x64

    ok, I'll try that and report back!


    Tried both things above, but sadly, they didn't fix anything.
    SFC again, found no problem.

    Also tried to create a new user and see what happens under that profile, but that didn't help either.
    Last edited by vultureg7; 09 Mar 2014 at 07:49.
      My System SpecsSystem Spec

Right click -> open on shortcuts doesn't work
Related Threads
Ok so, today I tried to edit my hosts file but when I tried to save it premission was denied. I had to open notepad as admin and only then was able to save it. Is there a way to not have to do that ? if I don't care much about security ? I have an anti-virus and I'm the only user of my PC, so as...
I have Windows 8.1 and on my desktop are several PNG files and shortcuts. When I double click on any of them the program that opens is Directory Opus (I use this instead of Windows Explorer). I checked the defaults and it is NOT Directory Opus. Can anyone help me or point me in the right...
I installed the latest upgrade to 8.1, now when I right-click a tile, no menu, it just puts a check in the tile. Where's the resize, etc menu?
First off I hope I have this posted in the right place. And I tried searching the forum for similar problems but didn't find any like mine. Found a lot of 8.1 related problems with the desk top but I don't think I found any exactly like my problem. My problem is ever since I installed windows...
Hi everyone, I am using a Wacom Cintiq Companion and just upgraded to Windows 8.1. After the upgrade my right-click stopped working and when I try to right-click it freezes my left click so I have to restart. Any help would be greatly appreciated! Thanks, Jack
Hello there. The title says it all. I used to open music files on double click with the Music App installed in Windows. I liked that. But now it doesn't do that anymore, it just shows me empty crap when I'm offline and doesn't play automatically anymore. Why? They changed something after an...
Open Apps but it's doesn't work in Software and Apps
Hi there, I install the "cut the rope" app but when I click on it, it's close it:cry:
Eight Forums Android App Eight Forums IOS App Follow us on Facebook