Windows 8 and 8.1 Forums

Win8.1 disk manager having trouble formatting USB drive

  1. #1

    Win8.1 disk manager having trouble formatting USB drive

    Win8.1 seems to have problems with an old Iomega external hard disk. The drive is SATA and the Iomega casing adds a USB connection with one cable for data and the other for extra power if required.

    In the past I had totally reformated the Iomega drive and got rid of the DVD ROM emulation partition etc. But trying to repartition or format it with Disk Manager is a nightmare. It has been formatting for an hour so far. I also tried booting from a Linux live CD and that partitioned the drive easy peasy. So why has MS got a problem?

      My System SpecsSystem Spec

  2. #2

    Posts : 1,360
    Windows 8.1 Enterprise

    I have found over the years external USB drives to have a large number of problems with communicating to Windows. The drive controller housed within the external enclosure does not last very long, even the newest versions. More often than not I find myself disassembling the hardware to extract the drive itself, which I can then connect directly to IDE or Sata.

    If this drive uses USB 1.1 even a quick format could take some time. Luckily things like Linux exist as a way to help alleviate the burden from Windows.
      My System SpecsSystem Spec

  3. #3

    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit

    If it had a non standard proprietary format it could take a long time to reformat, especially if its a high capacity drive. For me drive enclosures that rely solely on the USB port(s) for power can be problematic. Especially enclosures with 3.5 inch form factor drives. Although those enclosures usually come with an external power pack.
      My System SpecsSystem Spec

Win8.1 disk manager having trouble formatting USB drive
Related Threads
Hello I have a HDD 750G with 2 partitions NTFS with data. used externally in a USB3 box connected to my windows 8.1 asus laptop. No idea what I do, I always use 'eject' before disconnecting this HDD, but now I see that with diskpart : DISKPART> list disk
Messed up formatting new drive in Drivers & Hardware
I installed a WD Black 4Tb internal drive and when asked, selected to initialise and format it as GPT. Then I created three simple volumes and all was well. Then I made the big mistake of deciding I didn't want that and tried to install it again as an MBR drive. I did something wrong somewhere as...
I have found the solution, it is standardly unmounted (but i made it mount with ''partition found and mount, but now im dependable on that program for the hard drive to be mounted, so how do i make it like a normal hard drive?? and how do i format it so that its like a normal hard drive)now so the...
Solved Trouble imaging or cloning disk in Installation & Setup
I'm preparing for some extensive travel in a very remote area, and I would like to fully backup my HD (not just back up the files) before going, because if something happens to my computer along the way, it would be impossible to re-download software. First, I tried to use the built-in 'system...
Solved Having Trouble With DVD-RW Drive in Drivers & Hardware
Hello, good people. I'm new to these forums and Windows 8, and I'm glad there are kind souls out there to help. :D Yuh see, I bought this new laptop, a Toshiba Satellite P845t-S4310. There's a description of the laptop here - the laptop comes with a "DVD-SuperMulti drive (+/-R double layer)" and...
When I try to delete partitions to create a GPT partition on my 60GB Team Xtreem S1 SSD, it creates the necessary partitions and when I try to format or continue installation, it always gives error. (Booted with UEFI option) When I refresh the physical disk list, SSD drive disappears from the list...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook