Windows 8 and 8.1 Forums

Problem with StorageSpace and Bitlocker

  1. #1

    Posts : 1
    Windows 8.1 x64 Pro

    Problem with StorageSpace and Bitlocker

    I had a StorageSpace (resiliency by Parity) under Windows 8.1, that was to small (15 TB - 9.4 TB were used for photos (CR2 and PSD), old images and a lot of virtual machines). On the drive 14.1 TB were used incl. parity. I tried to enlarge it, but the Manager for StoragePools and -StorageSpaces wrote, that the new size (20TB) is invalid. Normally it should be possible to resize the StorageSpace up to 63 TB.
    Click image for larger version
    So I tried with Powershell
    Get-VirtualDisk | ? {$_.FriendlyName - eq "Data"} | Resize-VirtualDisk -Size 50TB
    I choose to enlarge it so extreme, so I might not need to enlarge it ever again.
    On my litte test szenario (enlarging a StorageSpace from 70 to 140 GB on the same StoragePool also the ResiliencySetting as parity and also encrypted with Bitlocker) it worked fine. After reboot of the system I had to enlarge the drive at disk manager and I had no problem to use the encrypted data.
    But on the real StorageSpace I have trouble: My system told me after I tried to unlock the StorageSpace, that it has to go on with encryption (30% (it means 15 TB of 50TB?)). But when I tried to go on I got a message, that the device is not ready.
    Click image for larger version
    I set up a new StorageSpace on a differnt StoragePool with the size of 60TB (there is no physical disk large enough to receive the 50TB StorageSpace).
    I tried
    repair-bde D: E: -rp "XX-XX-XX" -LogFile log.txt -Force
    but of course after 1% my drive with the StoragePool was full. I planned to check the recovered data, but the Drive E: (the new StorageSpace) was only RAW. My intention was to check if the command recovered any data, but I had no success.

    Now to my questions:
    1. Is there any chance to recover any data?
    2. Is it really necessary to have 50TB of free space to decrypt 9.4 TB of data?
    3. Is there a way to check if there are data to recover without having 50TB of free space?

    I do not need all the data back. Most of it is really crap. But it would be nice to get al least the last pictures back (80 GB), because I have no JPEGs of them in my backup.

    Update: I tried "repair-bde" again just for a short time (until the target was about 200 GB large) and tried: "check e: /f". Some data were found, but the drive was still RAW so I could not enter the drive. I tried the demo of GetDataBack for NTFS and could see some pictures - but older ones.
    Last edited by ThePaintedCow; 09 Feb 2014 at 15:11. Reason: Integration

      My System SpecsSystem Spec

Problem with StorageSpace and Bitlocker
Related Threads
Hi all, I really hope someone can help me. Basically the problem is my external drive is encrypted with bitlocker it asks me to unlock by entering a 48 digit key or load key from flash drive, the drive is partitioned in 3 and all the drives come up with a gold padlock. The story of what...
Please, anyone know how to fix it. I would appreciate your help! 52675
I turned on Bitlocker on three new Windows 8.1 laptops and saved the 48-digit recovery keys and associated identifiers, but I forgot to indicate which laptops they are associated with. Is there any way to find the identifiers/recovery keys on my laptops so I can document this? Or do I have to...
bitlocker HELP in System Security
i had 2 partitions of my 1TB External HDD encrypted with bitlocker, took backup of my laptop on it (including recovery keys backup files). formated my laptop reinstalled windows and now password works fine on one of the external HDD partition but on the other partition it is not accepting it and...
Hello, i hope everybody is okay . i bought dell venue pro 8 tablet , with windows 8.1 installed on it , and because some problem in dealing with win8.1, i turned off the bitlocker and formatted the whole devise. after that i boot from USB flash , but the touch screen not respond ! so i...
Problem enabling Bitlocker in System Security
Hi guys. When I want to turn on BitLocker on C drive (for some reason I can't do it on other drives) I get this message: 23332 What should I do in order to enable BitLocker for not only C drive, but all of my partitions? And can someone also tell me which encryption is BitLocker using?
Bitlocker in System Security
Hey! I activated Bitlocker for my Operating system drive on a Windows 8 machine. But when starting the process I only can back up the recovery key. I have no dialog to choose how to unlock the drive. Thus even though Bitlocker is running, the PC can be turned and windows can be accessed by common...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook