Windows 8 and 8.1 Forums


Partitions corrupt, cant boot

  1. #1


    Posts : 6
    Win 8.1 / Kali

    Partitions corrupt, cant boot


    Hello all,
    I recently thought it would be a good idea to install Kali on a second partition of my laptop as I am trying to learn network security / pen testing.
    Everything went fine at beginning, boot onto the live USB and install the thing. After it is all installed (including GRUB bootloader) I can no longer boot windows, no worries though, this is a common thing and a seemingly easy fix.
    I cant remember teh exact solution, but it was using testDisk and fixing the MBR.

    After doing this, I restart and can no longer boot into either Kali or Win 8.
    I get an
    "An operating system wasn't found. try disconnecting any drives that dont contain an operating system.
    Press Ctrl+Alt+Del to restart"

    I have tried booting onto a recovery drive, and running startup repair. This did not work (get windows was unable to repair..."
    I have tried bootrec /fixmbr bootrec /fixboot bootrec /fixbcd bootrec /scanos
    the last to return that 0 windows installs were found.
    I have tried Boot-repair-disk which did not work, but seems to have gathered some valuable info:
    paste.ubuntu.com/6829829
    paste.ubuntu.com/6829838

    I have a debian (Kali) live USB that I can boot into and connect to internet with, and a working win 8 recovery USB.

    its fine if I lose the kali partition with repairs, but would hate to loose my windows as I have a ton of school/work things on there and it would be a huge pain to have to backup/restore those first.

    Also, I have 2 different hardrives, a 1tb internal HDD that came with laptop (home of Kali), and a kingston SSD that houses my windows 8

    windows recovery and live usb are on 2 different USBs.
    The SSD that houses my windows partition is easily removable, the internal HDD is not.

    If you need more info, please let me know.

      My System SpecsSystem Spec

  2. #2


    Posts : 2,130
    Windows 8.0 x64


    By default W8 uses GPT partitions, not the old MBR type. Fixmbr will blindly write an MBR to the first sector on the disk. That is likely the "corruption" the system sees. My inclination, if you don't have a system image you can restore, would be to get Partition Wizard ISO freeware and burn a boot disc. Boot it and see if it will repair the GPT partitions.

    There's always the chance another poster has been in this same situation. In that case it may be advisable to wait a bit. See if that person chimes in.

    Also check grub. Often it saves the "MBR" sector. Perhaps it has an "undo" mechanism which may restore that sector of GPT info.
      My System SpecsSystem Spec

  3. #3


    Posts : 1,360
    Windows 8.1 Enterprise


    +1 for Partition Wizard. It's a very handy tool to have.
      My System SpecsSystem Spec

  4. #4


    Posts : 1,121
    Windows 8.1 x64


    As MilesAhead mentions, the Windows 8 install appears to have been in the UEFI configuration. I cannot really decipher the listing you attached, but it looks as though the other install added a special MBR to boot Linux in that configuration, and perhaps through your recovery attempts, the boot was reset.

    So I will just ask a couple of simple questions. If you boot and open the Boot Device menu, what options to you show? While installing the other OS, did you make any changes to the bios which might effect being able to boot to UEFI or Legacy or both?
      My System SpecsSystem Spec

  5. #5


    Posts : 6
    Win 8.1 / Kali


    Hello,
    Using partition wizard I was able to restore my "lost" partitions which contained windows.
    In response to Saltgrass, the options are the same as they were prior to linux install (UEFI and Legacy BIOS)

    When I boot using UEFI and windows boot manager set at top of boot list, I get an error 0xc000025
    Autorepair startup seems to not be fixing the problem as it hangs at attempting repairs for quite some time.

    bootrec /scanos now shows my windows installation on D:\Windows
    bootrec /FixBoot returns element not found
    bootrec /RebuildBcd works until the prompt to add my OS to boot list, once I hit "Y", it returns element not found.

    Am now running chkdsk on my drive.
      My System SpecsSystem Spec

  6. #6


    Posts : 6
    Win 8.1 / Kali


    More progress:
    After running chkdsk and whatnot, I now get a more different error:
    File: \EFI\Microsoft\Boot\BCD
    Error code: 0xc000000f
      My System SpecsSystem Spec

  7. #7


    Posts : 6
    Win 8.1 / Kali


    Quote Originally Posted by SteamGamer View Post
    Ubuntu can also run virtualbox

    pull up terminal ctrl + alt + T

    sudo apt-get install virtualbox
    I can only boot from kali live usb atm, I want to get windows partition working properly before fixing or installing linux again.
    I will probably end up just doing this on a different laptop.
      My System SpecsSystem Spec

  8. #8


    Posts : 6
    Win 8.1 / Kali
      My System SpecsSystem Spec

  9. #9


    Posts : 2,130
    Windows 8.0 x64


    Thanks for posting the solution.
      My System SpecsSystem Spec

Partitions corrupt, cant boot
Related Threads
Hi, I used Acronis to delete all partitions on my Surface Pro. So there is no recovery, C drive, nothing at all. Just a blank SSD drive without any partitions. Now the Surface Pro refuses to boot to any of my USB sticks so I can clean install an OS like I wanted to do. I've verified both of...
Hello there, I would really appreciate some advice as I have messed up my computer I need to work on! :(:cry: Basically, I had a freeven pro virus which I have identified by some malware software and I have deleted the registry folders where my several viruses were located. In the process I...
Corrupt Boot Problem in General Support
I'll try to keep this short as possible. I bought parts to build a new PC. It has an SSD so it'll boot fast, and boot fast it did. Unfortunately, something happened a few days later (boot got corrupt someway or another) and I got this message. 48042 So I go about my way to restore Windows....
I have a very peculiar issue; after using various disk imaging tools such as Macrium and Paragon, my boot partitions seem to be strangely corrupted. The effects of this corruption are: 1) Plain-text boot menu instead of the new graphical boot menu, 2) Long delays before the boot menu is shown,...
I can not boot my Toshiba laptop Windows 8.1 computer after I was attempting to resize partitions. I got in over my head. Now I'm stuck and cannot boot. I believe the problem is I somehow created a second copy of my EFI partition. Now I have two "system" partitions of the same size. Cannot...
hi.. i have one 750GB hard disk with 8 partition. i installed windows 7 in first partition and windows 8 in second partition. i want to hide windows 8 drive when i boot in windows 7 and hide windows 7 drive when i boot in windows 8. with NeoGrub tools in EasyBCD can do this, but i dont know how...
Hi, I would like to ask for advice. I have W8,W7,Wxp working well in multiboot. But i have W8 instaled in C:but it is the 2nd partition.How can i move it to first partition ?W7 and wxp are probably on the 1st D: partition. is there any solution ? 14312 thank you for your ideas o.J.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook